• May 26, 2018, 05:07:31 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Installing OS X Drivers [version 4.0.0.10]  (Read 45646 times)

gniknalu

  • Level 1 Member
  • *
  • Posts: 14
Installing OS X Drivers [version 4.0.0.10]
« on: June 17, 2010, 12:51:34 PM »

When I attempt to install the OS X driver - the installation completes with errors:

Quote
"System extension cannot be used
The sytem extension "/System/Library/Extensions/AtherosOtusMac.kext" was installed improperly and cannot be used. Please try reinstalling it, or contact the product's vendor for an update."

I get the same error whenever I insert the DWA-160 in a USB slot.

The DWA-160 utility is in the correct place but can't run because, as I mentioned, when you insert the DWA-160, you get the error.

Running Mac OS X 10.6.3 (Darwin 10.3.0) non 64 bit with Intel Core Duo.
Logged

arterio

  • Level 1 Member
  • *
  • Posts: 2
Re: Installing OS X Drivers [version 4.0.0.10]
« Reply #1 on: June 20, 2010, 12:22:17 PM »

I had this problem with the drivers on 10.6.x as well. My Mac running 10.5.8 however uses the drivers just fine. I think it's a compatability issue with 10.6.x. Hopefully they update the drivers soon.
Logged

csixty4

  • Level 1 Member
  • *
  • Posts: 1
Re: Installing OS X Drivers [version 4.0.0.10]
« Reply #2 on: September 08, 2010, 09:05:11 PM »

Preliminary instructions. Pretty sure I covered all the steps here.

To get the drivers installed under Snow Leopard:

1. Download the drivers from the D-Link website and mount the DMG file so it shows up like a drive on your desktop.

2. In that "drive" is a file named "D-Link DWA-160 Install.pkg". The icon is a cardboard box and you probably wont see the .pkg extension. Drag this file to your desktop and close the Finder window.

3. Right-click (ctrl-click) on the package file on your desktop and pick "Show Package Contents". This will open the pkg in a Finder window.

4. Open the "Contents" directory. Open the "Resources" directory.
 
5. Right-click (ctrl-click) on the "postflight" program. Choose "Open With" then "Other". In the dialog that pops up, scroll down to TextEdit. Select TextEdit and click Open.

6. You'll get a dialog saying "postflight" is a Unix application downloaded from the Internet. Click Open.

7. Change the first line from:

#!bin/sh

to

#!/bin/sh

8. Save the file and quit TextEdit.

9. Run the installer package from the desktop. You'll still get the kext warning, but you can ignore it (truthfully, you always could). But, this time the installer will complete and make you reboot.

10. When your computer comes back up, the DWA-160 utility will load but it wont detect any network cards.

11. Open a terminal. Type:

sudo kextutil /System/Library/Extensions/AtherosOtusMac.kext

(hit return)

12. The DWA-160 utility will spring to life. Go through the normal setup steps of opening Network preferences and fiddling with everything.

13. After you've played with your new toy a little bit, go back to that terminal window and type:

sudo touch /System/Library/Extensions

(hit return)

14. Your drivers should now load every time you reboot.
Logged

vim

  • Level 1 Member
  • *
  • Posts: 1
Re: Installing OS X Drivers [version 4.0.0.10]
« Reply #3 on: October 30, 2010, 08:10:49 AM »

csixty4,

tried your recommended steps. The wireless LAN utility is coming up but doesn´t recognize the network adapter.

MacOS 10.6.4, Build 10F569
DWA-160 H/W Ver. A2 F/W/Ver: v1.50(E)

Any ideas?
Logged

gniknalu

  • Level 1 Member
  • *
  • Posts: 14
Re: Installing OS X Drivers [version 4.0.0.10]
« Reply #4 on: November 06, 2010, 07:06:05 AM »

It worked csixty4! Thanks!

The only part of your instructions that I would amend is Step 3. Copy the package TO you desktop (so it won't be read-only), then continue.

Otherwise THANKS! I'm using the interface right now - SUPER!
Logged

scottwhitty

  • Level 1 Member
  • *
  • Posts: 1
Re: Installing OS X Drivers [version 4.0.0.10]
« Reply #5 on: April 17, 2012, 10:49:11 AM »

CSixty4

Thanks so much, your steps for the DWA-160 worked on Dell D630, 10.6.3. Your steps were perfect.

My thanks, scott
Logged