• September 19, 2019, 10:10:54 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Is it just me or is this the worst router you've ever used?  (Read 3429 times)

alphs

  • Level 1 Member
  • *
  • Posts: 1
Is it just me or is this the worst router you've ever used?
« on: April 28, 2010, 10:19:31 AM »

Coming from two old TrendNet routers, some other D-Link, a plain WRT54G, and a WRT54GL running Tomato (by far the most solid), this is the worst router that I've ever used.

The TrendNet routers and the old D-Link would need a reset once every week or two weeks. The WRT54G would need a reset every few months or longer, and I don't recall ever resetting the WRT54GL. But this piece of **** disconnects me 10-20 times in the span of a few hours. I'm at my parents house trying to fix this for them. Tried resetting it, played around with the settings, and downgraded the firmware to no avail. I feel bad for having bought this for them.

What a piece of ****. Last D-Link product I'll ever buy.
« Last Edit: April 28, 2010, 10:21:10 AM by alphs »
Logged

zkhaial

  • Level 1 Member
  • *
  • Posts: 8
Re: Is it just me or is this the worst router you've ever used?
« Reply #1 on: May 21, 2010, 02:31:00 PM »

I feel the same way - I think i am gona get off the DLINK stuff. for my next upgrade.
Logged

cloon

  • Level 2 Member
  • **
  • Posts: 50
Re: Is it just me or is this the worst router you've ever used?
« Reply #2 on: May 21, 2010, 04:00:16 PM »

Sadly I agree...   I now have less problem with it but Im scared each time I need to change some settings...  This is the last dlink router I will buy but I did buy some usb dlink access point and they are working fine so far...   


cloon_
Logged