• April 01, 2020, 11:40:45 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DCS920: changing admin password  (Read 20378 times)

Booey

  • Level 1 Member
  • *
  • Posts: 2
DCS920: changing admin password
« on: May 16, 2010, 06:17:29 PM »

Hi, Im having some problems changing my admin password on my DCS920

I know the default login is Login: admin / Password: "blank"

So I go into maintence, and there's an option to change the password.

it lists:

old password
newpassword
confirm

So I leave the old password blank

and type in my new password in the following 2 spaces. I click apply and a window pops up asking me to enter username and password. I just enter admin and leave the password blank. I hit ok, and everything seems to update ok. So i log out, and try to log back in.

A window pops up asking me for my password. I type in admin for my username, and my new password, and it wont work

I type leaving the username blank, and type in new password... WONT WORK

I type admin, and new password again.. WONT WORK

I try password with first letter capital.. WONT WORK

I try password with ALL CAPS... WONT WORK..

Basically it wont let me log in as admin anymore. I figure I may have typed the password wrong the first time so I reset the camera and try the process again.. SAME PROBLEM.

Am I doing something wrong in changing my password ?

I dont wanna leave my default admin login as admin/"blank" , but when I try and change the password, it wont let me log in again as admin.

Anyone else had this happen to them ?
Logged

Booey

  • Level 1 Member
  • *
  • Posts: 2
Re: DCS920: changing admin password
« Reply #1 on: May 16, 2010, 06:34:53 PM »

hey guys. I just wanted to give you an updated. I figured out the problem. I changed the password using a DIFFERENT password than the one i originally choose, and it worked... updated perfectly.

I thought maybe i was losing my mind, and that the camera didnt like my first password that i originally choose, so I resetted the camera again, and changed the admin password again, this time choosing the FIRST originaly password I had problems with.. and sure enough.. i came across the SAME problem.

I pushed the reset button, and then changed the admin password to ANOTHER password.. and.... IT WORKED...

just to make sure I REALLY wasnt losing my mind.. i tried it AGAIN with the first password.. and SURE ENOUGH... i came across the SAME problem..

So Ive come to the conclusion that maybe the camera glitches out when I so happen to use that one password..

very wierd...
Logged

Mackerel

  • Level 3 Member
  • ***
  • Posts: 348
Re: DCS920: changing admin password
« Reply #2 on: May 17, 2010, 12:15:25 AM »

Did you use (single or double) quotes, or unprintables in the password? If so, it just means the code (firmware) has not been tested correctly. Hackers use something similar when doing SQL injections.

If not, then it could be a protected word or some lingering test-word for the firmware...
There could be so many reasons specific codes/words are not accepted or maybe mishandled...

At least you found the source of the problem. Excellent.

If you want to, you can remove this thread, but if you want to 'inform' the D-Link people on this issue, then by all means leave it in...
Logged

marks2811

  • Level 1 Member
  • *
  • Posts: 1
Re: DCS920: changing admin password
« Reply #3 on: January 18, 2011, 06:50:07 AM »

I had the same problem. Turns out the password is limited to 8 characters (well... at least if you change it via the web page interface).

After restoring to default twice, I noticed it stopped echoing my input as dots after eight characters so I changed the password to an eight-character one and now can get back in!

I commented to D-Link's support doc on this in hopes they'll change the FAQ.
Logged

enidone

  • Level 1 Member
  • *
  • Posts: 5
Re: DCS920: changing admin password
« Reply #4 on: March 20, 2011, 01:23:35 PM »

I changed my password just this morning, on initial setup. I was prepared for a hassle but it didn't come.

I noticed the eight-character limitation but in my case it simply wouldn't take a longer password. Sounds like I had it easy!

Agreed that the password parameters should be documented. On the whole I'm pretty impressed with the D-Link documentation but as with anything there's room for improvement. Just glad they got someone fluent in English to write it.  :)

Support for strong passwords doesn't seem to be available out of the box in a lot of cases, it seems: I had someone at Vizio tell me yesterday that all-numeric passwords were "strong." Geez.
Logged