• October 15, 2019, 07:54:54 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: 1 [2]

Author Topic: DNS-323 Not showing up under Shared In Mac  (Read 17805 times)

jaypeecee

  • Guest
Re: DNS-323 Not showing up under Shared In Mac
« Reply #15 on: July 30, 2010, 08:43:03 AM »

The Bonjour package is available via the link in this thread:

http://forums.dlink.com/index.php?topic=14131.0

Works like a champ on firmware 1.09 with OSX 10.6.x using the default SMB configuration.
Logged

47th_ronin

  • Level 2 Member
  • **
  • Posts: 55
Re: DNS-323 Not showing up under Shared In Mac
« Reply #16 on: August 20, 2010, 03:58:12 AM »

hi,

i have been using dns-323 for nearly a year now. overall i'm very pleased with it. got ssh ja transmission daemons working. not too noisy and just the right size to stash away in some shelf corner.
however, i have had some minor problems in the past and some major problems now.
1. sometimes copying of large files to dns-323 failed. it happened twice or so with some osx error messages which i have forgotten already, i used ftp instead and everything went fine. never had a problem reading files from dns-323. used only samba.
2. two days ago i was watching a movie from dns-323 on my imac. the playback froze, after a few seconds mounted share (Volume_1) disappeared from desktop and dns-323 disappeared from finder windows. i pinged nas' ip-address and got replies. web interface for configuration works fine. transmission daemon's web interface works fine. transmission daemon itself works fine. twonkymedia works fine. login over ssh works fine. login and file transfer over ftp works fine. when logged in over ssh i can see that samba daemon works. i can stop, start and restart it, no error messages appear. i installed bonjour on dns-323. nas reappeared in finder, both as bonjour and samba servers. i can connect to nas entering username and password and i see Volume_1 on both servers. when i try to open this share i get error message saying 'the operation can't be completed because the original item for Volume_1 can't be found.'
last major change in my setup was imac's upgrade from 10.5.8 to 10.6.4 but that happened some weeks ago. i get the same behaviour from 10.4.11 powermac and winxp laptop. dns-323's firmware is 1.08, funplug is maybe six months old (can't remember the version and don't know how to look it up). transmission daemon version 2.0 (10784).
so, considering i'm not too familiar with linux, where should i start looking?

update: when i create new share (for user or group, r/w or full access), the new share appears in finder, i can connect to dns-323 with correct credentials and i get exactly the same error message.
« Last Edit: August 21, 2010, 01:06:52 PM by 47th_ronin »
Logged

47th_ronin

  • Level 2 Member
  • **
  • Posts: 55
Re: DNS-323 Not showing up under Shared In Mac
« Reply #17 on: September 13, 2010, 09:38:31 AM »

so, today i finally got around to finish backing up my dns-323 and did factory reset. and guess what? absolutely nothing changed except for ip address and users got wiped. no access over samba, nfs, bonjour, not on windows or osx machines. ftp and transmission working fine as previously. so this sorry piece of nas (network attached s?it) is taking low trajectory..
Logged

dosborne

  • Level 5 Member
  • *****
  • Posts: 598
Re: DNS-323 Not showing up under Shared In Mac
« Reply #18 on: September 13, 2010, 09:55:52 AM »

So basically, you got some error message you can't remember, loaded a bunch of software but you don't know what or if it is up to date, and you are blaming the NAS for being a piece of sh?t ??

Maybe you should try setting it up as it was designed to be run and see if it works poperly.
Logged
3 x DNS-323 with 2 x 2TB WD Drives each for a total of 12 TB Storage and Backup. Running DLink Firmware v1.08 and Fonz Fun Plug (FFP) v0.5 for improved software support.

47th_ronin

  • Level 2 Member
  • **
  • Posts: 55
Re: DNS-323 Not showing up under Shared In Mac
« Reply #19 on: September 13, 2010, 10:25:29 AM »

aaaaaaaaahhhh, a response! not much reading my first post, but still.

the problem is that dns-323's samba share disappeared without any tinkering fom my part (if it ain't broke, don't fix it, yes?). i was watching a movie at the time. transmission and ssh daemons were installed months ago and were running just fine, just as was twonkymedia server. osx upgrade from leopard to snow leopard happened weeks ago without any change in behaviour at the time. and i do remember the error message when trying to access samba share, i even wrote it down for everyone to see.

copying large files to dns-323 over samba turned out to be well known issue since fw 1.04, resurfacing now and then with later firmwares. bonjour and nfs packages are provided by d-link, complete with instructions for install and setup.

so yes, basically, i'm new to linux and taking it slowly, but i'm not actually stupid, if that was the hint.
Logged

dosborne

  • Level 5 Member
  • *****
  • Posts: 598
Re: DNS-323 Not showing up under Shared In Mac
« Reply #20 on: September 13, 2010, 11:50:18 AM »

My suggestion again is to set it up as it was designed to be run, remove the third party hacks and see if it works.

In regards to my "hint", I was simply suggesting there are better ways to ask for help with an issue than calling the product sh?t :)
« Last Edit: September 13, 2010, 11:54:40 AM by dosborne »
Logged
3 x DNS-323 with 2 x 2TB WD Drives each for a total of 12 TB Storage and Backup. Running DLink Firmware v1.08 and Fonz Fun Plug (FFP) v0.5 for improved software support.

47th_ronin

  • Level 2 Member
  • **
  • Posts: 55
Re: DNS-323 Not showing up under Shared In Mac
« Reply #21 on: September 21, 2010, 12:02:26 AM »

a bit of development in this situation:
finally i found myself some time to tinker a bit with this problematic nas (yes, i overreacted somewhat and thus saved it from destruction). what i did: i logged on via ftp and renamed fun.plug file. i wanted to delete funplug altogether, but i had no permissions to do it. then i restarted nas. so, the result is that funplug, transmission, twonky and ssh (the three started by funplug) stopped working. samba share reappeared on my imac desktop and seems to be working fine. no problems with permissions, no anomalies (at least not yet).
is there any difference restoring factory defaults by web interface and by hardware button? i need to clean up all funplug related and start over (this time i know better, what i need and what i don't).
Logged

lookingforinfo

  • Guest
Re: DNS-323 Not showing up under Shared In Mac
« Reply #22 on: September 21, 2010, 08:40:32 AM »

I believe there as a difference.  First you need to record ALL your current settings on the NAS.  You should be able to use the Grab utility, although I have not tried it.  If you are at FW 1.08, you should use the GUI interface to go to TOOLS/SYSTEM and in the Defaults section, select 'Restore'.  If you are not at 1.08, I think I would upgrade first.

After the system reboots you can connect as you did when you first purchased the system.  There is no password for the admin user.  Enter the same Workgroup and users you had previously.  You should be good to go at this point.  Personally, I like to sequentially restart the NAS using the TOOLS / SYSTEM / RESTART option, and then restart the Mac.  I feel this ensures that there are on old settings that could possible cause an issue.

Peace
Logged

47th_ronin

  • Level 2 Member
  • **
  • Posts: 55
Re: DNS-323 Not showing up under Shared In Mac
« Reply #23 on: September 21, 2010, 10:27:12 AM »

i renamed fun_plug file again to it's correct name. everything works (twonky, transmission, ssh, and samba) but root password got destroyed somehow along the way. this is really getting interesting.

edit: and samba stopped working again.. i'll update this post after i've restored defaults and reinstalled fun_plug 0.5 with transmission, twonki and ssh again.
« Last Edit: September 23, 2010, 01:23:35 AM by 47th_ronin »
Logged
Pages: 1 [2]