• July 18, 2019, 10:47:26 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DSM 520 freezes Rhapsody with new PC & router  (Read 3535 times)

johncoskey

  • Level 1 Member
  • *
  • Posts: 2
DSM 520 freezes Rhapsody with new PC & router
« on: March 20, 2010, 10:37:58 AM »

My D-Link DSM-520 Media Player disconnects Rhapsody or any online service after a few minutes. I have a new HP PC with Windows 7 (& McAfee firewall) and a new router Netgear WNDR 3700 (I connect thru a Netgear Powerline Adaptor).

I DID NOT have this problem with my old PC and router where it worked for 2 years.

Pls help - D-Link support (plus Rhapsody and McAfee support) have not been helpful.

John
Logged

fccgrant

  • Level 2 Member
  • **
  • Posts: 77
Re: DSM 520 freezes Rhapsody with new PC & router
« Reply #1 on: March 21, 2010, 02:12:02 PM »

First thing I would do is disable McAfee Firewall.

If that doesn't work then I would temporarily switch back to the old router or check the lease time on the new router to make sure it is not set too short of time before renewal.
Logged

johncoskey

  • Level 1 Member
  • *
  • Posts: 2
Re: DSM 520 freezes Rhapsody with new PC & router
« Reply #2 on: March 23, 2010, 03:26:59 PM »

I switched back to my old Linksys 350 wireless N router and Rhapsody plays thru my DSM-520 Media Player without disconnecting. So why would the DSM-520 Media Player disconnect with my new Netgear WNDR 3700 router? Netgear support said the lease time issue isn't causing the problem but doesn't have further suggestions at this point.

Any thoughts?
Logged

fccgrant

  • Level 2 Member
  • **
  • Posts: 77
Re: DSM 520 freezes Rhapsody with new PC & router
« Reply #3 on: March 25, 2010, 05:27:57 PM »

Are you connected wired or wireless?

If wireless, have you tried the 54 Mbps mode on the Netgear?
Logged