D-Link GamerLounge > DGL-4500

Xbox Live Connection Problem

(1/2) > >>

j.reyes093:
Hi, this is my first post here so I apologize if its missing anything.

I purchased the DGL 4500 a couple of weeks ago from newegg and have had problems ever since I've installed it.  At first, it was just basic problems, that I admit, were my error in setup.  These were resolved relatively quickly and soon I had everything working around my house with no problems, with one exception, my 360.  For some reason, despite my own, Dlink's , Comcast's, and Microsoft's troubleshooting I could not get the 360 to connect to live.  The troubleshooting has been long arduous, and honestly, I blame no one, nor am I angry- I just wish for everything to work.  Anyways, here is a summary of all my troubleshooting and info below

Setup
-DGL 4500 Router 1.21NA FW (I updated my first router to the most recent, and still had the same problem)
-Comcast Cable Modem (Says RCA, but unsure of exact model)
-Two desktop computers connecting directly to the router via ethernet
-A wireless network with 4 computers connecting, WPA encryption
-An ethernet cable that runs under the floor to a ethernet port hub.  This hub has four ports on it, slot 1 has the ethernet cable from the router plugged into it, slot 2 has an ethernet cable that runs to nothing, and slot 3 has an ethernet cable running from the hub to my 360.

The Problem
I get an error when trying to run the network test on xbox live, something like-
    can connect to the internet, but not not xbox live.  Your router or ISP may be blocking ports *info on how to open ports*
This is after it spending almost no time establishing a network and internet connection, and a crazy amount of time on the internet->xbox portion.  I get a small green bar afer 30 seconds or so, and like 2 minutes later an error.

The Process
Before:
Everything works perfectly fine with my previous WRT54GS router, no problems whatsoever.

0. Got router
1. Got everything to work with all my computers
2. Plugged in 360
3. Could not connect, all settings at automatic, received error described above
4. At above point the correct ports were forwarded as well as upnp being enabled
4. Decided to try it on DMZ, still did not work
5. googled a bit, found this forum, read and followed the recommended game setup by FurryNutz
6. Attempted to try again, at no avail
7. Messed with random settings, still could not find what was wrong
8. Upgraded firmware to 1.22NA, started from scratch but still did not work
9. This time around DMZ worked, however, it did what I described below in "other bits of strange info"
10. Called dlink tech support who took me through basic steps once again, none worked of course
11. Referred me to higher level tech support, who tried basic steps once again
12. After many, many calls with many, many different people, the tech basically told me "this cannot be a router problem, ports are forwarded correctly, call xbox
13. Decided to humor Dlink support even though the xbox worked with my previous router
14. Followed arduous and redundant tasks of 360 support to obviously no triumph
15. They said it was Comcast's problem as I could not connect my 360 directly to my modem
16. Comcast said all they could do was a reset on the modem, it was working fine (honestly, i don't know much about the modem. I probably did something wrong and could get it to connect to the 360 just fine if i wanted to take the time. I don't really see a point considering it worked with my last router)
17. Called dlink to show them it was a router problem, said it was defective and told me to RMA
18. RMA'd
19. Received new router today
20. Decided to set up router literally exactly as shown on the quick start guide
21. Got all computers working and connecting within 10 minutes
22. Connected 360 (without any ports forwarded) and same problem
23. Forwarded ports, same problem
24. DMZd, same problem
25. Set things according to guide, same problem
26. Posted a desperate cry for help here

Summary
Not a modem problem because the 360 worked with my previous router
Not a 360 problem because I followed the support and it worked with my previous router
Not a hardware problem because my replacement didn't work as well
Not a configuration problem unless i consistently misread the multiple guides I read
So basically... WTF
Help please?

Other Bits of Strange info
-I sometimes have been randomly able to connect for a brief moment.  However, on these times (its happened 3 times), I have changed nothing. And it still takes forever to connect. Once I have connected, if i change anything it no longer works, even if i change it to previous settings
-Sometimes i get an MTU error randomly that goes away after a minute.  This usually occurs if I reboot my router and do a test too quickly
-After putting my old router back up everything worked fine. However, I changed some port, dmz, and qos settings, and suddenly I received the "cant connect to xbox live error." However, after changing some setting, it worked, and even after changing it back it still worked.
-My xbox will not connect to the internet when plugged directly into the modem, it doesn't get assigned an IP address. However, my xbox also worked with my previous router, so I see no reason for the modem to be an issue.

jjk21107:
I was having similar problems with my 4500 as well.  One thing I did in the router (eventhough I didn't want to) was to disable the SPI (firewall).  I even after doing this, I am still hit or miss on being able to connect or stay connected to XBL.  If you have the gaming rule enabled for Xbox Live it might be creating your problem.  Turn it off and see what happens.  All I ever get now is DNS errors on the Xbox and then it locks up the router and I can't even get on the internet.

Also if you want to connect directly to the modem with the Xbox, you need to reboot the modem after connecting it to the Xbox (while the Xbox is on).  Comcast should then be able to assign a DHCP address to the 360.  I use Mediacom and they use the same modems as Comcast.  Keep the Xbox set to automatic on all network settings and see if this works.  Then you can rule out the modem for sure as I already have.

I think I am just going to hook up my old router for the time being, and send this POS back to NewEgg.  Not sure what router to get next, but it might be the Apple one. 

Best of luck to you.

FurryNutz:
Check out the DGL-4500 Gaming and Gamefuel for XBL. It works great. Disregard the Gaming section, I need to edit it for PC uses and not for consoles. All other information is accurate for XBL. I use these settings and play well. Let us know now it works for you.

FurryNutz:
One good reason for not using DHCP is that if you set up any of the optional rules or filters and set them to a specific IP address that has not been reserved as a static IP, if that IP changes down the road, the filters or rules you set up for that IP address will stop working until you go fix the issue. Sometimes people might for get they did this and think there is something wrong with the router when they forgot to reserve the IP and it changed on them. It also helps in management of the network and having additional devices on the network, specially for IT folk.

However there is no need to open up ports for gaming consoles I have found. Specially if more that one xbox. The Gaming section from what I understand if for application usage and if the device your going to be using, i.e. PC and or  application/PC game that needs to communicate thru those ports since the PC is doing the Hosting. Gaming consoles aren't hosting anything as they are typically clients that are needing to connect to a Host, i.e. XBL or PS Servers.

Yes initially i had searched for information regarding Gaming and GameFuel. Not having a better understanding of each feature, Gaming is not recommended for game consoles. Specially with more than 2 on the same router. I found that some consoles have problems signing in properly if Gaming is set up on one console, the next console tries to sign in and can't. I'm thinking it's confused when trying to connect and thinks that the 1st console thats has the ports open, tries to connect to it and not the XBL servers. My theory. Thus not using Gaming and using GameFuel with the settings out lined in the Sticky has been successful across many installations I've helped with and gaming with one or more consoles has been a good experience.

Yes, the Sticky is going to be edited to reflect the Gaming section change.

Other than this, Static IP is recommended for gaming and gaming consoles. Have a great time and might see you on a map some wheres. I'll be REACH-ing soon. LOL Have a great weekend.

j.reyes093:
Thanks for all the responses guys.  Unfortunately, I'm still unable to connect.  


--- Quote from: jjk21107 on March 04, 2010, 06:11:35 PM ---I was having similar problems with my 4500 as well.  One thing I did in the router (eventhough I didn't want to) was to disable the SPI (firewall).

--- End quote ---
I did try this without success, I receive the same error.  I wouldn't think this would work either, as DMZ should place the IP outside of the firewall, however, I may be wrong.  I also will attempt to connect my modem to the 360 directly with this information, thanks.  Maybe my previous router was simply able to bypass a modem error that existed?

I also set up a static IP, and made sure it was far away from my other IPs. This will not work as well.


--- Quote from: FurryNutz on March 05, 2010, 07:13:41 AM ---Check out the Gaming and GameFuel sticky on this forum. It works great. Disregard the Gaming section, I need to edit it for PC uses and not for consoles. All other information is accurate for XBL. I use these settings and play well. Let us know now it works for you.

--- End quote ---
I have been using these settings as well, but i was using the gaming section. Yet, even after disabling the game settings it still will not connect.


The things most frustrating and baffling to me is that DMZ will not work.  One would think if placed under DMZ that port and firewall problems would go away (correct?), however, this is not the case.  And ports shouldn't be an issue if what FurryNutz says is correct about ports not needing to be forwarded.  Therefore, this must be a configuration issue somewhere else, or possibly an issue with my modem? like I stated above- maybe my previous router was just able to handle the modem error and bypass it. I'm still desperately looking for solutions so if anyone has any input it would be appreciated.


Edit:
I just checked my logs after all of the above were done and during a live connection test. This is what appeared.

UPnP added entry 255.255.255.255 <-> 98.220.91.93:3074 <-> 192.168.0.161:3074 UDP timeout:0 'Xbox (192.168.0.161:3074) 3074 UDP'

then higher up, twice
UPnP renew entry 255.255.255.255 <-> 98.220.91.93:62436 <-> 192.168.0.195:62436 UDP timeout:0 'Teredo'

Then three times, higher
UPnP deleted entry 255.255.255.255 <-> 98.220.91.93:59498 UDP

These are all for my 360, however, even higher up are three unrelated UPNP errors
ex:UPnP added entry 255.255.255.255 <-> 98.220.91.93:60098 <-> 192.168.0.196:60098 UDP timeout:0 'Windows Media Format SDK (GoogleDesktop.exe)'

could this be a UPnP error?

Edit2: I just ran a upnp test on my laptop with upnp enabled and got these results.


--- Code: ---TEST 1 - Operating System Support - PASSED
TEST 2 - SSDP Service Running Check - PASSED
TEST 3 - SSDP Service Automatic Check - FAILED
TEST 4 - UPnPHost Service Running Check - PASSED
TEST 5 - UPnPHost Service Automatic Check - FAILED
TEST 6 - UPnP Framework Firewall Exception Check - PASSED
TEST 7 - Adapter #0 - 192.168.0.196 - PASSED
TEST 8 - Get External IP Address (Result: 98.220.91.93) - PASSED
TEST 7 - Adapter #1 - 5.68.252.59 - PASSED
TEST 8 - Get External IP Address (Result: 98.220.91.93) - PASSED

UPnP Test Program v1.15 Copyright Mark Gillespie 2005
Bugs/Comments to:  mark.gillespie@gmail.com
Please do not email me UPnP support requests. I will not answer them.
--- End code ---

Thoughts? I'm not really sure what the above are

Edit3:
When UPnP is disabled and ports are forwarded (and also unforwarded I just discovered) I receive this error over and over in my log:

--- Code: ---Blocked incoming TCP packet from 74.125.95.101:80 to 98.220.91.93:49822 as FIN:ACK received but there is no active connection
--- End code ---

Edit4: I just enabled DMZ with these settings (UPnP disabled, no gaming rules) and got a connection. I saved the configuration file, but when I ran the Xbox live test again it no longer worked, like I described in my first post.

Navigation

[0] Message Index

[#] Next page

Go to full version