• March 23, 2019, 04:29:41 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: [1] 2 3

Author Topic: Beta Firmware 1.33b01NA Feedback  (Read 29604 times)

davevt31

  • Level 8 Member
  • ***
  • Posts: 1450
Beta Firmware 1.33b01NA Feedback
« on: January 15, 2010, 04:17:57 PM »

Installed over the beta 09 from November.  Did not have to restore config file, all the settings were saved after the update.
Logged

Cobra

  • Level 4 Member
  • ****
  • Posts: 477
Re: Beta Firmware 1.33b01NA Feedback
« Reply #1 on: January 15, 2010, 04:28:14 PM »

Hard to provide feedback when I do not know what was changed or fixed.
Logged

lizzi555

  • Level 5 Member
  • *****
  • Posts: 605
Re: Beta Firmware 1.33b01NA Feedback
« Reply #2 on: January 16, 2010, 12:25:45 AM »

At least I did not find any optical or feature changes.

But all basic functions as schedules, webfilter, DynDNS are working flawlessly.

I'm running it without Advanced DNS but DNS-Relay enabled.


Edit: typo
« Last Edit: January 16, 2010, 04:17:04 AM by lizzi555 »
Logged

foxium

  • Level 1 Member
  • *
  • Posts: 23
Re: Beta Firmware 1.33b01NA Feedback
« Reply #3 on: January 16, 2010, 03:42:07 AM »

Would someone please tell us what's fixed so we can properly decide if we want to try the beta code or not?

Can't trust D-link too much these days.
Logged

ozzed3

  • Level 3 Member
  • ***
  • Posts: 143
    • Ozzed.net Bitpop and chip music
Re: Beta Firmware 1.33b01NA Feedback
« Reply #4 on: January 16, 2010, 04:13:22 AM »

That's lame. The Eropean firmware had a changelog. Have you checked so that there isn't a file in the download?

Maybe it's not the same but here's what's new in the EU beta released today.

DIR-655A4 release notes history.
====================================================
ver1.31EUb02 Beta, 2010/01/14, EricK
1. Ubicom SDK 7.6.1 build 158, 2010, Jan 11, UBICOM_7_6_1_B0158
2. Checksum: 0x0435D18F
3. arp cache time: 60 seconds
4. HNAP security bug, could send set command in with "GetDeviceSettings" SoapAction.

ver1.31EUb01 Beta, 2009/12/23, EricK
1. Ubicom SDK 7.6.1 build 156, 2009, Dec 22, UBICOM_7_6_1_B0156
2. Checksum: 0x0435D0C7
3. arp cache time: 610 seconds
4. update Advanced DNS string (multi-languages)
5. patch DNS relay
6. update sharePort (Kcode) to 0.99

ver1.30EUb09 Beta, 2009/12/10, EricK
1. Ubicom SDK 7.6.1 build 153, 2009, Dec 09, UBICOM_7_6_1_B0153
2. Checksum: 0x04356B6C
3. usb 3g card always connet to ISP, should follow behaviors of always/on demand/manual

ver1.30EUb09, 2009/10/01, EricK
1. Ubicom SDK 7.6.1 build 142, 2009, Sep 30, UBICOM_7_6_1_B0142
2. Checksum: 0x04356413
3. GUI, DE version, Access control page, schedule do not work with 2nd entries
« Last Edit: January 16, 2010, 04:21:42 AM by ozzed3 »
Logged


My bitpop and chip music

lizzi555

  • Level 5 Member
  • *****
  • Posts: 605
Re: Beta Firmware 1.33b01NA Feedback
« Reply #5 on: January 16, 2010, 07:20:17 AM »

It is not the same as the EU firmware is dated: 2010/01/14 - with HNAP security patch.
1.33NA is dated: 2009/12/22 what is before HNAP problem was made public.
NA firmware could be more compared with the previous 1.31b01 from the change log.


Here are both chklst.txt:
Code: [Select]
Firmware Version: ver1.31EUb02Beta
Firmware Date: 2010/01/14
ipVersion(Date): 7.6.1b0158 (2010, Jan 11)
ipOS SDK Version: 7.6.3 P (1134)
WAN MAC: 00:26:5A:B8:69:1F
LAN MAC: 00:26:5A:B8:69:1E
WLAN MAC: 00:26:5A:B8:69:1E
Wireless Region: 0x09
    SSID: DIR655A5
SubVendorDeviceID: 0x0
Wireless Domain: 0xFFFF
Firmware Notify URL: http://wrpd.dlink.com.tw/router/firmware/query.asp?model=DIR-655_AX_EU
Firmware Global URL: http://wrpd.dlink.com.tw/router/firmware/DIR-655/Ax/EU/DIR655A4_FW121EUb05.bin
Checksum: 0x0435D18F
Use non DFS channel only: Enabled
This version is Release version
USB_IP/K=Enable Version 0.99
USB_IP/S=Disable
WLAN 0 Channel List: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13
HW Ver: A4

Code: [Select]
Firmware Version: ver1.33NAb01
Firmware Date: 2009/12/22
ipVersion(Date): 7.6.1b0156 (2009, Dec 22)
ipOS SDK Version: 7.6.3 P (1134)
WAN MAC: 00:19:5B:51:DB:7C
LAN MAC: 00:19:5B:51:DB:7B
WLAN MAC: 00:19:5B:51:DB:7B
Wireless Region: 0x09
    SSID: DIR6XXN
SubVendorDeviceID: 0x2071
Wireless Domain: 0x30
Firmware Notify URL: http://wrpd.dlink.com.tw/router/firmware/query.asp?model=DIR-655_AX_NA
Firmware Global URL: http://www.dlink.com.tw
Checksum: 0x03FBE715
Use non DFS channel only: Enabled
This version is Release version
USB_IP/K=Disable
USB_IP/S=Enable Version 1.1.1
WLAN 0 Channel List: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13
HW Ver: A1/A2
Logged

Neblinio

  • Level 2 Member
  • **
  • Posts: 31
Re: Beta Firmware 1.33b01NA Feedback
« Reply #6 on: January 16, 2010, 08:38:09 AM »

EU code seems newer, but Shareport version is different (newer on NA version).

I live in Europe, but I think I'll stick with NA version for now, besides the security flaw.

I just flashed to 1.33b01NA on 2 DIR-655 A2 devices (one works as router, the other as switch+AP), and so far they are working ok.
Logged

alien

  • Level 3 Member
  • ***
  • Posts: 207
Re: Beta Firmware 1.33b01NA Feedback
« Reply #7 on: January 16, 2010, 08:51:33 AM »

i tried to go back to the eu firmware but it isn't possible, and wireless signal is still worse. even with 3 10DBI antennes on it
« Last Edit: January 16, 2010, 09:00:39 AM by alien »
Logged
First Router Draytek Vigor 2310N for performance an VPN

Backup routers Dlink Dir855, DIR 655
Backup router ASUS WL500GP Premium en WL500g with DDWRT.

alien

  • Level 3 Member
  • ***
  • Posts: 207
Re: Beta Firmware 1.33b01NA Feedback
« Reply #8 on: January 16, 2010, 01:09:20 PM »

Virtual server is not working. Everythome you fill it in en choose reboot, the otion is empty again. I have reset my router to defaults and fill everything again in and the problems still exist. Somethimes dns relay is on when i reboot my router. Annyone else heave this problem with an A2 router?
Logged
First Router Draytek Vigor 2310N for performance an VPN

Backup routers Dlink Dir855, DIR 655
Backup router ASUS WL500GP Premium en WL500g with DDWRT.

lizzi555

  • Level 5 Member
  • *****
  • Posts: 605
Re: Beta Firmware 1.33b01NA Feedback
« Reply #9 on: January 16, 2010, 01:17:58 PM »

No, my A2 is working fine.
I have set different virtual servers and portforwardings.

You use Internet explorer for the settings ? It works best.
I had issues with FF.
Logged

alien

  • Level 3 Member
  • ***
  • Posts: 207
Re: Beta Firmware 1.33b01NA Feedback
« Reply #10 on: January 16, 2010, 01:57:42 PM »

yes i use internet explorer 8 is it a bug? from who? (microsoft or dlink)
Logged
First Router Draytek Vigor 2310N for performance an VPN

Backup routers Dlink Dir855, DIR 655
Backup router ASUS WL500GP Premium en WL500g with DDWRT.

lizzi555

  • Level 5 Member
  • *****
  • Posts: 605
Re: Beta Firmware 1.33b01NA Feedback
« Reply #11 on: January 16, 2010, 02:07:03 PM »

Normally IE8 works fine but have a look at the status bar at the bottom whether your router's ip is recognized as local intranet.
If it is internet, your browser might deny to run the scripts in the WEB UI.

You may also try to add the IP to the trusted sites.
Logged

Krusher

  • Level 2 Member
  • **
  • Posts: 75
Re: Beta Firmware 1.33b01NA Feedback
« Reply #12 on: January 16, 2010, 07:06:12 PM »

I just did the 1.32NAbeta09 -> 1.33NAbeta01 and also noticed that you didn't have to reset the router to the factory configuration; all settings were saved.

I did the reset anyway, just to follow the forum instructions and see whether I could upload the 1.32NAbeta09 configuration file.  That feature did not work and I had to enter in all previous information from scratch.  No biggie; I've had to do that in the past.

So far, everything else works, although it's only been 10 minutes.  If I find something broken, I'll report back.
Logged

pbodq

  • Level 2 Member
  • **
  • Posts: 31
Re: Beta Firmware 1.33b01NA Feedback
« Reply #13 on: January 16, 2010, 10:44:26 PM »

Virtual server is not working. Everythome you fill it in en choose reboot, the otion is empty again. I have reset my router to defaults and fill everything again in and the problems still exist. Somethimes dns relay is on when i reboot my router. Annyone else heave this problem with an A2 router?

what kind of reset did you try? the hardware small button or via webpage interface?

i suggest you press the one at the rear panel
Logged

alien

  • Level 3 Member
  • ***
  • Posts: 207
Re: Beta Firmware 1.33b01NA Feedback
« Reply #14 on: January 17, 2010, 12:24:48 AM »

what kind of reset did you try? the hardware small button or via webpage interface?

i suggest you press the one at the rear panel

Ofcourse i used the button on the back of the router.
Logged
First Router Draytek Vigor 2310N for performance an VPN

Backup routers Dlink Dir855, DIR 655
Backup router ASUS WL500GP Premium en WL500g with DDWRT.
Pages: [1] 2 3