• October 20, 2020, 10:42:38 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: [1] 2
  Subject Started by Replies Views Last post
New Drivers - v5.0.5B08 - macOS 10.7-10.12 (Rev E Only) GreenBay42 0 7336 Last post September 20, 2017, 07:11:44 AM
by GreenBay42
New D-Link Web Sites - USA FurryNutz 1 52303 Last post March 07, 2013, 10:32:11 AM
by FurryNutz
DWA-131 macOS Big Sur 11 WIFIUser 0 361 Last post August 18, 2020, 05:13:26 PM
by WIFIUser
Mac Catalina BrasilCalling 5 3594 Last post March 29, 2020, 10:51:09 AM
by FurryNutz
wireless capability turned off frequently and automatically happening hakuna12 3 4221 Last post November 12, 2018, 06:56:46 AM
by FurryNutz
Adapter fails to connect (Win7&10 / Belgium) Pringab420 9 4554 Last post May 24, 2018, 06:45:02 AM
by GreenBay42
DLink DWA-131 connectivity Wnetuseronforum 1 6946 Last post December 01, 2016, 08:28:06 AM
by FurryNutz
DWA-131 for Os X Yosemite Update 10.10.5 ??? Johnny2015 12 12127 Last post October 06, 2015, 06:35:56 AM
by FurryNutz
Won't work with Windows 10 eddyuk 3 8596 Last post August 12, 2015, 07:17:51 AM
by FurryNutz
DWA-132 (REV-B1) XTM 5 11691 Last post June 30, 2015, 12:34:08 PM
by FurryNutz
DWA-131 (A) - IBM Thinpad T41 (2373) Win XP Sp3 kstrid 1 40600 Last post November 30, 2013, 09:07:39 AM
by FurryNutz
Frequent disconnects shoe 14 18927 Last post November 04, 2013, 10:20:58 AM
by FurryNutz
installation on mac lion mush2004 1 10114 Last post February 18, 2013, 04:19:39 AM
by todddalton
DWA 131 drops connection.... and goes crazy!! Volgrand 3 62698 Last post July 03, 2012, 07:43:34 AM
by FurryNutz
DWA-131 On Mac OS X 10.7 - Wireless Utility just bounces gnuyen 2 21180 Last post May 25, 2012, 02:27:32 PM
by FurryNutz
Only sees G Networks, doesn't see N mark0978 10 23485 Last post May 15, 2012, 09:13:05 AM
by VOS
DWA-131 losing connection ladilu 4 13852 Last post April 19, 2012, 09:24:32 AM
by ladilu
DWA-121 guybru1 1 13955 Last post February 12, 2012, 08:09:38 AM
by mmcn
Need to uninstall / reinstall with each reboot hank 0 6368 Last post December 27, 2011, 07:16:13 PM
by hank
Wireless adapter not found. NinjaPeter 1 19028 Last post November 14, 2011, 09:39:45 AM
by bastard#13
Pages: [1] 2

 

  • Normal Topic
  • Hot Topic (More than 15 replies)
  • Very Hot Topic (More than 25 replies)
  • Locked Topic
  • Sticky Topic
  • Poll