• July 22, 2019, 05:25:46 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: 1 [2]
  Subject Started by Replies Views Last post
Lost of visibility of Channel 12 & 13 in Driver v1.30 chaicka 1 4010 Last post October 17, 2008, 09:02:08 PM
by hswaters
Intermittent loss of Internet connectvity eboe 8 8855 Last post December 17, 2008, 02:51:32 PM
by arod
Install HANGS on Windows XP-SP2 using Latest Driver from Webpage markt5233 1 5863 Last post October 06, 2009, 12:49:09 PM
by kevinla
How do you disable WZC in Vista? scarass 2 4437 Last post January 14, 2008, 12:36:03 PM
by Rad Spencer
Full N not Draft Stepan 0 7587 Last post December 07, 2009, 12:56:36 PM
by Stepan
failed to install kathykearny 2 6569 Last post July 01, 2010, 10:17:35 AM
by marmoduke
Failed install...bad connections et al. marmoduke 0 13840 Last post July 01, 2010, 10:21:31 AM
by marmoduke
fail to install wireless driver bruce 1 4351 Last post April 01, 2008, 12:39:21 PM
by Lycan
DWA-142 Deauthentication Received connection dropped gbtex 2 4437 Last post February 23, 2008, 09:15:37 AM
by Phantasman
Dropping Connection andy 8 13235 Last post June 01, 2009, 06:27:50 AM
by andy
Documentation on RegionCode (SKU1-12) Selection in Driver 1.30 chaicka 0 3092 Last post October 12, 2008, 09:15:17 AM
by chaicka
Cannot find driver for DWA-142 poolboynaturel 1 8887 Last post October 12, 2009, 11:32:43 AM
by kevinla
Can't watch video on the internet kevinla 1 4723 Last post December 17, 2008, 02:56:07 PM
by arod
Can't watch some video on the internet kevinla 7 8912 Last post December 17, 2008, 02:54:57 PM
by arod
Blue screen on high network load CadErik 4 9032 Last post July 01, 2009, 05:11:02 PM
by philip
Pages: 1 [2]

 

  • Normal Topic
  • Hot Topic (More than 15 replies)
  • Very Hot Topic (More than 25 replies)
  • Locked Topic
  • Sticky Topic
  • Poll