• August 19, 2019, 04:05:08 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: [1] 2
  Subject Started by Replies Views Last post
Welcome! Lycan 0 5031 Last post August 30, 2007, 04:53:33 PM
by Lycan
United States Support and FAQ's Here! arod 0 6730 Last post January 19, 2009, 01:16:58 PM
by arod
DWA-142 - EOL FurryNutz 0 20469 Last post November 28, 2012, 12:30:12 PM
by FurryNutz
300Mbps Connection Requirements! Please Read! Lycan 0 5361 Last post November 07, 2007, 09:38:33 AM
by Lycan
New D-Link Web Sites - USA FurryNutz 1 46677 Last post March 07, 2013, 10:31:03 AM
by FurryNutz
Documentation on RegionCode (SKU1-12) Selection in Driver 1.30 chaicka 0 3112 Last post October 12, 2008, 09:15:17 AM
by chaicka
Wireless Network Connection deleted when connection to wireless router is lost vernsplaza 0 7656 Last post February 18, 2009, 12:36:50 PM
by vernsplaza
Failed install...bad connections et al. marmoduke 0 13918 Last post July 01, 2010, 10:21:31 AM
by marmoduke
Full N not Draft Stepan 0 7667 Last post December 07, 2009, 12:56:36 PM
by Stepan
Windows 7 Drivers? TheNewZackMorris 0 7936 Last post July 17, 2009, 04:58:57 AM
by TheNewZackMorris
Skipping Video ferdinand 1 3952 Last post November 05, 2008, 03:16:59 PM
by RussellM
Lost of visibility of Channel 12 & 13 in Driver v1.30 chaicka 1 4027 Last post October 17, 2008, 09:02:08 PM
by hswaters
Install HANGS on Windows XP-SP2 using Latest Driver from Webpage markt5233 1 5949 Last post October 06, 2009, 12:49:09 PM
by kevinla
fail to install wireless driver bruce 1 4363 Last post April 01, 2008, 12:39:21 PM
by Lycan
Cannot find driver for DWA-142 poolboynaturel 1 8965 Last post October 12, 2009, 11:32:43 AM
by kevinla
Wireless Connection Manager not working and connection drops bhav27 1 11745 Last post August 26, 2009, 02:59:13 PM
by kevinla
Can't watch video on the internet kevinla 1 4743 Last post December 17, 2008, 02:56:07 PM
by arod
x64 drivers coming? Thorgils 2 65745 Last post May 23, 2011, 12:35:30 PM
by RaZor87
failed to install kathykearny 2 6660 Last post July 01, 2010, 10:17:35 AM
by marmoduke
How do you disable WZC in Vista? scarass 2 4450 Last post January 14, 2008, 12:36:03 PM
by Rad Spencer
Pages: [1] 2

 

  • Normal Topic
  • Hot Topic (More than 15 replies)
  • Very Hot Topic (More than 25 replies)
  • Locked Topic
  • Sticky Topic
  • Poll