• May 24, 2020, 10:55:01 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Child Boards
No New Posts

Beta Drivers!

Beta Drivers for the DWA-542 for Vista and XP

Moderator: Lycan

5 Posts
2 Topics
Last post by daskino
in Re: Success stories with...
on September 23, 2009, 11:38:49 AM
Pages: [1] 2
  Subject Started by Replies Views Last post
Welcome! Lycan 0 5789 Last post August 30, 2007, 04:52:02 PM
by Lycan
300Mbps Connection Requirements! Please Read! Lycan 0 6464 Last post November 07, 2007, 09:38:13 AM
by Lycan
DWA-542 End Of Life FurryNutz 0 12063 Last post January 30, 2013, 12:58:01 PM
by FurryNutz
United States Support and FAQ's Here! arod 0 7810 Last post January 19, 2009, 01:18:12 PM
by arod
New D-Link Web Sites - USA FurryNutz 1 52060 Last post March 07, 2013, 10:31:20 AM
by FurryNutz
Can't connect to "N" when router is "Mixed" sting 0 5646 Last post October 14, 2009, 03:29:49 PM
by sting
Random Disconnects Flinten 0 10721 Last post October 25, 2009, 01:47:56 AM
by Flinten
Will the DIR-615 router work with the DWA-542 Adapter? russ1150 0 9987 Last post November 23, 2009, 09:46:25 AM
by russ1150
My wlan card not work on Windows 7 ultimate SaaM 0 17380 Last post March 11, 2010, 09:28:27 AM
by SaaM
Problem installing DWA-542 on Windows Home Server (32 bits) Dave 0 5152 Last post July 25, 2011, 11:50:49 AM
by Dave
DWA-547 problems Xaverous 0 55558 Last post August 04, 2011, 12:41:50 AM
by Xaverous
Fast User Switch Disable Workaround DJMark 0 5672 Last post September 20, 2009, 05:34:24 PM
by DJMark
Fast User Switching and WlanGINA csalas 0 6094 Last post August 27, 2009, 11:21:17 AM
by csalas
After much review....... Lycan 0 2907 Last post June 10, 2008, 12:37:46 PM
by Lycan
DWA-520 D-Link official advice to downgrade to SP2 Sumdumphuc 0 7793 Last post October 24, 2008, 11:00:51 PM
by Sumdumphuc
Extremely poor connection reliability BARBEERIAN 0 3429 Last post February 16, 2009, 05:30:17 AM
by BARBEERIAN
DWA-548 Wireless N incredibly slow GiantEwok 1 224 Last post April 16, 2020, 09:29:23 AM
by FurryNutz
DWA-510 Windows 7 Ultimate 64-bit Lohita 1 16337 Last post June 23, 2010, 03:35:55 PM
by Andre_NIT
Dropping Connection peste19 2 8233 Last post August 04, 2009, 07:33:01 PM
by 745i
missing drivers sealtldvl 2 4116 Last post August 20, 2008, 03:28:31 PM
by arod
Pages: [1] 2

 

  • Normal Topic
  • Hot Topic (More than 15 replies)
  • Very Hot Topic (More than 25 replies)
  • Locked Topic
  • Sticky Topic
  • Poll