• December 14, 2018, 10:40:08 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Child Boards
No New Posts

Beta Drivers!

Beta Drivers for the DWA-552 for Vista and XP

Moderator: Lycan

15 Posts
5 Topics
Last post by FurryNutz
in Re: !seen Windows 7 beta...
on February 07, 2013, 07:47:17 AM
Pages: [1] 2 3 ... 9
  Subject Started by Replies Views Last post
Welcome! Lycan 0 5222 Last post July 16, 2007, 03:33:48 PM
by Lycan
300Mbps Connection Requirements! Please Read! Lycan 0 6623 Last post November 07, 2007, 09:34:38 AM
by Lycan
Vista Beta Drivers BSOD/Hardlock Issue! Lycan 0 6009 Last post April 24, 2008, 06:07:42 PM
by Lycan
United States Support and FAQ's Here! arod 0 4862 Last post January 19, 2009, 01:09:10 PM
by arod
New D-Link Web Sites - USA FurryNutz 0 15956 Last post June 29, 2012, 07:24:46 AM
by FurryNutz
WiFi connected but connection times out n3m37h 0 23270 Last post April 17, 2012, 08:05:30 AM
by n3m37h
Faible signal et Windows 7 x64 à moitié supporté... Tenebricosus 0 3379 Last post May 09, 2010, 07:31:58 PM
by Tenebricosus
DLink wireless connection manager source of issues. retread 0 9498 Last post January 06, 2010, 03:37:45 PM
by retread
dwa 552 adapter goes to mixed 802.11n and 802.11g sanserve 0 2082 Last post December 28, 2009, 09:50:15 AM
by sanserve
D-Link Wireless Manager or Windows Manager? P01arBear 0 5210 Last post March 23, 2010, 08:24:30 PM
by P01arBear
MOVED: New - DWA-582 - AC1200 Wi-Fi PCI Express Adapter FurryNutz 0 4319 Last post February 17, 2015, 01:40:28 PM
by FurryNutz
Slow rate with windows update drivers 7.7 CadErik 0 2226 Last post October 25, 2009, 07:23:05 PM
by CadErik
DWA 552 drivers or mine zdrzero 0 2139 Last post October 03, 2009, 10:08:16 PM
by zdrzero
DWA-552 + DIR-655 disconnection issues Co0oW 0 3178 Last post September 08, 2009, 10:39:49 PM
by Co0oW
802.11G network, and its just not capable d0rkiishchris 0 2259 Last post August 24, 2009, 08:45:10 PM
by d0rkiishchris
Need new driver for Vista SP2 RTM. KGB7 0 2187 Last post April 30, 2009, 01:41:23 PM
by KGB7
"API Init error" and Virtual Machine Network Services FYI initerror 0 3049 Last post March 26, 2009, 11:27:55 PM
by initerror
Augggggh! ruxpinator 0 1984 Last post May 17, 2010, 06:38:19 PM
by ruxpinator
DWA 552 Adapter with a Netgear Antenna jdubyak 0 1991 Last post June 28, 2010, 10:46:47 AM
by jdubyak
DWA-552 installed but not showing any wireless networks? agallantknight 0 9244 Last post June 14, 2012, 06:25:10 AM
by agallantknight
Pages: [1] 2 3 ... 9

 

  • Normal Topic
  • Hot Topic (More than 15 replies)
  • Very Hot Topic (More than 25 replies)
  • Locked Topic
  • Sticky Topic
  • Poll