• June 16, 2019, 06:11:26 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DGS-3100-24P - VLAN Configuration Issue  (Read 205 times)

Blue.R

  • Level 1 Member
  • *
  • Posts: 1
DGS-3100-24P - VLAN Configuration Issue
« on: April 22, 2019, 10:42:19 PM »

Hi,

I'm in the process of setting up a my network which has a DGS-3100-24P (firmware 3.60.28) as the core switch.

I would like to configure a couple of VLAN on the switch, however I'm not having much luck with getting it to work at the moment.

The network topology is as follows:
pFsense Visualized with 2 NICs.

pfSense IP - 192.168.100.1

em0 - WAN (DHCP)
em1 - LAN_MAIN (DHCP - 192.168.100.XXX)

I want to establish 4 VLAN on the switch, these are as follows:

Port 1 is configured as the VLAN Trunk port in the switch under "VLAN Trunking"

VLAN 150 - General (DHCP - 192.168.150.XXX)
VLAN 200 - Security (DHCP - 192.168.200.XXX)
VLAN 220 - IoT (DHCP - 192.168.220.XXX)
VLAN 250 - Management (DHCP - 192.168.250.XXX)

This is what I have done so far:
1. Create VLAN interfaces on pFsense with em1 as the parent interface.
2. Enable all interface in pFsense with associated DHCP settings.
3. Setup pass all rules in firewall for starting purposes and testing.
4. Configure the 3100 as shown in the image. Note: I have only done VLAN 200, 220 and 250, for the moment for testing purposes. If I configure VLAN 150 I loose connectivity with the switch at the moment.

https://www.dropbox.com/s/so6gntgv723r359/D_LINK%20-%20VLAN_Settings_5.jpg?dl=0

I hae "Asymmetric VLAN" enabled on all ports at the moment, however I will change that to as specific port once I have things configured and working the way I want.

The issues:
- The devices that are connected on VLAN 200, 220 and 250 are not able to get a IP from pfSense.

I'm not sure if I have missed something with the configuration on the switch... I can ping all the "pfSense VLAN gateways" from 192.168.100.10 IP which is part of the default VLAN.

Any guidance on troubleshooting will be much appreciated..

Logged