D-Link Enterprise > DGS-1210-Series

DGS-1210-52 Erroneously Lists Device Type as DGS-1210-28P

(1/2) > >>

I purchased a used DGS-1210-52 switch.  I performed a factory reset.  After logging into the admin panel and setting the new password, IP and etc, I decided to see if a firmware update was needed.  When I look in the main page, it lists the device type as "DGS-1210-28P".  However, this is a DGS-1210-52.  It seems to be working fine with no special configurations.

I try to do firmware upgrades but it fails and I'm assuming because it is identifying as a different switch than it is .  Anyone have any ideas re: how to fix this?  Is there another factory reset that does more?

Thanks in advance for any help!

After looking closer, I now see the web software only gives access to 28 ports.  So, it is definitely thinking it is a different device than it is.  Luckily, the SFP port is working as it is so the switch is operational.  We only need 24 Cat5 ports, so we are good.  But need to figure this one out?

Would this be cause by someone putting an improper firmware on it?

What HW version is the switch?
What version of FW is loaded on it currently?
What region are you located?

Be sure that the sticker is for a 52. If it is, you might try to see if you can get the actual 52 version of FW on it.
Did you buy this switch used?

Thank you for the quick reply.  I am in the US, this is a USED switch and here is the info from the stickers and what the web interface is telling me:

Type: DGS-1210-52
H/W: C1
F/W: 4.10.004

Web UI
Type: DGS-1210-28P
Boot Ver: 1.00.016
Firmware: 4.00.064
Hardware: C1
Serial Number: Different than sticker.  Refurb?
MAC: Different than sticker.  Refurb?

The firmware for the 1210-52 HW C from D-Link is 4.10.004, which is different than what is installed.  I tried installing it, anyway, but the Web UI would not let me.  I also tried via the CLI, to no avail.

I have setup a TFTP server and will see if there is a way I can use the CLI to force the installation of the downloaded firmware.  Any other ideas?

I found in the log that it is stating the following when I try to apply the FW I downloaded from D-Link:

Illegal file causes firmware upgrade failure.

I'm guessing since it thinks it is a -28P that the -52 FW is not allowed.  Correct?


[0] Message Index

[#] Next page

Go to full version