The Graveyard - Products No Longer Supported > DIR-810L

Can't reach the Router Recovery webpage when pressing hardware reset button


Hi, I'm trying to reach the emergency firmware flashing page as described in the "Emergency Flashing HOWTO" discussion, but it won't work for me.

I've used a variety of interfaces on the router (WAN and all LAN), static IP addresses on my computer ( and and URL's to try to reach on the router ( and, and different approaches to pressing down the reset button (how many seconds before powering on, whether to release after power led starts blinking orange etc.) but nothing works for me (it does work on my DIR-845 though). The DIR-810L never even replies to ARP requests when I'm trying to browse to the recovery page after booting with the reset button pressed.

I've got a DIR-810L hardware revision A1.

Anyone got any ideas?

Last time I tried this on mine it worked. I've always use static IP address on my PC. IE11 or FF browsers have worked for me.
Have you been using OEM FW or 3rd party FW?

Are you sure your following this correctly?
Emergency Recovery Mode

After the LED starts blinking after you let go of the reset button, try to ping the router at Does it respond?

Hi, I'm trying to restore OEM FW after installing OpenWRT. OpenWRT boots and appears to work (gets an IP address through, DHCP, starts talking to NTP servers and so on) but I can't connect to it to configure, as all five interfaces appear to be just one logical interface (they all talk on VLAN 2 and they all use the same IP) and it seems this logical interface is the WAN interface, where OpenWRT isn't listening on any ports so I can't connect with http/https/ssh/telnet etc..

If I understand correctly the Emergency Recovery Mode should be available even after flashing 3rd party FWs, as it was an OpenWRT webpage that tipped me off to the possibility to unbrick a D-Link router using that method.

I've tried following the 11 steps (except steps 1 and 9-11) under the heading "Procedure for DIR series routers" in the post you're linking, both verbatim and with a few changes. Besides verbatim I have for instance:
* connected to the WAN port in step 2
* tried and in step 3
* only unplugged the router without first powering down in step 4
* in step 6 I've both released the reset button directly after the power led turns amber, released it after about 5 seconds, 10 seconds, and I've also not released it but tried connecting with the reset button held
* I've scanned the entire range to try to find any open port on any IP in that range (in step 7)
* I've tried repeatedly forr several minutes in step 8, even though it really shouldn't take more that 10-20 seconds (if even that) for the router to boot and start serving that page

All in all I don't know how many times I've tried most of the combinations of the above variations of the instructions, without success.

I have also tried to ping the router, but it doesn't reply (no arp requests ever gets a response, regardless if it's for pinging or connecting to port 80).

Does OpenWRT have there process to migrate back to OEM FW posted someplace?
I 'm wondering if there FW somehow blew away the recovery partition of NVRAM.  :-\ If it's not appearing using our method, then I'll bet the recovery partition is gone.  :(

You might ask someone over there on there forum about this issue and if anyone has more information about it. Would need to some how get the recovery partition recovered to the router...even if that's possible.  ::)


[0] Message Index

Go to full version