• August 22, 2019, 09:06:05 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Chromecast Performance Issues  (Read 1657 times)

square_eyes

  • Level 2 Member
  • **
  • Posts: 32
Chromecast Performance Issues
« on: January 24, 2018, 01:23:20 AM »

Couldn't decide if I should start a new thread but curious that I return to this forum after nearly a year of pretty good performance and the first post is similar to my issue. Happy to start a new one as this kind of diverted.

Chromecast performance has degraded for me lately, as has mDNS (.local), as has SSH (port 22).

Experience is that Spotify, Youtube, Plex on my Nougat phone will see the Chromecast icon but time out casting content. Sometimes the Chromecast icon is greyed out or my renderer device unavailable. I have tried Google's troubleshooting and restarted everything. Sometimes it works, usually it doesn't.

SSH connections to a Raspberry Pi via IP fail 50% of the time and the Pi's mDNS address (.local) fails to resolve more often than not. But the kicker is that they both sometimes work.

It seems something is interfering with the way these services broadcast their availability/status.

I haven't changed anything on the router lately. Google Home app seems to see the Chromecast fine and allow me to remotely reboot it and change the slide show.

I am on WW1.08 HW A1 with ~15 devices. I have Powerline connected for a NAS, but this route is not used for any of the other mentioned services.
« Last Edit: January 24, 2018, 02:33:21 AM by square_eyes »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47702
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Chromecast Performance Issues
« Reply #1 on: January 24, 2018, 08:06:54 AM »

So do you have a extender that your using with your 880L?
Is Smart Connect enabled?

What is the Mfr and model of the ISP modem?
What is the ISP Speed UP and Down your supposed to get?

Is QoS enabled and configured?
Speed testing via LAN cable connection with a PC thats not in the QoS configuration?

Are you getting any disconnections with the router or just seeing slower speeds over time?
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

square_eyes

  • Level 2 Member
  • **
  • Posts: 32
Re: Chromecast Performance Issues
« Reply #2 on: January 24, 2018, 10:23:02 PM »

No extender, have always used Smart Connect. I don't use a modem. The 880L connects directly to the carrier Fibre ONT (Optical Network Terminal). Speed is 100MB down and 20 up. QoS is disabled. I'd like to use it but have had problems in the past. Speed test is consistently 90MB+ and 20MB Dl.

Speed is fine I think, throughout. Although I'm not a heavy downloader so wouldn't notice.

It seems like all these services that rely on broadcasting their availability locally are being impeded somehow.

Weird thing is, the Chromecast used to work fine.

Thanks for your help!
« Last Edit: January 24, 2018, 10:24:47 PM by square_eyes »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47702
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Chromecast Performance Issues
« Reply #3 on: January 25, 2018, 06:56:24 AM »

Are you speed testing via wireless or wired connection?

Is the ONT passing thru a public IP address or a private address to the 880L?

Are you getting IPv6 native services at all from the ISP?
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

square_eyes

  • Level 2 Member
  • **
  • Posts: 32
Re: Chromecast Performance Issues
« Reply #4 on: January 25, 2018, 04:21:13 PM »

I'm speed testing on WiFi, but speed seems not to be the issue as far as I can tell. In fact I'm not sure what WAN internet has to do with this at all. The issue is Chromecast visibility and connection to my LAN devices.

Not sure on ONT IP. Again not sure it's relevant for my LAN issues. I can tell you the 880L doesn't require a modem and is configured to interact with the ONT on VLAN 10.

Not sure on IPv6. I'm not knowingly using IPv6.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47702
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Chromecast Performance Issues
« Reply #5 on: January 25, 2018, 05:24:28 PM »

You need to test LAN cable connection with a PC. Don't use wireless.

Check the IPv6 settings on the router. Set for Local Only if you don't know if your ISP provides native IPv6 support.

Disable DNS Relay on the router as well. Reboot both router then all devices after setting this option.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting