• August 24, 2019, 01:13:11 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Firmware Question  (Read 3924 times)

Niteowl1

  • Level 1 Member
  • *
  • Posts: 3
Firmware Question
« on: March 18, 2015, 08:01:11 AM »

I have DIR-601, Hardware Version A1, Current Firmware Version: 1.02NA Current Firmware Date: Thu, 25 Nov 2010.

When I click on the "Check Online Now for Latest Firmware Version" button in the admin panel, it responds "This firmware is the latest version." When I go to the D-Link support page, I see 1.04B02 available, which seems to be a later version. Should I upgrade to that one?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47712
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Firmware Question
« Reply #1 on: March 18, 2015, 08:04:36 AM »

Link>Welcome!

  • What region are you located?

Please follow this for doing any FW updates:
 FW Update Process

If it works, don't fix it.  ::)
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

Niteowl1

  • Level 1 Member
  • *
  • Posts: 3
Re: Firmware Question
« Reply #2 on: March 18, 2015, 08:17:20 AM »

I'm in the USA. Router isn't communicating with my Apple Devices after release of IOS 8.2, and I'm wondering if a firmware update will resolve.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47712
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Firmware Question
« Reply #3 on: March 18, 2015, 08:23:47 AM »

What modes are you using on the router?
Try single mode G or N?
Do the apple devices connect if you temporarily disable WPA security? Re-enabled after testing then set for WPA2 and AES only and test with single mode N...Auto Channel Width 20/40Mhz
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

Niteowl1

  • Level 1 Member
  • *
  • Posts: 3
Re: Firmware Question
« Reply #4 on: March 18, 2015, 08:42:13 AM »

That got it. I was on mixed g, b, and n. Switched to mixed g and n, and now it's fine. Hopefully won't negatively affect other devices in the house. Thanks for the tip!
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47712
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Firmware Question (RESOLVED)
« Reply #5 on: March 18, 2015, 08:47:42 AM »

Glad it's working better now. Enjoy.  ;)
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting