• October 16, 2019, 02:05:35 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Port Forwarding Not Working  (Read 17151 times)

wilsonhew

  • Level 1 Member
  • *
  • Posts: 6
Port Forwarding Not Working
« on: May 10, 2014, 07:23:08 AM »

Dear all,

I am having issue with port forwarding on 850L. Current firmware is 1.10SG.

Tried both port forwarding and virtual server, nothing works. A simple SSH 22 port forward also does not work.

Any hint what should I try next? Tried another old router and it works better than this 850L.  >:(

Thanks,
Wilson
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47838
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Port Forwarding Not Working
« Reply #1 on: May 10, 2014, 08:01:43 AM »

Link>Welcome!

  • What region are you located?
  • Are you wired or wireless connected to the router?

Internet Service Provider and Modem Configurations
  • What ISP Service do you have? Cable or DSL?
  • What ISP Modem Mfr. and model # do you have?
  • Is ISP Modem/Service using Dynamic or Static WAN IP addressing?
  • What ISP Modem service link speeds UP and Down do you have?
  • Check cable between Modem and Router, swap out to be sure. Link> Cat6 is recommended.
  • Check ISP MTU requirements, Cable is usually 1500, DSL is around 1492 down to 1472. Call the ISP and ask. Link>Checking MTU Values
  • For DSL/PPPoE connections on the router, ensure that "Always ON" option is enabled.

Router and Wired Configurations
Some things to try: - Log into the routers web page at 192.168.0.1. Use IE, Opera or FF to manage the router. Besure to log into the Admin account on the router.
  • Turn off Advanced DNS Services if you have this option under Setup/Internet/Manual or under Setup/PARENTAL CONTROL/Set to>None: Static IP or Obtain Automatically From ISP.
  • Enable Use Unicasting (compatibility for some ISP DHCP Servers) under Setup/Internet/Manual.
  • Turn on or OFF DNS Relay under Setup/Networking. Link>Finding Faster DNS Addresses using Name Bench and input new DNS addresses under Setup/Internet/Manual.
  • Setup DHCP reserved IP addresses for all devices ON the router. Setup/Networking. This ensures each devices gets its own IP address when turned on and connected, eliminates IP address conflicts and helps in troubleshooting and maintain consistency for applications that need to connect as well as mapped drives.
  • Ensure devices are set to auto obtain an IP address.
  • If IPv6 is an option on the router, select Local Connection Only or Disable IPv6 options under Setup/IPv6.
  • Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall. Enable or Disable SPI to test.
  • Enable uPnP and Multi-cast Streaming under Advanced/Networking. Disable uPnP for testing Port Forwarding rules. Enable IPv6 Multi-cast Streaming for routers that have a Media Server option. Disable IPv6 Multi-cast Streaming if IPv6 or Media Server is not being used.
  • Turn off WISH, and WPS under Advanced.
  • WAN Port Speed set to Auto or specific speed? Some newer ISP modems support 1000Mb so manually setting to Gb speeds can be supported by the router. Advanced/Advanced Networking/WAN Port Speed
  • Set current Time Zone, Date and Time. Use an NTP Server feature. Tools/Time.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

wilsonhew

  • Level 1 Member
  • *
  • Posts: 6
Re: Port Forwarding Not Working
« Reply #2 on: May 10, 2014, 09:45:20 AM »

Hi FurryNutz,

Thanks for your reply. Please see my response below. Tried your suggestions but still not working. Out of idea... :(

Regards,
Wilson

Link>Welcome!

  • What region are you located?
ASIA
  • Are you wired or wireless connected to the router?
Both wired and wireless

Internet Service Provider and Modem Configurations
  • What ISP Service do you have? Cable or DSL?
DSL
  • What ISP Modem Mfr. and model # do you have?
AlcaltelLucent, I240G
  • Is ISP Modem/Service using Dynamic or Static WAN IP addressing?
Dynamic IP addressing
  • What ISP Modem service link speeds UP and Down do you have?
10Mbps up/down
Connection is good
  • Check ISP MTU requirements, Cable is usually 1500, DSL is around 1492 down to 1472. Call the ISP and ask. Link>Checking MTU Values
MTU is 1492
  • For DSL/PPPoE connections on the router, ensure that "Always ON" option is enabled.
Yes, always on

Router and Wired Configurations
Some things to try: - Log into the routers web page at 192.168.0.1. Use IE, Opera or FF to manage the router. Besure to log into the Admin account on the router.
  • Turn off Advanced DNS Services if you have this option under Setup/Internet/Manual or under Setup/PARENTAL CONTROL/Set to>None: Static IP or Obtain Automatically From ISP.
No such option
  • Enable Use Unicasting (compatibility for some ISP DHCP Servers) under Setup/Internet/Manual.
  • Turn on or OFF DNS Relay under Setup/Networking. Link>Finding Faster DNS Addresses using Name Bench and input new DNS addresses under Setup/Internet/Manual.
Yes, turned off.
  • Setup DHCP reserved IP addresses for all devices ON the router. Setup/Networking. This ensures each devices gets its own IP address when turned on and connected, eliminates IP address conflicts and helps in troubleshooting and maintain consistency for applications that need to connect as well as mapped drives.
Yes, running on DHCP
  • Ensure devices are set to auto obtain an IP address.
Yes, obtain IP address from router
  • If IPv6 is an option on the router, select Local Connection Only or Disable IPv6 options under Setup/IPv6.
IPv6 disabled
  • Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall. Enable or Disable SPI to test.
Tried both, still does not work.
  • Enable uPnP and Multi-cast Streaming under Advanced/Networking. Disable uPnP for testing Port Forwarding rules. Enable IPv6 Multi-cast Streaming for routers that have a Media Server option. Disable IPv6 Multi-cast Streaming if IPv6 or Media Server is not being used.
Tried turning on/off, still does not work.
  • Turn off WISH, and WPS under Advanced.
Turned off.
  • WAN Port Speed set to Auto or specific speed? Some newer ISP modems support 1000Mb so manually setting to Gb speeds can be supported by the router. Advanced/Advanced Networking/WAN Port Speed
Set to auto.
  • Set current Time Zone, Date and Time. Use an NTP Server feature. Tools/Time.
Yes, using NTP, and correct timezone.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47838
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Port Forwarding Not Working
« Reply #3 on: May 10, 2014, 11:51:11 AM »

  • If the ISP modem has a built in router, it's best to bridge the modem. Having 2 routers on the same line can cause connection problems: Link>Double NAT and How NAT Works. To tell if the modem is bridged or not, look at the routers web page, Status/Device Info/Wan Section, if there is a 192.168.0.# address in the WAN IP address field, then the modem is not bridged. If the modem can't be bridged then see if the modem has a DMZ option and input the IP address the router gets from the modem and put that into the modems DMZ. Also check the routers DHCP IP address maybe conflicting with the ISP modems IP address of 192.168.0.1. Check to see if this is the same on the ISP modem, and if modem can't be bridged, change the DIR router to 192.168.1.1 or .0.254.
    Example of a D-Link router configured for PPPoE with ISP Modem bridged: PPPoE Configuration on Router
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

wilsonhew

  • Level 1 Member
  • *
  • Posts: 6
Re: Port Forwarding Not Working
« Reply #4 on: May 14, 2014, 09:31:17 AM »

Thanks for your reply. Checked and don't think modem is the culprit. As I am using the same IP addressing for my old router (DIR-615) and port forwarding works.

I am out of idea...
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47838
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Port Forwarding Not Working
« Reply #5 on: May 14, 2014, 09:51:25 AM »

To tell if the modem is bridged or not, look at the routers web page, Status/Device Info/Wan Section, if there is a 192.168.0.# address in the WAN IP address field, then the modem is not bridged.

Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall. Enable or Disable SPI to test.

Disable uPnP for testing Port Forwarding rules.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

wilsonhew

  • Level 1 Member
  • *
  • Posts: 6
Re: Port Forwarding Not Working
« Reply #6 on: May 14, 2014, 09:55:56 AM »

Thanks for your reply.

- Yes, checked. It is bridge mode. I am seeing my public IP address from the ISP instead of private IP address.

- Under Advanced/Firewall, no "Endpoint Independent for TCP and UDP" option. Yes, tried enable and disable SPI.

Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47838
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Port Forwarding Not Working
« Reply #7 on: May 14, 2014, 10:06:26 AM »

Is the uPnP disabled when you have PF rules enabled?

Can you give Virtual Server a try as a test with your configuration and see if that resolves this? Disable PF rules when you go to use VS.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

wilsonhew

  • Level 1 Member
  • *
  • Posts: 6
Re: Port Forwarding Not Working
« Reply #8 on: May 14, 2014, 10:18:54 AM »

1. Yes uPNP disabled under Advanced - > Advanced Network, when I tested with PF rules enabled.
2. Tried Virtual Server with PF disabled, uPNP disabled and SPI disabled.

It works when I put my server in DMZ, which I am trying to avoid.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47838
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Port Forwarding Not Working
« Reply #9 on: May 14, 2014, 10:24:20 AM »

Can you test with VS and uPnP enabled?

If DMZ is working, this could be a configuration issue...
What ports values are you using?
Is this to a PC or some device?
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

wilsonhew

  • Level 1 Member
  • *
  • Posts: 6
Re: Port Forwarding Not Working
« Reply #10 on: May 14, 2014, 10:30:05 AM »

Yup, tested VS with uPNP enabled.

I am trying with port 80, 443, 8443, 22, 5001, 1701, 500 and 4500.

It is a NAS. To eliminate issue with the NAS, I tested PF to a web server with port 80, 443 and 8443.

This is what I am trying to figure out, it works with my DIR-615 but not the 850L.  ???
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47838
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Port Forwarding Not Working
« Reply #11 on: May 14, 2014, 10:35:18 AM »

Are you trying to gain access to the NAS or web server from a remote location?
I know have use D-Link DNS NAS and to access FTP, i'm only using port 21.
Thats one test you could try, set up port 21 for FTP and see if remote FTP works, if it also fail, I presume there is a configuration issue somewhere or something in FW.

If this fails, I recommend that you phone contact your regional D-Link support office, ask for level 2 or higher support.

Please let us know what they say.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting