• June 16, 2019, 06:04:10 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Infrared mode not detected?  (Read 5293 times)

TKorho

  • Level 2 Member
  • **
  • Posts: 28
Infrared mode not detected?
« on: November 07, 2013, 08:48:54 AM »

Hi,

I have used my DCS-2132L for some days now. Being the engineer I am, I have tested most everything.

One thing I can't seem to get working is Infrared sensing. The IR picture that is.
  • PIR detection seems to work ok
  • IR illuminator seems to work: it clearly lights up under controls. As TrackIR5 user I know what IR light looks like
  • ICR IR cut remove filter seems to work, it clearly clicks when toggled
  • ICR change also changes color mode beetween color/bw. And some optical features.

But under no conditions I can "see in dark". No matter how close the objects are, the picture is plain dark when using IR lighting only. Gain, ICR and night modes do not seem to change this. I have manually toggled each of these, in any combination that I can think of, and I see nothing in darkness. So far I have not detected anything in IR darkness. Next I'll have to test with positive IR emitter to test.

This could be explained if ICR toggle does not change the filter, but software mode of the color/bw only. I can not tell as I have not confirmed what happens during the toggle "click". The picture *looks* a bit more blurry when ICR is off (=the filter is off), which matches what I do know about IR optics. But still not any kind of detection.

How is it supposed to work? Is my camera defective? Do anyone have example pictures with the IR lighting? You don't seem to find any by googling.
Logged

TKorho

  • Level 2 Member
  • **
  • Posts: 28
Re: Infrared mode not detected?
« Reply #1 on: November 07, 2013, 10:07:43 AM »

Oh, and when the ICR is active, the field of view is slightly more light on the right side. Not illuminated, but more lighter (grainy). This hints that IR mode is active. But still nothing.
This is strange. IR illumination is on, probably ICR mode as well, video works. What is the problem?

And: when using automatic ICR mode, it never turns off (to day mode) by itself, even in plain daylight, looking out the window. Otoh, I don't have oversaturation problem looking out, but it doesn't seem to work add I would expect.
« Last Edit: November 07, 2013, 01:27:11 PM by TKorho »
Logged

TKorho

  • Level 2 Member
  • **
  • Posts: 28
Re: Infrared mode not detected?
« Reply #2 on: November 13, 2013, 03:27:50 PM »

After testing some more: the IR illumination and detection does work. It just worked just couple of inches. Objects are visible in complete darkness, but only about 2-3 inches away. Blocking the illumination led proves that it is infrared... So my unit must be partly defective. Too bad, that night time functionality is part of the requirements for home intrusion detection.
Will try with additional IR illumination, but then it is return to store...
Logged

RYAT3

  • Level 10 Member
  • *****
  • Posts: 2110
Re: Infrared mode not detected?
« Reply #3 on: November 13, 2013, 04:05:17 PM »

this is the strangest camera screw up

your daytime picture is fine?

Logged

TKorho

  • Level 2 Member
  • **
  • Posts: 28
Re: Infrared mode not detected?
« Reply #4 on: November 14, 2013, 02:08:59 AM »

Thanks for the interest. :) I was fishing for it.

Yes, otherwise the camera works just as expected. I have it on-line right now, and have setup up medias and events. They work. The IR and ICR activate on command as expected. I see no visual problems with ICR mechanism or IR illumination or LED/window. PIR works also quite well. I'll still need to test it with using TrackIR IR illuminator as an alternate IR light source to see if the problem is IR sensitivity or illumination.

The problems are blindness in dark, and not working ICR auto-mode.

The motion tracking control is quite clumsy, considering intended use as security device. But that is quite normal poor UI capability, I think.
Logged

RYAT3

  • Level 10 Member
  • *****
  • Posts: 2110
Re: Infrared mode not detected?
« Reply #5 on: November 14, 2013, 03:57:37 AM »

You have tried adjust image settings in the firmware?

You do here the full click on icr cutout? Or maybe more of a pop?

Logged

TKorho

  • Level 2 Member
  • **
  • Posts: 28
Re: Infrared mode not detected?
« Reply #6 on: November 14, 2013, 06:07:07 AM »

I do not understand your question. No, I have not done anything inside the firmware, not as in touching the software itself.

I have only adjusted image settings from the web user interface. And yes, of course directly to the camera since the MyDlink version is so limited. I have tried different exposure modes, as well as played with gain, and other settings. (See my post into surplus logs thread).

I have changed ICR and IR modes in the Advanced tab : that is the only way to do it known to me. And yes, the ICR actuator does seem to physically change the filter: between a slightly bluish and a clear one. I do not know/remember which is which. IR led illumination also works when commanded manually. I think that IR bound to ICR also works, but the ICR mode never changes automatically, so I have to change it manually.
Logged

TKorho

  • Level 2 Member
  • **
  • Posts: 28
Re: Infrared mode not detected?
« Reply #7 on: November 23, 2013, 07:51:52 AM »

I finally got besides the camera at night and was able to test some things. No screenshots, sorry, but I will introduce them later.

It really looks the IR detection ability of the system is very inferior (dysfunctional). I tested it with the Camera's local IR illuminator and with TrackIR5 as IR source. Both worked the same, so it is not about DCS-2132L small IR illuminator.

The visual range with IR was very very small. I could see a jar within 5 cm, dimly, and a glass within 8cm. Another object was near invisible within 12-15 cm. Very very dim (positive) shadow, but not really visual, it would have been imperceptible if I had known it is there.

The ICR filter worked as expected: even the external illumination totally disappears when ICR is set to block-IR. And things are (poorly) visible when the filter is off. And IR illumination and picture works the very same independent of the source.

So it now looks like it has to be poorly functioning (dysfunctional) camera sensor on IR band. If the camera is advertised as night cam, then it must see more then 20cm. Otherwise the cam works quite ok. Too bad.
Logged