D-Link DSL Modem/Routers > DSL-520B

Avaya VPN phone behind Router behind DSL-520B ADSL Modem - Hanging at Discover

(1/2) > >>

(Reposting this from Reddit here in hopes someone may be able to help)

Background: A few weeks back my AT&T 2wire Gateway suffered a hardware failure and I had to look into a replacement modem.

My existing setup was like this:
WAN ---<2 Wire configured into bridge mode >--- Wireless Router (Configured with PPPOE login info)>----LAN

I did some research and settled on the D-Link DSL-520B, which apparently had some routing functions but I understood these could be disabled (a must since I didn't want to have any issues with my VPN phone contacting the call server). I set everything up, initially having some issues correctly configuring the DSL-520B into bridge mode but afterward was successful. Everything works fine however my VPN phone for work now is unable to fully connect. I enter my secure credentials and it appears to build the VPN tunnel successfully however it hits "Discover x.x.x.x" and hangs there, where it would usually pick up my number and successfully log me in.

I looked at it with voice support folks in my office and had no luck, everything on the phone itself and the way I have things setup looks good. I had even ensured any ports necessary were properly forwarded, however that had not been previously necessary. Even plugging into the modem directly did not allow the phone to connect. It appears all routing functions are disabled on the DSL modem however it would appear SOMETHING is still preventing this from working as it used to. I'm rather out of ideas and was hoping someone would be familiar with this hardware.

Any help that can be provided would be greatly appreciated.


* What Hardware version is your modem? Look at sticker under modem.
* Link>What Firmware version is currently loaded? Found on the modems web page under status.
* What region are you located?
Is the new modem in bridge mode?
Is the wireless router still being used? What Mfr and model is the wireless router?

We always recommend bridging ISP modems if possible and let the external routers handle any PPPoE.

* Check ISP MTU requirements, Cable is usually 1500, DSL is around 1492 down to 1472. Call the ISP and ask. Link>Checking MTU Values
* For DSL/PPPoE connections on the router, ensure that "Always ON" option is enabled.

Will confirm some of these and answer in full once home in about 30 minutes :)

If your still using an external router with the Modem, might try putting your VPN phone IP address in the host routers DMZ.

Let us know when you can...

Okay, to cover the questions answered:

Hardware version of my DSL-520B is: T1
Firmware is NA_1.10
Region: NAM

New modem is in bridge mode, worked with D-Link Support to ensure everything is right.

Wireless router is an ASUS RTN56U, which handles PPPoE.

DSL MTU settings are correct and verified with AT&T. Keep in mind everything except the modem was "as-is" prior to this. The old ISP modem/gateway was setup in bridge mode before it died and this setup all worked fine prior to this.


[0] Message Index

[#] Next page

Go to full version