• September 20, 2019, 06:19:40 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DHCP Out the WAN Port  (Read 32081 times)

soundman87

  • Level 1 Member
  • *
  • Posts: 1
DHCP Out the WAN Port
« on: February 01, 2013, 08:27:24 AM »

I have an issue with the ebr-2310 router.  It is Hardware Revision C1 with Firmware Version: 3.00

If I disable the DHCP server, it starts issuing DHCP addresses to devices connected to the WAN port.  As soon as turn the DHCP server back on it no longer issues addresses out the wan port.

I have an address range of 192.168.5.0 in the office with a DHCP server on the file server.  I then have this router connected up with the wan port connected to the office network.  The lan ports are connected to a couple of devices that are on a 192.168.1.0 address range that I can not change.  I then have port forwardings setup so that I can access the 192.168.1.0 devices from my office desk through the router.

Devices on the office network are getting DHCP addresses from the router.  It even shows up in the system logs on the ebr-2310 router.  How can a fix this.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47763
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DHCP Out the WAN Port
« Reply #1 on: February 01, 2013, 08:33:42 AM »

Are you trying to use this as an actual router or do you have the file server acting as a DHCP server?

Can you draw us a diagram of what your network looks like?
Example:ISP Modem>Router<>any swtiches><Wired devices
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

jyakimic

  • Level 1 Member
  • *
  • Posts: 4
Re: DHCP Out the WAN Port
« Reply #2 on: June 26, 2013, 12:00:03 PM »

Bump:

I've just had the exact same issue with the same revision and firmware number!  It was sending DHCP OUT of the WAN port!  I've just updated to firmware 3.01 and will update with whether the issue is corrected with the firmware upgrade.

DHCP OUT the WAN port!  Crazy.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47763
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DHCP Out the WAN Port
« Reply #3 on: June 26, 2013, 12:00:46 PM »

Hmmm, that seems odd behavior.

Keep us posted on results.

Bump:

I've just had the exact same issue with the same revision and firmware number!  It was sending DHCP OUT of the WAN port!  I've just updated to firmware 3.01 and will update with whether the issue is corrected with the firmware upgrade.

DHCP OUT the WAN port!  Crazy.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

jyakimic

  • Level 1 Member
  • *
  • Posts: 4
Re: DHCP Out the WAN Port
« Reply #4 on: June 26, 2013, 12:28:58 PM »

Extremely odd.  Updating to firmware 3.01 fixed the issue.  I used 2 separate brand new routers of this model/revision on 3.00 for testing (I have dozens of them sitting here for a project- glad the firmware update solved the issue).  Never heard of anything like it.



Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47763
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DHCP Out the WAN Port (RESOLVED)
« Reply #5 on: June 26, 2013, 12:30:46 PM »

Wondering if something was just hung up on the router and a factory reset was needed or a clean load of FW.

Glad it's working for you know. Enjoy.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

jyakimic

  • Level 1 Member
  • *
  • Posts: 4
Re: DHCP Out the WAN Port
« Reply #6 on: June 26, 2013, 12:35:04 PM »

The problem followed multiple brand new routers of the same revision and fw.  I have a few dozen of th EBR-2310s sitting here, so testing was an easy option. The update to fw 3.01 ended up being the fix. 
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47763
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DHCP Out the WAN Port
« Reply #7 on: June 26, 2013, 12:44:41 PM »

Good to know and hear. Thanks for sharing and posting.

Enjoy.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting