• June 24, 2019, 09:19:37 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Email Alerts again..  (Read 8954 times)

TBone81

  • Level 1 Member
  • *
  • Posts: 6
Email Alerts again..
« on: October 27, 2011, 02:03:26 PM »

Hi.

Im trying to get my 655B1 to send the log file to my gmail account.

I have read almost every post on this forum about this but i just cant get it working.

My firmware is 2.01.

I get this message via syslog when i send a test mail

syslog: [email failed]envelope from address info@yourrouter.com not accepted by the server

I have tried everything, gmail, hotmail as "from" and "to". different ports 465, 587, 25. Different ways of typing my login and so on..

I dont think it is my ISP that is blocking.

I have no problems sending a mail from outlook express using my gmail account.

Any ideas how this can be solved or is it a firmware bug?

Thanks Thomas. 

« Last Edit: October 27, 2011, 02:04:59 PM by TBone81 »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47483
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Email Alerts again..
« Reply #1 on: October 27, 2011, 02:42:20 PM »

Have you set the SMTP server to your ISP's SMTP address?
Mines set for: *@cableone.net
Recipient set for: myemail@netscape.net> where you can put in the gmail email address here.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

TBone81

  • Level 1 Member
  • *
  • Posts: 6
Re: Email Alerts again..
« Reply #2 on: October 27, 2011, 02:58:06 PM »

Hi Furrynutz ;D

My smtp is set for smtp.gmail.com.
I have no mail service at my ISP, but maybe i can find their smtp and port settings.
 
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47483
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Email Alerts again..
« Reply #3 on: October 27, 2011, 03:05:49 PM »

ya, Try using the ISP SMTP. You should be good. Even though you don't use there email, you should still be able use their SMTP server. I might call them and ask to be sure and tell them that once in a while that the router needs to send logs via there server.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

Hard Harry

  • Guest
Re: Email Alerts again..
« Reply #4 on: October 27, 2011, 04:37:09 PM »

First try what Furry says, since there is a pretty good chance your SMTP will allow outgoing email no matter who the sender. If that doesn't not work, you need to create a email address under your ISP's domain (ie yourname@comcast.net) and set that as the FROM and then set your Gmail as the TO. Then you would just use 25 with no authentication, or what ever configuration your ISP suggest for a email client. If that doesn't work, you can look around for a email relay server.

Email is like DNS, that on the surface its super easy, but once you start digging down....
Logged

TBone81

  • Level 1 Member
  • *
  • Posts: 6
Re: Email Alerts again..
« Reply #5 on: October 27, 2011, 08:42:46 PM »

Thanks ;) I will give it a try when i get home.
Logged

TBone81

  • Level 1 Member
  • *
  • Posts: 6
Re: Email Alerts again..
« Reply #6 on: October 28, 2011, 05:38:28 AM »

Hi again :)

I just tried Furry´s suggestion.

From Email Address : xxxx@gmail.com     
To Email Address : xxxx@gmail.com     
SMTP Server Address : smtp.ips.com  
SMTP Server Port : 25, 465 and 587     
Enable Authentication : check     
Account Name : xxx@gmail.com     
Password : xxxx     
Verify Password :   xxxx

That didn´t work, i now get this message via syslog with port 25:

syslog: [email failed] authentication failed (method login)

Guess i will have to contact my isp to get a mail acount then..

Reporting back;-)

  
« Last Edit: October 28, 2011, 05:54:05 AM by TBone81 »
Logged

TBone81

  • Level 1 Member
  • *
  • Posts: 6
Re: Email Alerts again..
« Reply #7 on: October 28, 2011, 06:04:06 AM »

Wait.....

It works ;D

I did this:

From Email Address : xxxx@gmail.com     
To Email Address : xxxx@gmail.com     
SMTP Server Address : smtp.ips.com 
SMTP Server Port : 25     
Enable Authentication : uncheck

Sender is unknown but that doesn`t matter, thank you very much guys.

Have a nice weekend ;)

Thomas.       


Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47483
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Email Alerts again..
« Reply #8 on: October 28, 2011, 07:20:53 AM »

Enjoy.  ;)
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting