• October 20, 2019, 04:34:18 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: 1 2 [3]

Author Topic: Wireless stopped working way quicker than before!  (Read 28213 times)

Megabite

  • Level 1 Member
  • *
  • Posts: 12
Re: Wireless stopped working way quicker than before!
« Reply #30 on: November 08, 2008, 03:16:08 PM »

I have not tried a static IP address yet, mainly because my ISP uses dynamic IPs.  Probably there is no relation with router installations is there??

Sorry, I meant a static IP address on your wireless computer that is connecting to the WBR-2310, not the WAN port on the router.

Cheers

[Update]

Sorry about the poor quality pic in this link.  This is the only component that gets hot:

http://www.freeimagehosting.net/image.php?79e8a75089.jpg
« Last Edit: November 08, 2008, 04:04:26 PM by Megabite »
Logged

jonesb

  • Level 2 Member
  • **
  • Posts: 33
Re: Wireless stopped working way quicker than before!
« Reply #31 on: November 09, 2008, 04:35:55 AM »

I think that both of the wireless PC have "static IP addresses.  Here is a repeat of my so-far most successful settings for the WBR-2310:

1) Reverted to Firmware 1.04 from 1.05

2) Gave DHCP reservations to my main PC (where the router is) and to the other two in the house using wireless.  Each reservation required a router reset (Save Changes) - and the reservations appeared in the list - I used IP 192.168.0.100 for the main PC and 192.168.0.101 and 192.168.0.102 for the two wireless ones plus Mac addresses.

3) Changed the DHCP lease time from 180 to 9999.

So does this mean that each PC uses the same IP to connect, i.e. .....101 and .....102??

Logged

Megabite

  • Level 1 Member
  • *
  • Posts: 12
Re: Wireless stopped working way quicker than before!
« Reply #32 on: November 09, 2008, 09:40:59 AM »

No, you are still using the DHCP server on the WBR-2310 to assign IP addresses to your wireless computers.  Therefore, if the DHCP server on the router fails, your computers will not recieve IP addresses.  What I've done in this case is either:

1. Setup a different DHCP server and disable the one on the WBR-2310 or
2. Set a static ip address on the wireless computer itself (start > settings > control panel > network connections > properties on "wireless network connection" > Internet Protocol (TCP/IP), properties) 

Logged

bjrichus

  • Level 3 Member
  • ***
  • Posts: 119
Re: Wireless stopped working way quicker than before!
« Reply #33 on: November 09, 2008, 11:42:35 AM »

1. Setup a different DHCP server and disable the one on the WBR-2310 or
2. Set a static ip address on the wireless computer itself (start > settings > control panel > network connections > properties on "wireless network connection" > Internet Protocol (TCP/IP), properties) 

Megabite,

That's another interesting thought - that our problems are the DHCP server in the router.

While I don't have a problem setting up a DHCP server on Unix, I've never done it on Windows (XP to be exact). So I'm going to have a play with at least one of the packages pointed to form here:

http://techrepublic.com.com/5208-11189-0.html?forumID=82&threadID=177162&messageID=1801117

I'll let you know how it all goes....

 ::)
« Last Edit: November 09, 2008, 12:26:32 PM by bjrichus »
Logged

jonesb

  • Level 2 Member
  • **
  • Posts: 33
Re: Wireless stopped working way quicker than before!
« Reply #34 on: November 10, 2008, 05:04:23 AM »

Just above, Megabyte said:

2. Set a static ip address on the wireless computer itself (start > settings > control panel > network connections > properties on "wireless network connection" > Internet Protocol (TCP/IP), properties)

Sounds good - and I checked my PCs that this could be done.

So, what static IP do I set.  The one(s) I had assigned using DHCP on the master PC with the router?

Or can I set a static IP on the master PC first and then set the other two PCs to find that one using the Megabyte solution 2.

BTW folks, other boards in these threads are reporting some new firmware from a Russian web site to solve all this mess.  Personally I'd be very leery of that.

Logged

Megabite

  • Level 1 Member
  • *
  • Posts: 12
Re: Wireless stopped working way quicker than before!
« Reply #35 on: November 10, 2008, 08:32:05 AM »

So, here's what happened over the weekend during my testing of the router with the cover off:

Heat:
No noticeable heat issues anywhere inside the router except for VR1 and VR2 chips.  Maybe these are Voltage Regulator chips?  No idea.

Runtime:
Using BST, I sent about 50GB of data over the wireless, until I noticed it failed and the client lost its IP address.  Without rebooting the router, I set a static IP address onto the wireless computer and continued to run BST, but this time it was running very slowly.  Before the DHCP issue, I was getting ~1.5MB/s, now I was getting about 50KB/s.   The admin page was still accessible and I could see that the router had NOT yet rebooted.

After leaving it run like this overnight, I noticed this morning that BST failed again, but this time I could not access or ping the router, although the wireless still said it was connected.  Under closer examination, I noticed that the "heartbeat" LED as I call it, was on solid (the LED that is directly to the right of the power LED - circle with a triangle inside).  The Wireless LED was still flashing and my WAN LED was flashing oddly (~6 quick flash, then steady on ~3-4 seconds, repeat).  At this point, I could only SEE the SSID, but no longer connect at all.

I've let the router in this state for further investigation when I get home from work.

It seems that there is a two stage failure here:

1. DHCP Server failure
2. Catastrophic wireless failure.

I do not believe this is a heat related issue though (which is a good thing!), so maybe it is some sort of firmware bug still.  I will try the same test with the DI-624 rev D firmware (maybe even the Russian one!) and see what happens.


Cheers

Logged

XPhile

  • Level 1 Member
  • *
  • Posts: 6
Re: Wireless stopped working way quicker than before!
« Reply #36 on: November 14, 2008, 10:05:59 AM »

Hello;

Try that Russian Firmware. 

I did and it stopped me from pulling out the rest of my hair trying to resolve all the problems that this router gave me.

If it doesn't work for you, flash the router back to a WBR
 

You'll find the DI-624 firmware here:
http://ftp.dlink.ru/pub/Router/DI-624/Firmware/Rev%20D/
(save the file that ends with ".bin".)
 
Logged
Pages: 1 2 [3]