• September 20, 2019, 05:22:35 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Login Error. What's wrong w/it?  (Read 3238 times)

jangotate

  • Level 1 Member
  • *
  • Posts: 3
Login Error. What's wrong w/it?
« on: August 21, 2010, 09:18:41 PM »

My DGL-4100 just started this today after adding a new device into MAC Filter. Whenever I log in or change from one page to another, I get the following:

An error occurred on this page. This might be because you are
not properly logged in, for example just after a reboot.
Press OK to go to the login page, or Cancel if you want to see
the error message.

Then:

The error on line 107 of http://192.168.151.1/gateway.js is:
"missing ; before statement".

Has anyone seen this before with the 4100 or any other model? Tried rebooting it several times. Among the minor annoyance of getting these pop-ups, it no longer displays all of the devices currently connected to my LAN. Haven't tried doing a hard reset, and would like to avoid it. I haven't backed up my settings for quite a while.
Logged

genestet

  • Level 1 Member
  • *
  • Posts: 1
Re: Login Error. What's wrong w/it?
« Reply #1 on: September 05, 2010, 08:05:10 AM »

The fix is to not use any special characters, especially an apostrophe, anywhere in the configuration, DHCP, GameFuel rules, etc. This also fixes the other problems mentioned. This seems to apply to some other Dlink routers as well.
« Last Edit: October 22, 2010, 09:16:26 AM by genestet »
Logged