• October 23, 2019, 10:45:55 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: failed to install  (Read 6826 times)

kathykearny

  • Level 1 Member
  • *
  • Posts: 1
failed to install
« on: September 26, 2009, 11:04:40 AM »

I bought the DWA-142 wireless adapter last January and it worked just fine until I recently had to reformat and reinstall Windows XP SP2. Now whenever I try to install the driver for the network adapter I get a message saying that it failed to install. What can I do?
Logged

kevinla

  • Level 3 Member
  • ***
  • Posts: 107
Re: failed to install
« Reply #1 on: September 29, 2009, 05:18:10 PM »

I would install the latest adapter.

http://www.dlink.com/products/?pid=DWA-142&tab=3

Click on drivers.

If that does not work work, I would contact customer sevice.

Logged

marmoduke

  • Level 3 Member
  • ***
  • Posts: 164
Re: failed to install
« Reply #2 on: July 01, 2010, 10:17:35 AM »

Drivers for DWA-142

Download on another computer from this FTP site:

ftp://ftp.dlink.com/Wireless/dwa142/Drivers/

Choose the latest...which actually is not the very latest...

Install the driver on the desired computer from the ZIP file, following directions.

Once it is installed and working, you can use Microsoft update to get the VERY LATEST driver for this NIC from MARVELL.
Logged