D-Link Forums

D-Link Wireless Routers for Home and Small Business => COVR-3902-US => Topic started by: mloc3 on January 18, 2018, 06:00:10 PM

Title: Can't get IPV6 working
Post by: mloc3 on January 18, 2018, 06:00:10 PM
My ISP has native ipv6.  The covr wont pull the DNS automatically for some reason so I manually input googles.  Then I can't get it to assign ipv6 addresses.  It pulls a WAN address but that is it.
Title: Re: Can't get IPV6 working
Post by: FurryNutz on January 18, 2018, 06:01:56 PM
Have you enabled IPv6 and or set up any advanced SLACC or ULA configurations?
I don't have Ipv6 so I can't test this...

Whats the ISP modem Mfr and model #?

My ISP has native ipv6.  The covr wont pull the DNS automatically for some reason so I manually input googles.  Then I can't get it to assign ipv6 addresses.  It pulls a WAN address but that is it.
Title: Re: Can't get IPV6 working
Post by: mloc3 on January 18, 2018, 06:17:15 PM
I am using the default settings.  I use an arris  SB6190.  IPV6 works fine with my google wifi router as well an my Netgear R8000p, just does not work with covr.
Title: Re: Can't get IPV6 working
Post by: FurryNutz on January 18, 2018, 06:50:38 PM
OK. I'll pass this on to D-Link for review.

I recommend getting into a different Arris modem. The 6190 has issues not related to this of course.  ::)
Title: Re: Can't get IPV6 working
Post by: FurryNutz on January 19, 2018, 08:23:28 AM
This issue has been reported to D-Link and is under review.  ;)
Title: Re: Can't get IPV6 working
Post by: Gattsu on January 22, 2018, 07:33:30 AM
Internet Service Provider?

Can you please try it again with the settings below?

Internet Connection: Auto Configuration
DNS Type: Obtaina DNS server address
Enable DHCP-PD: Enabled
Enable Automatic IPv6 Assignment: Enabled
Enable Automatic DCHP-PD in LAN: Enabled
Auto configuration Type: SLAAC+Stateless DHCP

My router does not receive DNS IPv6 but my computer does and my internet on IPv6 works fine.

Try testing you IPv6 with this site: http://ipv6-test.com/

I am using the default settings.  I use an arris  SB6190.  IPV6 works fine with my google wifi router as well an my Netgear R8000p, just does not work with covr.
Title: Re: Can't get IPV6 working
Post by: FurryNutz on January 23, 2018, 10:39:03 AM
Does this help any?
http://forums.dlink.com/index.php?topic=73003.0 (http://forums.dlink.com/index.php?topic=73003.0)
Title: Re: Can't get IPV6 working
Post by: mloc3 on January 25, 2018, 12:25:00 AM
Internet Service Provider?

Can you please try it again with the settings below?

Internet Connection: Auto Configuration
DNS Type: Obtaina DNS server address
Enable DHCP-PD: Enabled
Enable Automatic IPv6 Assignment: Enabled
Enable Automatic DCHP-PD in LAN: Enabled
Auto configuration Type: SLAAC+Stateless DHCP

My router does not receive DNS IPv6 but my computer does and my internet on IPv6 works fine.

Try testing you IPv6 with this site: http://ipv6-test.com/

I am using the default settings.  I use an arris  SB6190.  IPV6 works fine with my google wifi router as well an my Netgear R8000p, just does not work with covr.
Those are the default settings and nope it is not working.  I have Charter Spectrum (Former TimeWarner).  Works fine with my netgear r8000p and google wifi.  I do notice I pull a very different IPV4 ip with the Covr than I do with the other routers.
Title: Re: Can't get IPV6 working
Post by: FurryNutz on January 25, 2018, 08:48:35 AM
"I do notice I pull a very different IPV4 ip with the Covr than I do with the other routers."

Can you give an example?

Title: Re: Can't get IPV6 working
Post by: mloc3 on January 25, 2018, 11:11:34 AM
"I do notice I pull a very different IPV4 ip with the Covr than I do with the other routers."

Can you give an example?
Normal ip I pull with other routers start with 172, with the Covr I always get a 104.  Anyway tried mac clone and it didn't make a difference.  I have a WAN ipv6 address but the clients get nothing but the link-local.  This router will also not pull an ISP DNS at all, the other routers do, though I use googles DNS anyway.
Title: Re: Can't get IPV6 working
Post by: FurryNutz on January 25, 2018, 11:14:39 AM
And you use the SB 6190?

a 172 address is a private IP address in most cases. If your ISP is giving a public address, it should be of a ##.##.###.### format string.
Title: Re: Can't get IPV6 working
Post by: GreenBay42 on January 25, 2018, 12:25:26 PM
Turn the power off your modem for a minute before connecting the covr and see if the ipv4 address changes.  Modem is probably holding the MAC of the other router.
Title: Re: Can't get IPV6 working
Post by: Gattsu on January 25, 2018, 01:09:22 PM
Have you spoken to your ISP? Have them look at it from their side, if IPv6 packets are being exchanged or not. Setting the IPv6 to Auto Detection or Auto Configuration should have worked with the ISP's native IPv6 network.
Title: Re: Can't get IPV6 working
Post by: mloc3 on January 25, 2018, 03:22:34 PM
And you use the SB 6190?

a 172 address is a private IP address in most cases. If your ISP is giving a public address, it should be of a ##.##.###.### format string.
My ISP gives 172.88.xx.xxx.  I use the SB6190
Title: Re: Can't get IPV6 working
Post by: mloc3 on January 25, 2018, 03:25:06 PM
My ISP can see the modem has an ipv6 address.  I can see the WAN IPV6 address in the Covr GUI,  But as I said the Covr is only assigning the clients the link-local address only.
Title: Re: Can't get IPV6 working
Post by: FurryNutz on February 22, 2018, 05:16:57 PM
Any update on this?  ???

My ISP can see the modem has an ipv6 address.  I can see the WAN IPV6 address in the Covr GUI,  But as I said the Covr is only assigning the clients the link-local address only.
Title: Re: Can't get IPV6 working
Post by: mloc3 on February 26, 2018, 10:08:52 PM
Nope gave up on this router for the second time.  Went to Netgear Orbi (worked but was ugly), now Linksys velop in black.
Title: Re: Can't get IPV6 working
Post by: FurryNutz on February 26, 2018, 10:19:50 PM
Ok. Sorry it didn't work out for you.

Ya, the Orbi isn't the best looking equipment out there.  ::)

Good Luck.