D-Link Forums

D-Link Connected Home => DSP-W215 => Topic started by: kasovnik on December 03, 2016, 06:53:22 AM

Title: DSP-W215 connects to router, but does not show up in my devices via d-link app
Post by: kasovnik on December 03, 2016, 06:53:22 AM
Hello,

just bought a new DSP-W215.
I've set it up  with the Home app for android, but it does not show under my devices screen.
Tried few times with no luck. Everything is ok, the green led is solid, but nothing under my devices screen.
What can could be wrong?
Its Firmware External Version: V2.02
Firmware Internal Version: V2.02b04

The router is Mikrotik.

I've downloaded new firmware, but since the device not showing up in my devices, can not update it.
How to update manually and to try setup again?

A manual IP address, gateway and DNS would be highly appreciated.

Thanks in advance!
Title: Re: DSP-W215 connects to router, but does not show up in my devices via d-link app
Post by: kasovnik on December 04, 2016, 06:54:41 AM
Did managed to upgrade the firmware, to: Firmware External Version: V2.04
Firmware Internal Version: V2.04b04.

Managed to connect mydlink home app, and it immediately and automatically  upgrade the firmware to: Firmware External Version: V2.22
Firmware Internal Version: V2.22b05.

Now the plug is in my devices list, but keeps saying installing new firmware........... although the green led is solid and connected to router.

P.S. Now rebooted the plug, connected automatically, on the app it keeps saying "please reboot your device"

Any ideas?

Title: Re: DSP-W215 connects to router, but does not show up in my devices via d-link app
Post by: kasovnik on December 04, 2016, 08:43:53 AM
ok, now flashed with: Firmware External Version: V2.21
Firmware Internal Version: V2.21b01

and the plug seems to be connecting to the mydlink service, since reporting online and firmware upgrade needed to Firmware External Version: V2.22
Firmware Internal Version: V2.22b05.
Once the upgrade happens no status is being reported tot he mydlink service :(
The device is on and connected (green led), but mydlink home app says offline.

So Firmware External Version: V2.21
Firmware Internal Version: V2.21b01
this version seems to be working but can not be used, because of the obligatory upgrade needed :(

Please, someone?
Title: Re: DSP-W215 connects to router, but does not show up in my devices via d-link app
Post by: FurryNutz on December 13, 2016, 11:18:48 AM
I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this. We find that phone contact has better immediate results over using email.
Let us know how it goes please.
Title: Re: DSP-W215 connects to router, but does not show up in my devices via d-link app
Post by: kasovnik on December 17, 2016, 05:06:30 AM
No reply from any support, that I wrote to :(
Tried all kind of configurations and the only way its working is to connect  the DSP to my neighbor's router (a simple TP-Link 740N) :)
Anyway that was a test drive, and I can not demand from the guy to use his network, only because the damn DSP doesn't like my Mikrotik dual NAT :)
That's sad since my dlink cloud cameras are working hassle free with my network :(
In some way the latest firmware is not compatible either with a dual NAT networking, nor Mikrotik routers :(
Since there's no simple way to manually configure the DSP (only with mydlink app and DHCP), I have no possible use cases with this product.
Considering to try to return it, or sale it second hand :(
Title: Re: DSP-W215 connects to router, but does not show up in my devices via d-link app
Post by: FurryNutz on December 17, 2016, 09:47:30 AM
Have you tried putting the DSP in the DMZ on your dual NAT router? Dual NAT is not recommended for most client side devices like DSP and other D_Link products. As you can see, it creates problems.
Title: Re: DSP-W215 connects to router, but does not show up in my devices via d-link app
Post by: FurryNutz on January 30, 2017, 07:00:03 AM
Any status on this?  ???

No reply from any support, that I wrote to :(
Tried all kind of configurations and the only way its working is to connect  the DSP to my neighbor's router (a simple TP-Link 740N) :)
Anyway that was a test drive, and I can not demand from the guy to use his network, only because the damn DSP doesn't like my Mikrotik dual NAT :)
That's sad since my dlink cloud cameras are working hassle free with my network :(
In some way the latest firmware is not compatible either with a dual NAT networking, nor Mikrotik routers :(
Since there's no simple way to manually configure the DSP (only with mydlink app and DHCP), I have no possible use cases with this product.
Considering to try to return it, or sale it second hand :(