D-Link Forums

D-Link IP Cameras for Home => DCS-960L => Topic started by: Blubber on August 01, 2016, 09:39:59 PM

Title: myDlink Lite won't connect to DCS-960L - SOLVED
Post by: Blubber on August 01, 2016, 09:39:59 PM

Posting this here in case anyone else is unable to get their camera connected to their network via the myDlink Lite app.

While trying to get the app to connect my new camera to the network, it kept saying it couldn't connect every time I entered my WiFi password. After trying this for two hours, I tried turning encryption completely off on my router. The camera connected on the first try. After this, I logged into the camera as well as my router and re-enabled WPA2 encryption.

I appears that rather than trying the various levels of encryption when connecting, the camera/app just tries none and hard fails if that doesn't work.

I would kindly suggest D-Link engineers allow their cameras/apps to support the basic encryption protocols that are widely used out of the box rather than forcing users to battle them as long as I did.
Title: Re: myDlink Lite won't connect to DCS-960L - SOLVED
Post by: RYAT3 on August 01, 2016, 10:43:15 PM
Interesting.. I do not remember those type of problems. 

Which F/W and which Router are you using?
Title: Re: myDlink Lite won't connect to DCS-960L - SOLVED
Post by: Blubber on August 01, 2016, 10:54:00 PM
I used the original FW it came with, which was 1.1.05. After getting everything connected, I upgraded it to the latest which is 1.3.05.

I have a Buffalo WXR-1900DHP router.

Either way, got it working now and just wanted to capture this info somewhere online to save someone else the pain.
Title: Re: myDlink Lite won't connect to DCS-960L - SOLVED
Post by: FurryNutz on August 02, 2016, 06:50:17 AM
All D-Link cameras support wireless encryption protocols out of the box. They wouldn't be able to release them if they didn't. May have been a wireless handshaking issue between the camera and the router...