D-Link Forums

The Graveyard - Products No Longer Supported => Routers => DIR-850L => Topic started by: bhwsyd on April 12, 2014, 05:18:06 PM

Title: Unable to add device to mydlink (RESOLVED)
Post by: bhwsyd on April 12, 2014, 05:18:06 PM
Hi all

I am unable to add my 850L to mydlink. I have tried both setting up an account from within the router software as well as trying to add to an existing account. The same error message appears along the lines of:

"Unable to add device to your mydlink account, error is BINDERR005"

Other relevant details that might help:
Firmware v1.09. Sydney, Australia. Bigpond cable modem, Motorola SB5100.

The 850L connects to the modem through the WAN port, then I connect to a 16 port Gigabit switch, hence only one LAN port in use.

Otherwise it runs perfectly, well I'm still annoyed you can't use the broadcast address for WOL!
Title: Re: Unable to add device to mydlink
Post by: FurryNutz on April 13, 2014, 09:11:37 AM
I presume you have pre-setup an account first at the mydlink.com web site then register from within the router?
Title: Re: Unable to add device to mydlink
Post by: bhwsyd on April 13, 2014, 03:43:07 PM
Yes that is correct. I also just set up a new one just in case... but same outcome.

What is the BINDERR005?
Title: Re: Unable to add device to mydlink
Post by: Falls PC on April 14, 2014, 04:35:11 PM
I've been dealing with this problem for months also. Not happy with this dlink router at all.
I have the DIR-816L

Mine is the same error code, but says this:
A[Unable to add this device to your mydlink account]We were unable to add this device to your mydlink account. Please make sure your device is connected to the Internet, reboot your device, and try again later. (Error code: BINDERR005)

I've tried everything.
Drops connections all the time, piece of junk, I'm ready to replace it. Had a Belkin for 7 years with no problems then tried this as an upgrade, turns out it's more like a downgrade.
Title: Re: Unable to add device to mydlink
Post by: Falls PC on April 14, 2014, 04:50:13 PM
Forgot to mention, it's obviously connected to the internet or I wouldn't be here.
Title: Re: Unable to add device to mydlink
Post by: Falls PC on April 14, 2014, 04:57:46 PM
same stupid think with the firmware information, damn cheap service. I get this:
No response, Please make sure you are connected properly to the internet.

What a stupid response! This is the stupid kind of help you offer? Make sure your connected, are you kidding me?

Then the stupid router times out every time I blink and I have to log in again, I'm so sick of that!!
I have worked with a lot of different routers and always thought that d-link's were good, this is my first one, and my last. I will never recommend these to a customer either.
Title: Re: Unable to add device to mydlink
Post by: FurryNutz on April 14, 2014, 06:33:18 PM
@ Falls PC


Internet Service Provider and Modem Configurations

I recommend that you both phone contact your regional D-Link support office and ask for help and information regarding this. We find that phone contact has better immediate results over using email.

Ill forward this to my contact and see if there is any issues regarding this...

Let us know how it goes...Im currently connected and registered with my DIR-868L with MDL.

All routers i've tested from D-Link have worked well out of the box...I enjoy D-Link products and have never had any major issues. Most issues seen here are configuration issues or environmental.
Title: Re: Unable to add device to mydlink
Post by: bhwsyd on April 14, 2014, 07:52:23 PM
Well thanks to Falls PC's note I played around a little more.

That was the exact error message I was receiving regarding BINDERR005.

I decided to check for a firmware update within the router and it readily found 1.10WW. So no connection issues on that front.

After installing this firmware update, mydlink registration worked fine!

I'd have to conclude that there was some sort of an issue inside 1.09 (or maybe a an error within the router from the installation, but I doubt it).
Title: Re: Unable to add device to mydlink
Post by: FurryNutz on April 15, 2014, 09:35:03 AM
Glad you got it fixed and the FW udpate worked. I presume that maybe there could have been a MDL update and maybe a cause of incompatibility with v1.09. I'll recommend users to update to v1.10 if they are having problems getting the ruoter to connect to mydlink.com.

Thank you for sharing and enjoy.
 ;)
Well thanks to Falls PC's note I played around a little more.

That was the exact error message I was receiving regarding BINDERR005.

I decided to check for a firmware update within the router and it readily found 1.10WW. So no connection issues on that front.

After installing this firmware update, mydlink registration worked fine!

I'd have to conclude that there was some sort of an issue inside 1.09 (or maybe a an error within the router from the installation, but I doubt it).
Title: Re: Unable to add device to mydlink
Post by: FurryNutz on April 15, 2014, 09:42:29 AM
Any status on this? Seems to be resolved...

I've been dealing with this problem for months also. Not happy with this dlink router at all.
I have the DIR-816L

Mine is the same error code, but says this:
A[Unable to add this device to your mydlink account]We were unable to add this device to your mydlink account. Please make sure your device is connected to the Internet, reboot your device, and try again later. (Error code: BINDERR005)

I've tried everything.
Drops connections all the time, piece of junk, I'm ready to replace it. Had a Belkin for 7 years with no problems then tried this as an upgrade, turns out it's more like a downgrade.
Title: Re: Unable to add device to mydlink (RESOLVED)
Post by: climbski on May 17, 2016, 08:49:58 PM
I had the same problem, but found I hadn't installed the mydlink addin for my browser.  After that I was able to add my router.
Title: Re: Unable to add device to mydlink (RESOLVED)
Post by: FurryNutz on May 18, 2016, 07:42:03 AM
Thanks for the info and feed back. Hope it will help future users.

Enjoy.  ;)

I had the same problem, but found I hadn't installed the mydlink addin for my browser.  After that I was able to add my router.