D-Link Forums

The Graveyard - Products No Longer Supported => Routers => DIR-850L => Topic started by: Pbryanw on June 14, 2013, 03:01:35 PM

Title: OpenDNS DNS Servers not working with 845L Router
Post by: Pbryanw on June 14, 2013, 03:01:35 PM
Hi,

I'm using a D-Link 845L With the latest 1.01b02 firmware. My PC is set to automatically get a reserved address via DHCP. DNS Relay is switched off and I have entered the Open DNS Servers in Router settings: Setup -> Internet and also in my Windows Network Configuration.

However when I go to OpenDNS's test pages at http://www.opendns.com/support/article/64
all three tests fail. And when I try and run Namebench I get the warning message "Your router or Internet Service Provider appears to be intercepting and redirecting all outgoing DNS requests. This means you cannot benchmark or utilize alternate DNS servers".

I am with Virgin Media here in the UK, and use their modem connected to my 845L. However the modem can also be used as a router and when I connect my PC this way (removing the D-Link) the OpenDNS DNS servers seem to work.

So, I'm not sure whether the problem lies with the D-link or with my ISP - any help appreciated.

Thanks, Paul
Title: Re: OpenDNS DNS Servers not working with 845L Router
Post by: FurryNutz on June 14, 2013, 04:15:30 PM
Link>Welcome! (http://forums.dlink.com/index.php?topic=41537.0)


Internet Service Provider and Modem Configurations

Hi,

I'm using a D-Link 845L With the latest 1.01b02 firmware. My PC is set to automatically get a reserved address via DHCP. DNS Relay is switched off and I have entered the Open DNS Servers in Router settings: Setup -> Internet and also in my Windows Network Configuration.

However when I go to OpenDNS's test pages at http://www.opendns.com/support/article/64
all three tests fail. And when I try and run Namebench I get the warning message "Your router or Internet Service Provider appears to be intercepting and redirecting all outgoing DNS requests. This means you cannot benchmark or utilize alternate DNS servers".

I am with Virgin Media here in the UK, and use their modem connected to my 845L. However the modem can also be used as a router and when I connect my PC this way (removing the D-Link) the OpenDNS DNS servers seem to work.

So, I'm not sure whether the problem lies with the D-link or with my ISP - any help appreciated.

Thanks, Paul
[/list]
Title: Re: OpenDNS DNS Servers not working with 845L Router
Post by: Pbryanw on June 14, 2013, 04:29:21 PM
  • What region are you located?
UK

  • Are you wired or wireless connected to the router?

Wired via built-in Realtek networking

  • Has a Factory Reset been performed?

Yes, DNS Server reverts back to OpenDNS on reset but after I've changed a few settings the problem comes back. However, I'm not sure what setting brings back the problem.

Internet Service Provider and Modem Configurations

  • What ISP Service do you have? Cable or DSL?

Cable

  • What ISP Modem Mfr. and model # do you have?

Virgin Superhub v1 (http://"http://help.virginmedia.com/system/selfservice.controller?CMD=VIEW_ARTICLE&ARTICLE_ID=3859&CURRENT_CMD=SEARCH&CONFIGURATION=1001&PARTITION_ID=1&USERTYPE=1&LANGUAGE=en&COUNTY=us&VM_CUSTOMER_TYPE=Cable") in Modem Mode

Thanks for your help with this and your welcome. Resetting to factory defaults seems to fix the problem but then after I've reconfigured the router to my liking the problem comes back. Would a change one setting at a time and see if the problem comes back approach be advised?
Title: Re: OpenDNS DNS Servers not working with 845L Router
Post by: FurryNutz on June 14, 2013, 04:50:41 PM
Yes, attempt changing one item at a time and see. Could be a mis-configuration as well.
Title: Re: OpenDNS DNS Servers not working with 845L Router
Post by: Pbryanw on June 15, 2013, 12:53:29 PM
Hi,

I think I've found what was causing the problem. The problem starts when I register the Mydlink Service under Mydlink settings. As I did this every time I reset my router, it's probably why the OpenDNS servers would work for a while then stop working.

I can replicate the problem by removing the router from the mydlink web service (which also resets the router), reload a config (at which point OpenDNS servers start working again) then register with Mydlink. Almost immediately the OpenDNS servers will stop working. Or I can reset to factory defaults and as soon as I register with Mydlink, the OpenDNS servers stop working too.

As I don't use the Mydlink web service I think I'll just not register for the time being, and hope this problem is fixed in the future.
Title: Re: OpenDNS DNS Servers not working with 845L Router
Post by: FurryNutz on June 15, 2013, 01:21:27 PM
I recommend that you phone contact your regional D-Link support office and inform them about this. At least let them know.
Title: Re: OpenDNS DNS Servers not working with 845L Router
Post by: Pbryanw on June 15, 2013, 01:35:53 PM
I recommend that you phone contact your regional D-Link support office and inform them about this. At least let them know.

Hi, would my local Dlink phone support office be open to bug/fault reports like this or is there an online way to report faults like this?

I've tried signing up to the eSupport portal but can't get it working with Internet Explorer 10.

Thanks again for your help.
Title: Re: OpenDNS DNS Servers not working with 845L Router
Post by: FurryNutz on June 15, 2013, 01:40:13 PM
Of course.

Also try using other browsers like FF or Opera.
Try setting IE10 into compatibility mode and re-try.
Title: Re: OpenDNS DNS Servers not working with 845L Router
Post by: Pbryanw on June 15, 2013, 03:20:06 PM
Hi, after two support accounts created and disabled, it seems that when copying the password from my email, a space was being inserted after the last letter and this was causing the problem with logging in. My third account was successfully, and I have now lodged a support request and will see if D-Link can provide further support with this.

Thanks again for your help.
Title: Re: OpenDNS DNS Servers not working with 845L Router
Post by: FurryNutz on June 18, 2013, 07:37:35 AM
Glad you found the problem. Keep us posted if D-Link responds with this. I presume this kind of function didn't happen on any other router using any kind of Browser?
Title: Re: OpenDNS DNS Servers not working with 845L Router
Post by: Pbryanw on June 19, 2013, 07:20:34 PM
Glad you found the problem. Keep us posted if D-Link responds with this. I presume this kind of function didn't happen on any other router using any kind of Browser?

Hi, the only other router I've used is the Virgin Superhub's built-in one and that didn't have this problem. Also I've tried Internet Explorer, Firefox as well as Chrome and when I register with Mydlink on the 845L all three start having problems with OpenDNS.

Will update once I get a solution or cause for this from D-Link support. Thanks again.
Title: Re: OpenDNS DNS Servers not working with 845L Router
Post by: FurryNutz on June 19, 2013, 09:00:33 PM
Title: Re: OpenDNS DNS Servers not working with 845L Router
Post by: Pbryanw on June 20, 2013, 06:46:47 AM
Hi, no it's ok. The Superhub has two modes - when it's in modem mode it functions solely as a Cable modem. When it's in Router mode it functions as a router/modem.

When I have it connected to the D-link 845L I put it into modem mode and all the Superhub's router functions are switched off and made inaccessible (I presume by the Superhub's software).
Title: Re: OpenDNS DNS Servers not working with 845L Router
Post by: FurryNutz on June 20, 2013, 06:54:44 AM
I still wonder if the modem is fully in modem mode though.  :-\

Keep us posted.
Title: Re: OpenDNS DNS Servers not working with 845L Router
Post by: FurryNutz on June 20, 2013, 10:47:15 AM
Just FYI, I found a un-official beta build of FW for the 845L. It hasn't been posted anywhere officially and isn't public. Might give this a try. You can always downgrade if something happens.
Title: Re: OpenDNS DNS Servers not working with 845L Router
Post by: Pbryanw on June 20, 2013, 11:49:14 AM
Hi, thanks for that. Can I ask what the firmware version is and how I can get it (I couldn't see a link in your post)?
Title: Re: OpenDNS DNS Servers not working with 845L Router
Post by: FurryNutz on June 20, 2013, 11:53:30 AM
Sent you a PM.
Title: Re: OpenDNS DNS Servers not working with 845L Router
Post by: Pbryanw on June 24, 2013, 11:01:19 AM
Hi, I'm not sure if this is a workaround or solution but Dlink got back to me and asked if Parental controls were enabled. Looking at these options, I didn't know you could enable OpenDNS from the Parental Control settings.

So I went to Setup -> Parental Controls, enabled Advanced DNS and the OpenDNS DNS Servers started working again - this was with Mydlink enabled too.

Not sure why OpenDNS stops working when Mydlink is enabled, but this seems the best solution available at the moment. Thanks to FurryNutz for your help on this thread.
Title: Re: OpenDNS DNS Servers not working with 845L Router (RESOLVED)
Post by: FurryNutz on June 24, 2013, 11:04:46 AM
Cool. Glad you got it working. I'll keep this in mind for anyone else using OpenDNS.

Enjoy.

Hi, I'm not sure if this is a workaround or solution but Dlink got back to me and asked if Parental controls were enabled. Looking at these options, I didn't know you could enable OpenDNS from the Parental Control settings.

So I went to Setup -> Parental Controls, enabled Advanced DNS and the OpenDNS DNS Servers started working again - this was with Mydlink enabled too.

Not sure why OpenDNS stops working when Mydlink is enabled, but this seems the best solution available at the moment. Thanks to FurryNutz for your help on this thread.