D-Link Forums

The Graveyard - Products No Longer Supported => DIR-655 => Routers => Europe DIR-655 => Topic started by: Ronneske on December 22, 2009, 10:51:58 AM

Title: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: Ronneske on December 22, 2009, 10:51:58 AM
Have the A4 model.
Also having the constant reboots.

What i did try:
- 1.32NA firmware. Same issues.
- 1.32NAB09, beta firmware.Same issue. Cannot revert back to previous firmware but that will solve in time.

Opened the cover some days ago. Noticed the ceramic heat sinks are quite hot.

So today i found an obsolete CPU cooler. Disconnected the fan from the CPU heat sink and put it onto the open DIR-655.
Put it running on 5Volts otherwise the fan is freezing the DIR-655 :) with a separate power adapter (fill fix this later...)
Until now and this is a record for this DIR-655: almost 6 hours up and running without any reboots.

So i think it is a heat issue in the A4 models.

So anybody with frequent reboots varying from minutes to hours: try getting it cooler.

Will try to find some traditional heat sinks and glue them to the chip-set and see if it runs without the fan this way. If not will mount the fan fixed into the top of the DIR-655.

A small 70x70 fan costs about 7 Euro so that will not kill you. If you need it to run on 5 Volt get an 7805 with it to reduce the input voltage and you can directly tap it from the plug !

Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: Ronneske on December 22, 2009, 01:48:59 PM
10 and 15 minutes without rebooting !!!

Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: ozzed3 on December 22, 2009, 02:57:08 PM
Mine Freezes up about once a day. It doesn't reboot, just goes into "Brick-mode" until I reboot it. I haven't tested if it has anything to do with heat but I wouldn't think so as I live on an attic floor in Sweden with 3 "outer walls" and it's always pretty cool in here. One additional thing you can try is to align it perpendicularly. Or vertically or whatever.. I think there's a stand included for it even.. Just watch out for cords pulling the device downwards if you do this.
Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: Ronneske on December 22, 2009, 03:43:26 PM
Are you using P2P (torrents) a lot? If so this might exhaust your internal memory. Any logs indicating such.
Saw there is an option to write the log to a syslog device, did not try this. e.g. don't know how to.

12 hours and 10 minutes without rebooting !
Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: ozzed3 on December 22, 2009, 03:57:32 PM
Yes, I do use torrents a lot and I usually leave my pc on at night to seed. Is the number of connections the issue or something?
Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: Ronneske on December 23, 2009, 01:46:45 AM
Probably this is the cause of the 'hang-up'. Try reduce the # of concurrent torrents and/or the number of peers per torrent.

22 hours and 10 minutes without reboot !
Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: ozzed3 on December 23, 2009, 02:14:17 AM
I tried reducing the number of total connections and number of peers per torrent. Seems to work for now at least.. 9 hours up and running without issues. Kind of lame that a "Platinum" product like the 655 can't handle some stress through :(
Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: Ronneske on December 23, 2009, 02:56:02 AM
Guess the limit are predefined looking at the available memory. And P2P isn't that router friendly.
So if you can manage with some reduction in the number of peers/torrents think that is a good workaround.

Have some heat-sinks at hand to mount on the CPU but not sure this will be as good as the fan freezing the router:).
Also need to find some paste to mount them.

Still no reboot after 23h 20min.....
Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: ozzed3 on December 23, 2009, 08:35:54 AM
1000 global connections and 50 peers per torrent is what I set it to now.. This makes it barely runable but oh well.. Let's see how it goes.

Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: Ronneske on December 23, 2009, 01:31:54 PM
Mounted some not to big heat sinks on the CPU and switch ic.
Not that stable as with the blower and the ceramic heat sinks.

But maybe with some large ones this just might do it.

Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: Ronneske on December 23, 2009, 04:11:22 PM
Fan back on top seems the most stabilizing factor. Noticed some repeated wireless disconnects running only on the new heat sinks (yep i exchanged the ceramic heat sinks with some given aluminium ones, thanks to PA2WJE).

The fan from an old CPU cooler does most of the good work until now.
Had a reboot after approx 24 hours. But this could have been the expiring lease time of the DHCP by the Linksys that triggered this. Also the heat sinks are just sticked on top of the CPU with cooling paste. Not a very solid mount this way.
Tomorrow will do some soldering again so i can put the open DIR into the electic cupboard with the fan on top and have it replace the competition brand router. See what happens...

Fortunatly the DIR-655 was given to me by a colleague who could not operate her work with the intermediate reboots. So some serious redesign on this hardware is the best that can happen to it.
Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: Ronneske on December 27, 2009, 12:01:08 PM
Router is running with the fan and the ceramic heat sinks for some days now. I put cpu cooler paste between the IC and the ceramics to enforce some better heat conductance.

Besides frequent wireless restarts in the log of the router with fw 1.32NA Beta 09 is doing almost what it should do. Route the network.

Maximum uptime with fan cooling the system: approx 24 hours. No hang-ups and while running P2p with 6.3Mb at the peak.

Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: Ronneske on December 30, 2009, 10:51:23 AM
Didn't manage to get it stable even with a fan cooling it.

Switched back to my Linksys WRT150N.
Even upgraded this to DD-WRT. Looking good so far.

bye
Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: ozzed3 on December 30, 2009, 02:29:06 PM
That's where I am headed too as soon as Linksys gets their throughput speed sorted. Not really a point in having a gigabit WAN port when their top model can only handle a puny 130MB of throughput.
Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: Ronneske on December 30, 2009, 03:35:46 PM
it is doing LAN traffic at say 90Mbits/sec so maybe a second hand wrt150n and flash it with DD-WRT is also an option.
Increase the wifi signal a bit to 100mW (max is 251mW but that will kill the device one day) so the signals are good.

Will however try the DIR-655 my father has if it is showing similar defects as my given router.

Best wishes for 2010 !

Ron - PA3FAT
Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: Ronneske on January 03, 2010, 07:28:42 AM
Flashed the WRT150N to DD-WRT. Works great no issues.

Also tested my fathers DIR-655 for the LAN download speed between the PC and the NAS.
Here also not a straight line of high throughput. Peaks upto 300Mb but also drops to 4Mb for longer times.
So this is not very convincing onthe throughput time over LAN for the DIR-655.

Will stick to my WRT and see what DLink think they need to do to have me as a customer.

Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: Ronneske on January 22, 2010, 09:07:11 AM
Okay i am back to the DIR-655 experiments.

Flashed with new NA 1.33 beta.
Up and running for 21 hours+ since yesterday.

Did not connect wireless yet and also no p2p traffic yet.

But i must admit things are looking good so far :)

Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: alien on January 23, 2010, 11:03:54 AM
i go back to the eu frimware because of the bad wireless in the NA firmware.
Going back is possible but not without risk.
Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: Ronneske on January 23, 2010, 12:59:23 PM
I am also back to the EU version (via the RU fw).
But seems the NA was more stable (42 hours without reboot). The EU already showed some wireless disconnects and reboots (always around the time was synchronized....)

Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: alien on January 23, 2010, 11:51:43 PM
mine is stable for two days no reboot.

what timeserver do you use?
i use ntp1.dlink.com
Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: Ronneske on January 24, 2010, 03:37:11 AM
yes that i am using now.

Reconfigured my router with the backup of the settings. So the non dlink ntp server was initially installed.
14 hours uptime since last night.

Let's see....

Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: Ronneske on February 05, 2010, 11:57:44 AM
Still not stable.

FW restored to 1.21EU
Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: Ronneske on February 08, 2010, 11:33:32 AM
That 1.21EU fw is not good at all.

Moved back to 1.33NA. At this moment 1 day+ uptime.
Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: leowood on February 19, 2010, 08:43:00 PM
Still not stable.

FW restored to 1.21EU

I believe the DIR 655 QOS absolutely can't handling P2P downloading, QOS can do  nothing except hang up the router and slow down the network , So just disable the QOS, you can got a very solid router.
Title: Re: A4: Is it getting too hot or is it firmware: guess it is heat !!!!
Post by: leowood on February 22, 2010, 06:52:44 PM
I believe the DIR 655 QOS absolutely can't handling P2P downloading, QOS can do  nothing except hang up the router and slow down the network , So just disable the QOS, you can got a very solid router.

Good news, today received replaced 655 from Dlink office, seems everything is OK,
Just download 4 torrent files meantime in office (100M connection), total 3300 sessions,  250 ESD connections, around 5M/s speed,QOS enabled, router is stable, no ping delay and packet lost under heavy download,

so the conclusion is QOS is applicable for heavy torrent handling no problem,
my old DIR 655 is a defective,
So sadly I waste 3 days on this,