D-Link Forums

The Graveyard - Products No Longer Supported => D-Link Multimedia and USB => DSM-520 => Topic started by: pomoster on December 06, 2009, 02:32:49 PM

Title: Won't turn on :(
Post by: pomoster on December 06, 2009, 02:32:49 PM
Hello there,

I recently tried to turn on my DSM520 after having left it dormant (and unplugged) for about five months.  It worked fine before but now it won't turn on at all.

The only pieces of evidence I have for you are:

1) When I first plugged it in the optical port on the back flashed red (very slowly).
2) After about ten minutes of being plugged in the optical port went completely red and has stayed there since.

So, the power button won't turn the unit on but there is some form of electrical activity happening given the optical port light.

Any ideas? 

Thank you!
Title: Re: Won't turn on :(
Post by: fccgrant on December 07, 2009, 11:26:46 AM
I'm assuming that you used the power button on the front panel rather than the remote control.

The only thing I can think of now is to press the Reset button on the back and hope it recovers.