D-Link Forums

D-Link Range Extenders => DAP-1860 => Topic started by: Sychost on June 21, 2020, 12:09:14 PM

Title: Doesn't Work With Higher 5Ghz Channels
Post by: Sychost on June 21, 2020, 12:09:14 PM
I used this extender for years and then suddenly it stopped working.

After spending countless hours troubleshooting why my 5Ghz couldn't be picked up, I rolled back the firmware and no change. I attempted to fix this several times (a few hours each time) over the past 6 months. Numerous resets, firmware updates, router reboots, and router firmware updates all to no avail.

I then spent an hour with several D-Link support techs (and I use that term loosely) a few months ago to first be told my extender didn't support 5GHz, even though I assured them it worked perfectly for years, to eventually be told it was out of warranty buy a new one.

Today I gave it one more shot, rolled back firmware and still only my 2.4Ghz network would show. Then while browsing my router settings I notice the 5Ghz band channel setting was 165. I selected a double digit channel and low and behold the extender now worked on the 5Ghz band and connected to my router.

It's shocking how bad D-Links tech support is. I post this here to hopefully help anyone else that suddenly finds their DAP-1860 no longer working on their 5GHZ network. If so check your networks channel.
Title: Re: Doesn't Work With Higher 5Ghz Channels (RESOLVED)
Post by: FurryNutz on June 22, 2020, 08:02:27 AM
Yes, the DAP is a dual band DAP. Not sure why they told you it wasn't. Most if not all current DAPs are dual band.
Glad that the channel change worked.

Enjoy.  ;)