D-Link Forums

The Graveyard - Products No Longer Supported => D-Link Storage => DNS-320 => Topic started by: byethecrin on February 10, 2020, 01:16:31 PM

Title: Recovering Data - Please Help
Post by: byethecrin on February 10, 2020, 01:16:31 PM
I am really hoping someone can help me try and recovery my data from my DNS320L? I am in a pretty sticky situation as stupidly it had the only copy of my wedding video on it (I know), so I need to try everything I can to recover.

I have seen the sticky on this board and have installed the hard drives in a W10 desktop and tried the software listed to no avail.  The drives spin and are visible, but I cannot work out how to access them?

Does anybody have any experience and could give me some starting points, as I genuinely think I may be doing something wrong and I am not really sure which tools would work with the formatting on the drive.

I've recovered windows drives previously, using things like chkdsk and sureface level checking tools (the Lenovo T series BIOS one being really effective). But I wasn't sure if there was something similar I could do with these discs, given 1. they have been in a RAID and 2. They are linux formatted.

If anyone has any pointers this would be massively appreciated, as I am realising how much of an amateur I am in this set of circumstances.

EDIT - Just to add it was RAID0 configured.

Title: Re: Recovering Data - Please Help
Post by: FurryNutz on February 10, 2020, 01:21:37 PM
Please review this:
http://forums.dlink.com/index.php?topic=41400.0 (http://forums.dlink.com/index.php?topic=41400.0)

Title: Re: Recovering Data - Please Help
Post by: ivan on February 10, 2020, 02:05:04 PM
First thing - DO NOT let windows do anything to your drives especially connecting then directly to to computer motherboard.

Next thing equip yourself with a) a usb/sata powered adapter to attach the drives to the computer  b) a working copy of the R-Studio recovery software.

Next, make a sector level disk image of both drives assuming you haven't tripped the a) problem.

Next, download the R-Studio manual and read it - if there is anything you don't understand ask.

Next, make sure you have enough free space on the computer drive (or an external USB hard disk for the software to download the data to.

Possible problems:
a) mounting the drives in a windows computer and booting into windows usually allows windows to mess up the software raid of the disks which can make the data unrecoverable.
b) trying to read a Linux formatted disk on windows without the necessary IFS (installable file system) driver will also mess up the raid array information data.
c) if you have messed up the raid array information data you may need to use a professional data recovery company.

The other thing I have to say is good luck.
Title: Re: Recovering Data - Please Help
Post by: byethecrin on February 13, 2020, 12:55:34 PM
@FurryNutz - Thanks, had seen that link already and tried the software and although it sees the drives I cannot read them

Ivan - That is a really good reply, thank you so much for the advice! I am going to have a pop at it this weekend.

Few Questions before I start

1. Given its a RAID0 and a single partition, am I going to need both disks attached and make an R Studio image of the whole thing or do one at a time?
2. I have a bootable USB Linux Pen drive (UBUNTU), do you think this would be a better bet (any pointers if so)?
3. If I use Ubuntu, again do I need both drives attached to see the RAID and drive?

PS I have been very careful not to mount the drives in Windows as I was acutely aware of the RAID information.

Title: Re: Recovering Data - Please Help
Post by: ivan on February 14, 2020, 03:16:42 AM
You are going to need both drives available but you need to read the R-Studio documentation.  I haven't used it in several years (retired now) and they might have changed something in the program but the last time it asked for each drive as necessary.

At this point using Linux won't help - you have to assemble the raid array (if it had been raid 1 then it would have been easy) because parts of large files are on both disks in raid 0.

Being a software raid array you need either the device that created the array or the R-Studio software to assemble the array in a form that can be accessed by other operating systems.

Please read the R-Studio documentation and make sure you understand what you are expected to do.  That way you will have a better chance of a successful recovery.  Good luck.