D-Link Forums

D-Link Wireless Routers for Home and Small Business => COVR-2202 => Topic started by: FurryNutz on September 26, 2019, 09:21:55 AM

Title: New - COVR-2202 Firmware v1.04 Build09 Released
Post by: FurryNutz on September 26, 2019, 09:21:55 AM
Firmware: v1.04B09   09/25/2019 NA Region Only
Revision Info
Problems Resolved:   
1.Fix Intel 8265 client ping loss issue
2.Fix IPv6 auto detection not work issue
3.Fix 2.4GHz low link rate issue

1.McAfee support by country code-CA, CN country code not support McAfee, US country code not support MLS-Remove Web filter/MAC filter/Remote control functions in McAfee supported region
2.Only allow Ethernet backhaul connection between CAP and RE< Thank you D-Link.  :D
3.Upgrade ookla speed test agent to v2.6.2.2
4.Upgrade McAfee agent to Dlink-QCA_SHP2.0

Known Issues:
1. There is IOT issue when COVRCOVR-2200 connect with Intel AC8265AC8265. This issue will be fixed in v1.04. See Above.

Get it here: NA Region
COVR-2200 (https://support.dlink.com/productinfo.aspx?m=COVR-2202-US)

Please follow the> FW Update Process (http://forums.dlink.com/index.php?topic=42457.0) to ensure a good FW upgrade is performed.

Let us know how it works for you...

Title: Re: New - COVR-2202 Firmware v1.04 Build09 Released
Post by: Lexist2112 on September 26, 2019, 12:06:03 PM
Thank You...Sir ;D
Title: Re: New - COVR-2202 Firmware v1.04 Build09 Released
Post by: FurryNutz on October 29, 2019, 11:22:47 PM
So pulling out this system today. Verified that Ethernet back haul works with the B point connected to the A point router thru a LAN switch. THANK YOU D-Link.  ;D Very nice since I have a remote location in the home in the basement wired for Ethernet.

 I would like to see if D+Link could change the status of the B point from wireless to wired when and only when the B point is connected via Ethernet if possible:
(https://i.ibb.co/TvjYyhP/COVRPoint-When-Wired.png) (https://ibb.co/r78F9y5)
Would be helpful to visually see that the RBS is connected wired instead of wireless. I didn't see any status change after the B point was connected over a wired connection. Something to consider for the 1203 system as well if it's not already supported.

However, i found a bug, flaw or an oversight of something that I'd like to see get fixed for the 2202 series. Please.
So in router mode we see, Operation Mode in the UI:
(https://i.ibb.co/QfBZ7CY/COVROperation-Mode-Seen-Router-Mode.png) (https://ibb.co/37Xw5MS)

If a user selects the Bridge mode, from the Operation mode drop down menu and applies the settings. The transition to Bridge mode works.
However, when in bridge mode, there is no Operation mode seen in the UI:
(https://i.ibb.co/7GcHRsP/COVR-No-Operation-Mode-Seen-Bridge-Mode.png) (https://ibb.co/fCRbnjf)
So if the 2200 router is in Bridge mode, and a user wants to revert back to "router mode", There is no easy way to get the router configured back to router mode. I looked else where in the UI and didn't find anything to revert back to router mode. Opera and IE11. I had to factory reset the A point and setup the router from scratch which is really inconvenient and doesn't seem logical as it should be able to revert back with a flip of a mode switch in the UI and go back to router mode. A user should not have to factory reset the A point to get back to router mode.
Please review this and please consider adding a UI Operation mode switch so users can revert back to router mode from Bridge mode.

One last request, Please change the word "Bridge" mode under operation mode to "Access Point" or "AP" mode. I think I mentioned this before. Bridge mode seems a bit mis-leading as "Bridge" mode we mostly refer to "wireless bridge mode" where wifi connected as a client to another wifi AP source. The "bridge" mode on 2200 when set operates as a wired LAN connected Access Point for wireless clients to connect too. Thus it should be worded in the UI as "Access Point" mode in the UI instead of "Bridge" mode. Please consider using correct working or nomenclature for the Operation Mode for the 2200.

Since the ethernet backhaul is now supported, i'll be putting this online and seeing how it works out live.  ;D

Thank you for your considerations.
Title: Re: New - COVR-2202 Firmware v1.04 Build09 Released
Post by: FurryNutz on October 31, 2019, 01:22:12 AM
Well I tired to connect my 2202 system only tonite. Had a hard time with just the A point router. Seems to be an odd issue with DNS relay being disabled. I had to clear out and flush DNS caches on PCs to make them work and get internet access. Something I usually don't have to do. After I thought I had things running ok, I connected the B point to a switch I had at my desk just long enough to see the COVR led turn WHITE. I noticed that there was down activity on the switch and on two PCs connected to this switch after the B point seemed to be connected and up and running. So I figured, lets see what happens when I took it and connected it downstairs in the basement behind 5 LAN switches. The B point seem to connect and came to ready while connected to the switch in the basement. However my iphone and pad would not get internet access for unknown reasons. Also saw the Dlink guest network appear as well. This isn't enabled on the A point router. I had DNS relay disabled on the A point router. I turned DNS Relay back on and finally got internet access with the B point. However the system seem to be very unstable for unknown reasons. The A point WiFi seem to stop working as I noticed my cameras had gone off line. I had power cycled them initially after the A point was online, as they would not re-connect to the SSID name and PW previously used with other routers. They usually re-connect with out having to power cycle them. DCs-933L, 936L and 960L.

So I figured there was something wrong with the B point being wire connected. So I disconnected it and let it re-sync wirelessy to the A Point router. It did and my iphone and pad were able to get internet access. Speedtest was kind of bad. Nothing seen over 95Mpbs with them connected to the B point.  :-\

I was hoping to keep the 2202 system online and let it run however my confidence in the wired back haul and stability with DNS Relay left me no choice to remove it and come back to this this weekend and see if I can figure out whats going on. I have other Non D-Link routers and they have worked well with wired back haul using these same switches with no issues. Possible having switches in between could be problematic. My COVR1203 worked last time I had it running, however I can't use it long term as my two NEST controllers don't like it's WiFi signal the rendering them useless with there mobile app.  ::)

More to come.
Title: Re: New - COVR-2202 Firmware v1.04 Build09 Released
Post by: GreenBay42 on November 20, 2019, 12:15:57 PM
Issues (out of order):

1. Change Bridge mode to "AP" or "Access Point" mode - Everyone agrees and the request has been made to HQ.

2. Display Ethernet connection vs wireless - Everyone agrees and has been requested.

3. When in "bridge" mode, you currently have to reset it to get it back to router mode. It was in D-Track and not sure if that will change anytime soon.

4. Make sure both units have the latest firmware and reset them. If you want to use B as backhaul, connect via Ethernet directly to A first to sync them. After you get the white LED, unplug and move to your switches.
Title: Re: New - COVR-2202 Firmware v1.04 Build09 Released
Post by: FurryNutz on November 20, 2019, 01:40:24 PM
Thank you Sir.

Hope to see changes in a future FW update.

I'll reconfirm issues with wired B point,  DNS Relay and Cameras again.  ;)
Title: Re: New - COVR-2202 Firmware v1.04 Build09 Released
Post by: FurryNutz on December 06, 2019, 05:43:06 PM
Ok, so I was able to come back to the 2200 and get it online as I wanted to see how it would do on my home network with the B point wired.
Couple of problems:
1. If I setup the A point router for my networking need prior to putting it on the home network with DNS Relay disabled. I don't get any internet access for some reason. I noticed that my Mac Book Pro what was wired or wireless connected, NO DNS Addresses showed up with DNS Relay disabled. This is the first for me as I normally disable DNS relay on all D-Link routers I've used before. Saw no issues with this until now with the COVR2202. Something with DNS Relay being disabled is not working right.  :(

2. I was able to connect the B point extender downstairs at the end of 5 switches that are daisy chained. 3 DLink DGS105/108 were replaced with HP Pro Curve 1800 series non managed switches. The front LED was solid white after getting connected.
However, speed testing with a Galaxy Tab S2, iPhone 6sP and Mac Book Pro 2018 using Ooklas's speed test app resulted in horrible speeds. Nothing over 12-15Mbps on the down. I turned off and back ON, the wifi radios on each device while near the B Point downstairs so I could ensure they were connecting to the B Point there. I have a different Non D-Link MESH system that was just tested and I see near 900Mbps while using that system.

3. The A point router is unstable for some reason as after I rebooted the A point after DNS Relay was enabled then disabled again to see if WAN side DNS would populate devices, i was no longer able to connect to the A Point router from down stairs behind the last switch. Also noticed that my mac book pro wired or wireless would not get an IP address from the A point router. I also noticed that while I was downstairs with the B point that was wire connected, it was solid WHITE, then started blinking Amber is it seemed to loose connection with the A point router after I disabled DNS relay. I also think that maybe changing the DHCP IP address pool from .2 and .254 to .100 thru .150 and applying this change may have caused instability as well while all other wired network devices were online. I presume something that shouldn't make the router hang or cause the router to stop working correctly. I normally get this up and thought I had a day prior before going live this evening. I guess not.

I'd like someone from D-Link to review this and see if they can reproduce any of these issues. I'm most concerned about the DNS Relay issue since my other D-Link routers haven't exhibited this kind of behavior using those models.

I had to remove the 2202 system from operation.

I'll bring out my COVR 1203 system next to see if this operates the same or differently.
Title: Re: New - COVR-2202 Firmware v1.04 Build09 Released
Post by: FurryNutz on December 07, 2019, 11:02:46 AM
Ok so I updated by 1203 system to v1.08 last nite. I factory reset everything and setup from scratch. I preset the A point router for DNS Relay disabled, set SSID name and PW and set a new DHCP IP address pool of 192168.0.100 to .150. Applied all settings and rebooted. Powered it off and staged everything. I Rebooted my ISP modem, disconnected the host router and connected the A Point router. Just connected 1 wired PC to the A point. The router came online and was getting internet. DNS on my Mac Book Pro is showing ISP DNS correctly. I rebooted the A point router and connected my DGS-1100 main network cable to the A point and connected the Mac Book Pro to the DGS. A point came online. Started showing connected devices. I powered ON the B Point down in the basement that was ethernet connected. It eventually appeared on the routers web page. I then ethernet connected the 2nd B point down in the bed room. IT also eventually appeared online and shows WHITE led on top.

All is good and working. This confirms the 1202 system is working with DNS RELAY disabled.

Wired speed test with my mac book pro shows just under 400Mpbs on the down and 52Mbps on the up on a 1Gb/50Mpbs ISP service. I know the 1203 system doesn't support anything near 900Mpbs and seems capped at 300-400Mbps.

So the entire setup with the 1203 system was smooth and saw no issues with DNS.

Hoping the 2202 system can be looked into. I believe this is a FW issue.
Title: Re: New - COVR-2202 Firmware v1.04 Build09 Released
Post by: FurryNutz on January 01, 2020, 02:28:41 PM
Were you able to confirm what I was seeing with my 2202?

Thank you Sir.

Hope to see changes in a future FW update.

I'll reconfirm issues with wired B point,  DNS Relay and Cameras again.  ;)