D-Link Forums

D-Link Wireless Routers for Home and Small Business => DIR-878 => Topic started by: FurryNutz on March 10, 2019, 09:12:25 PM

Title: WIFI fails to stay OFF using WiFI button in back and rebooting thru UI
Post by: FurryNutz on March 10, 2019, 09:12:25 PM
So I did a factory reset, loaded v1.12 on top of v1.10, factory reset once more then setup from scratch. I skipped the setup wizard.
I configured the router for my needs. I'm using a different WiFi AP for the main wifi. Did not configure WiFi settings. Left default settings. Upon completing the configuration. I pressed the WiFi button in back of the router and saw that both 2.4 and 5Ghz LEDs turned off. I powered off the router and connected it in place as the main host router with the ISP modem. I powered it ON and waited. I noticed that the 2.4G LED came ON green. The 5G LED remained OFF.  :o

I checked the UI and the SSID names were grayed out. Smart Connect Enabled. I pressed the WiFi button in back again and the 5G LED came on. I pressed the WiFi button in back again and both 2.4G and 5G LEDs turned OFF. I did another reboot thru the UI and waited for the router to come back to ready. Again the 2.4G LED turned ON green while the 5G LED remained OFF as the router came to ready. I picked up my Galaxy Tab S2 and opened my wifi scanning app. I saw the default SSID 2.4G name coming from the 878. Again, I pressed the WiFi button in back and the 5G LED came on. I pressed the WiFI button in back again and both 2.4G and 5G LEDs turned OFF. The 2.4G SSID disappeared from the scanning app.

Is this expected behavior? I would hope not. IF the button is pressed turning off both radios, they should remain OFF thru a power cycle until a user presses the button again to turn them back ON. I have not checked to see if disabling WiFi in the UI persists thru a power cycle.
Title: Re: WIFI fails to stay OFF using WiFI button in back and rebooting thru UI
Post by: GreenBay42 on March 12, 2019, 07:50:02 AM
I will have a tech test. My 878 is missing from my desk.  :o >:(
Title: Re: WIFI fails to stay OFF using WiFI button in back and rebooting thru UI
Post by: FurryNutz on March 12, 2019, 07:54:46 AM
Ok. Yes, seems to be reproducible after the few times I rebooted mine with WiFi button disabled.  ::)

Title: Re: WIFI fails to stay OFF using WiFI button in back and rebooting thru UI
Post by: FurryNutz on March 13, 2019, 12:38:52 PM
So for unknown reasons, all Internet went down yesterday while away. I talked others at home to power cycle the router and ISP modem. The 2.4Ghz LED was back ON after the 878 was back online. I didn't get to turn it back OFF as I got home late.  ;)