D-Link Forums

The Graveyard - Products No Longer Supported => D-Link Storage => DNS-323 => Topic started by: turkvu on January 09, 2019, 04:53:23 PM

Title: Used wrong power adapter - any chance to recover?
Post by: turkvu on January 09, 2019, 04:53:23 PM
Hi all - could really use some help. Was cleaning up my closet last night and I ended up switching the power adapters from another unit and my 321 (I know this is the 323 board, but this one is way more active and my understanding is that the two units are very similar). After I realized my error, I plugged in the correct adapters, the other unit booted up fine...unfortunately the 321 did not. I'm getting no lights & no fan, however the drives are spinning up. The unit is not connecting to the network.

I've tried pulling the drives and pressing the power button - no joy.

I've tried hitting the reset button on the back of the unit for 10s - no change in behavior.

Any ideas for how to troubleshoot or proceed? Wondering if there's anyway to get this unit up and running again, or short of that can I recover the data by plugging them into a replacement unit?

Thanks in advance!!
Title: Re: Used wrong power adapter - any chance to recover?
Post by: ivan on January 10, 2019, 02:05:47 PM
First thing, what was the voltage supplied by the wrong unit?  Almost everything revolves round the answer to that question.  I don't have the specs for the 321 (we never used them in my company) but I would assume it required both 12v and 5v from the PSU.  This adds another question. What is the pinout of the unit you incorrectly used?  You have 4 pins to carry voltage to the unit and there is NO standard pinout for that 4 pin plug.  If you got 12v where there should have been only 5v you have a dead unit and I assume no backup of your data.

If you need to try and copy the data from your disks we need to know how they were formatted, Raid 0, Raid 1, Standard or JBOD,  each is different in how you recover data from them.  You would also need some hardware to convert them to USB (the safe way of attaching them to a computer to minimise data loss especially if you are using a windows computer).  RAID 1 is the easiest to recover data from, you have two copies of the data, one on each disk, and you can use a live Linux DVD to do the recovery.  The other require recovery software and then don't guarantee full recovery.

Sorry to be so pessimistic but I have seen it all too many times before I retired.
Title: Re: Used wrong power adapter - any chance to recover?
Post by: turkvu on January 14, 2019, 08:49:30 AM
Hi Ivan - thanks for the response.

I plugged in a unit that supplied 12v @ 7.5a while the correct unit had outputs of 12v@3a and 5v@3a (as you mentioned)

So, sounds like I had 12v where I should have only had 5.

The data was in a Raid0 array.
Title: Re: Used wrong power adapter - any chance to recover?
Post by: ivan on January 18, 2019, 04:00:39 AM

You have two things working against a successful data recovery, RAID 0 require both disks to be without fault and then you need a lot of space on the disks of the computer you are using for recovery. Go to the R-Studio site and download their manual, it gives all the information necessary.  The other problem is that you may have fried part of each disks electronics, the part that deals with data read/write - those things don't like 12v when they are expecting 3.3v (it depends on if the NAS 5v section burned out before anything got to the disks - the disks may run, the 12v section is much more robust).