D-Link Forums

D-Link Wireless Routers for Home and Small Business => COVR-3902-US => Topic started by: mloc3 on November 15, 2018, 04:23:22 PM

Title: Abandoned
Post by: mloc3 on November 15, 2018, 04:23:22 PM
So has this router been abandoned?  No new official firmware in over a year.
Title: Re: Abandoned
Post by: davevt31 on November 15, 2018, 06:24:26 PM
Nope not abandoned, I have asked for status a couple of times without a real response.   I get PMs from one of the forum admins every once and awhile that they haven't forgot us but have nothing new right now.
Title: Re: Abandoned
Post by: GreenBay42 on November 16, 2018, 06:46:53 AM
Firmware has been a SLOW process lately. Not sure if there is a new one planned for this router/extender since we have so few support calls about it. There aren't announcements of upcoming firmware in most cases unfortunately so I do not know.
Title: Re: Abandoned
Post by: mloc3 on November 20, 2018, 08:31:39 AM
Along with other issues I reported in other threads, I have a major issue with the cover showing connected devices in the GUI, or not showing them.
Title: Re: Abandoned
Post by: GreenBay42 on November 26, 2018, 10:46:01 AM
Unfortunately the connected devices issue has been there with all routers with this same GUI. Not sure why it has been an ongoing issue but it is happening with multiple routers. I haven't been told exactly how the router receives information from the clients other than the router will send out ARP requests and if the client doesn't respond back it should remove it from the connected device list UNLESS you either renamed the device or set a reservation - it should be grayed out.  I am not clear how the router knows what the device it other then some generic string the device sends to the router (device name) or if it connects to some magical database with every device in the world matched with mac addresses.
Title: Re: Abandoned
Post by: FurryNutz on November 26, 2018, 01:54:00 PM
I know that some devices mainly older ones had HOST NAME values. This was also user editable. I'm not sure if this was also tied to ARP return results or completely different. I noticed over the years that if I set a custom HOST NAME value on my devices, most routers would see this. I see that some newer devices like IoT and others HW may not have this value anymore or it's hidden and set by the Mfr. I notice with other router mfrs that they also see problems in device naming management and how they get displaying in the UI and managed. Yes, this issue has been on going since the 880L. Kind of hoped that D-Link had this nailed down.