D-Link Forums

D-Link IP Cameras for Home => DCS-936L => Topic started by: happyhere on September 09, 2018, 12:25:58 AM

Title: DCS-936L in Firefox 60 or Firefox 60 ESR
Post by: happyhere on September 09, 2018, 12:25:58 AM

I was using Firefox 52.9 ESR for long time  to view video from DCS-936L firmware 1.05.  It was great and stable all day all week.

Then, today my Firefox is version 60.2 ESR (because of auto update).  It is NOT working now.
 The web UI of DCS936L is now saying to use internet explorer or apple safari and will not show anything in firefox.

I dont have chrome at the moment. But anyone here have workaround for firefox?
Title: Re: DCS-936L in Firefox 60 or Firefox 60 ESR
Post by: GreenBay42 on September 09, 2018, 07:36:21 AM
Thanks for the info (including your other posts). I will have a tech look at on Monday to test.
Title: Re: DCS-936L in Firefox 60 or Firefox 60 ESR
Post by: GreenBay42 on September 10, 2018, 09:42:02 AM
Firefox removed Java support in ESR 60 unfortunately. You will have to use IE 11 or Safari to access the web UI or use ESR 52.9 if you need to use Firefox.
Title: Re: DCS-936L in Firefox 60 or Firefox 60 ESR
Post by: FurryNutz on September 10, 2018, 09:43:37 AM
Thanks for letting us know. I'll have remove 60 and re-install 52.9.  ::)

Firefox removed Java support in ESR 60 unfortunately. You will have to use IE 11 or Safari to access the web UI or use ESR 52.9 if you need to use Firefox.
Title: Re: DCS-936L in Firefox 60 or Firefox 60 ESR
Post by: GreenBay42 on September 10, 2018, 09:55:55 AM
I am not sure what the point is for ESR 60 if they disabled support lol
Title: Re: DCS-936L in Firefox 60 or Firefox 60 ESR
Post by: FurryNutz on September 10, 2018, 09:59:24 AM
Ya, why I thought they were at least letting plug-ins work on ESR. Ya think Mozilla and Java would work things out. If Java is still being used all over, why is browser Mfrs blocking it. Makes it hard on Device Mfrs to develop and support for there customers who by there products that have Java.  ::)
Title: Re: DCS-936L in Firefox 60 or Firefox 60 ESR
Post by: GreenBay42 on September 10, 2018, 10:16:32 AM
Exactly. it is for "security reasons".   ::)  Unfortunately it is not a simple code rewrite for products to not use plugins like java.
Title: Re: DCS-936L in Firefox 60 or Firefox 60 ESR
Post by: FurryNutz on September 10, 2018, 10:23:20 AM
Ya i know, once you have Java included, hard to write it out, spend all that money trying to develop another solution. Test, support. Oy vay.  :-\
Title: Re: DCS-936L in Firefox 60 or Firefox 60 ESR
Post by: happyhere on September 27, 2018, 06:43:18 AM
yeah... problem solved.  I have downgraded to Firefox ESR 52.9 and is back to normal. I have to disable the auto update

The new MacOS Safari 12 also dropped support for the dlink plugin.
Title: Re: DCS-936L in Firefox 60 or Firefox 60 ESR
Post by: FurryNutz on September 27, 2018, 06:51:49 AM
You might try the new 936L FW. I haven't had a chance to try it yet.  ::) It's supposed to fix this I believe.
http://forums.dlink.com/index.php?topic=74133.0 (http://forums.dlink.com/index.php?topic=74133.0)


yeah... problem solved.  I have downgraded to Firefox ESR 52.9 and is back to normal. I have to disable the auto update

The new MacOS Safari 12 also dropped support for the dlink plugin.
Title: Re: DCS-936L in Firefox 60 or Firefox 60 ESR
Post by: llaen on October 27, 2018, 06:01:11 PM
Unfortunately it doesn't. IE-only still. Good luck if you're not using Windows...

You might try the new 936L FW. I haven't had a chance to try it yet.  ::) It's supposed to fix this I believe.
http://forums.dlink.com/index.php?topic=74133.0 (http://forums.dlink.com/index.php?topic=74133.0)
Title: Re: DCS-936L in Firefox 60 or Firefox 60 ESR
Post by: GreenBay42 on October 29, 2018, 07:51:42 AM
Safari 11 and Firefox ESR 52 still work.
Title: Re: DCS-936L in Firefox 60 or Firefox 60 ESR
Post by: FurryNutz on October 29, 2018, 08:58:08 AM
Those are working for me. Be aware that Safari v12 is now no longer working as Apple has removed plug in support. So keep Safari v11 or continue to use FF v52.