D-Link Forums

The Graveyard - Products No Longer Supported => Routers => DIR-601 => Topic started by: lelagirl on April 18, 2018, 09:22:07 AM

Title: one secure website won't load with router (but used to), but will with modem
Post by: lelagirl on April 18, 2018, 09:22:07 AM
Hi,
I just registered and this is my first post, so bear with me if I am not doing everything right.
I have searched these forums, found similar issues, but nothing to help me.

I have a DIR601  H/W=A1, F/W=1.00NA

I am using a laptop with Windows 10.
There is one secure website that will not load (just keeps spinning with white screen).  This just started about a month or so ago.
I never had problems before (been logging in to this website for years)
I have tried using Chrome and also Internet Explorer.

However, when I disconnect my router, and hook up my computer directly to the modem, I am able to get to the website, login and do my work.

I also tried to connect with my smartphone - and got an error - Net::ERR_cert_authority_invalid   - connection is not private - so it didn't connect.
I googled this and tried the below, still not working.  (did someone try to hack me?)

My date/time is ok.
I cleared my brower history, and also flushed the dns - because technical support had me change my ip address several times a few months ago.
I reset the router to default settings, then set up a secure connection changing the SSID.
Security type:   WPA-Personal
Network band:   2.4 GHz
Network channel:   6
IPv4 address:   192.168.0.100
IPv4 DNS servers:   192.168.0.1

TKIP and AES

What else can I try?
 
Title: Re: one secure website won't load with router (but used to), but will with modem
Post by: FurryNutz on April 18, 2018, 12:22:50 PM
Link>Welcome! (http://forums.dlink.com/index.php?topic=48135.0)



Internet Service Provider and Modem Configurations

I would upgrade the FW on this router, its way out of date and last version for this Rev A is 2013:
http://support.dlink.com/ProductInfo.aspx?m=DIR-601 (http://support.dlink.com/ProductInfo.aspx?m=DIR-601)

Link> >FW Update Process (http://forums.dlink.com/index.php?topic=42457.0)

If this still fails, you may need a new DIR series router.
Title: Re: one secure website won't load with router (but used to), but will with modem
Post by: lelagirl on April 19, 2018, 01:51:43 PM
I didn't have any problems back in February, so it wouldn't be the firmware. (but I can still try it)
I don't recall how my security was set up when I initially installed the router, so I don't know if I set it up the same or not.
And this is the first time I tried it using my phone.   My isp is comcast - cable
Title: Re: one secure website won't load with router (but used to), but will with modem
Post by: FurryNutz on April 19, 2018, 04:48:54 PM
Try the FW update then go from there...