D-Link Forums

D-Link IP Cameras for Home => DCS-936L => Topic started by: robman501a on March 19, 2018, 02:23:22 PM

Title: RTSP lag
Post by: robman501a on March 19, 2018, 02:23:22 PM
Hi there, I'm noticing an lag in the RTSP stream.
In VLC I open this ...
rtsp://192.168.1.138:554/play1.sdp
and I notice that there is a few second delay in the video and then it drops out. However, if I use Media Player or any other players I get the same result. When I make an MJPEG connection I get the video in real time with no lag.
The only way I can get a live video stream to work is with the  D-ViewCam app.
When I head to the live video section of the DCS-936L's webpage the video playback in full 1280x720 quality is amazing and it has no issues at all.
So, my question is, why is the playback of the RTSP stream delayed on the computer or any other apps but the device web UI is flawless? Is it my router not being able to keep up?
Title: Re: RTSP lag
Post by: FurryNutz on March 19, 2018, 06:03:51 PM
Using VLC on my Mac Book Pro 2007 and streaming same from my 936L is working and streaming with out dropping the connection. Just watched about 1 minuted of video stream...
Title: Re: RTSP lag
Post by: robman501a on March 20, 2018, 09:55:34 AM
Hmm.. sounds like it's my router than. Would make sense since it has to do more processing to get the desktop to connect to the server rather than just doing it all on the camera's web interface.
I'm using an old Netgear WNDR3700v1 router with DD-WRT build 33679. Maybe it doesn't have enough CPU power or RAM to work with the 936L.
Title: Re: RTSP lag
Post by: FurryNutz on March 20, 2018, 10:54:52 AM
Ya thats kind of old. I gave mine away a while back.

Does the PC maintain a connection if ethernet connected instead of wireless? Maybe need a wireless upgrade as well.

Title: Re: RTSP lag
Post by: robman501a on March 20, 2018, 01:22:21 PM
Yeah, that's the thing. The PC is not wireless and it's on an 10/100/1000 connection and I am connected at 1 Gbps.
Title: Re: RTSP lag
Post by: FurryNutz on March 20, 2018, 02:14:04 PM
I'm using a Mac Book pro 2007 on a wireless connection, 300Mb.

You might give a different router a try and see. The camera would be on wireless and the 3700 only supports up to 450Mb on 5Ghz if I remember right and 300Mb on 2.4Ghz. Maybe 300mb on both. Don't remember for sure.
Title: Re: RTSP lag
Post by: robman501a on March 23, 2018, 11:48:58 AM
Got a new router in mind.
https://www.asus.com/Networking/RT-AC1900P/
This should work amazing!  :D
Title: Re: RTSP lag
Post by: FurryNutz on March 23, 2018, 12:02:15 PM
You should consider this one as well:
http://shop.us.dlink.com/d-link-ac1750-mu-mimo-wi-fi-gigabit-route.html (http://shop.us.dlink.com/d-link-ac1750-mu-mimo-wi-fi-gigabit-route.html)
Title: Re: RTSP lag
Post by: robman501a on March 24, 2018, 12:26:43 PM
What's the Tx/Rx rate of the DCS-936L? I'm running at 72.2 Mbps, is that normal?
Title: Re: RTSP lag
Post by: robman501a on March 24, 2018, 01:28:42 PM
Most curious, the router is super fast but the playback of the camera is worse than my older router. That sucks!  :'(
Title: Re: RTSP lag
Post by: robman501a on March 24, 2018, 06:00:08 PM
Camera is 5 feet in front of the router and RTSP is still behind but MJPG is fine. I guess it supposed to be a few seconds behind for RTSP?