D-Link Forums

D-Link VPN Router => DSR-150 / DSR-150N => Topic started by: rdalhoff on February 19, 2018, 07:56:43 AM

Title: Allow public static IP addresses to access devices on DSR-150 with same IP addr
Post by: rdalhoff on February 19, 2018, 07:56:43 AM
Our church wants to put a DSR-150 between a Century Link C1000Z modem/router and a phone system to better firewall the phone system.  Currently the C1000Z is set up to allow a “Block of Static IP Addresses” using the PPPoE protocol for connect to Century Link.  That works okay but the C1000Z cannot provide the necessary firewalling we want.  The public static IP address are a block of xx.xx.xx.94 netmask IP addresses.  The phone system is configured with three of the public IP address:  xx.xx.xx.89, xx.xx.xx.90 and xx.xx.xx.92, with the gateway is xx.xx.xx.94.

When I put the C1000Z into ‘transparent bridging 0/32’ the DSR-150 does connect successfully to Century Link using the PPPoE protocol.  However it appears that no traffic is passed through the DSR-150 between the public internet and the phone system.

I tried the following setup, but I must be doing something wrong.

Connection Type: PPPoE
Address Mode:  Static IP
Username:  xxxxxxxxxxx@qwest.net
Password:  xxxxxxxxxx
IP Address:  xx.xx.xx.94
IP Subnet Mask:
Authentication Type:  Auto Negotiate
DNS Server Source:  Use these DNS servers  (
MAC Address Source: Use Default    [Century Link said they do not pay attention to the MAC address]

Oddly when the WAN PPPoE login occurs, the Status - Device -WAN1 webpage shows:
IPv4 Address:  xx.xx.xx..94/
with Gateway:
I thought the mask would remain as

I did set IP Aliasing to xx.xx.xx.94 and netmask to supposedly allow the WAN port to know about all the IP addresses on it.

The WAN Routing Mode is set to Classic.

Yet the xx.xx.xx..89, xx.xx.xx.90 and xx.xx.xx.92 IP addresses are not seen by the public network.  Actually xx.xx.xx.94 is not seen by the public internet either.  I cannot ping or access any of these addresses from the public side.  [With the C1000Z in place as a router, I can ping all these IP addresses.]

Even though NAT is disabled, when I connect a laptop to the DSR-150 it does obtain an IP address of so I can access the Admin GUI at

I thought maybe that I should put the xx.xx.xx.94 with netmask subnet in the DMZ, but then the WAN side complained, upon saving its configuration, that I should not have the same IP addresses in WAN as well as DMZ.

What am I setting up wrong on the DSR-150 to get the internal IP addresses visible on the public Internet?
Do I need ot mess with static routing?
DSR-150, Firmware Version: 3.11_WW, Hardware Version: A3
Title: Re: Allow public static IP addresses to access devices on DSR-150 with same IP addr
Post by: FurryNutz on February 19, 2018, 09:59:31 AM
Link>Welcome! (http://forums.dlink.com/index.php?topic=48135.0)

You'll need to contact your ISP to ensure that the ISP modem is in FULL bridge mode and make sure the PPPoE account information and values are correct and correctly entered in to the DSR router. If the DSR router is still not responding after this, I would phone contact D-Link support.he US offers Chat support for consumer products at support.dlink.com. 24/7 as well.