D-Link Forums

D-Link IP Cameras for Home => DCS-2132L => Topic started by: mrfr33z3 on December 21, 2017, 06:06:40 PM

Title: Stuck on "Enable mydlink services" screen
Post by: mrfr33z3 on December 21, 2017, 06:06:40 PM
I cannot find any way to create a mydlink account. I've tried, several times, to enter information under the "No, I want to sign up..." option. I can setup my IP cameras fine, but cannot access them remotely, due to this utter failure. I click the "Next" button, and nothing happens.

I've disabled my firewall and AV software, and have tried on two separate machines now. Both times, there is no indication of anything happening. Clicking "Next" apparently is doing nothing, or the software developers have failed to implement a proper indication of something occurring when that button is clicked.

I have version "B" of the cameras, and my firmware is up to date.

This is a deal-breaker. Is there another way to create an account? Is this service still around? Should I just give up and return my cameras?