D-Link Forums

D-Link Network Storage => DNS-320L => Topic started by: seamonkey on December 22, 2016, 10:18:32 AM

Title: [SOLVED] WINDOWS 10 > UPLOAD TO NAS SLOOOW > DOWNLOAD FROM NAS FAST
Post by: seamonkey on December 22, 2016, 10:18:32 AM
Hi guys, I have an issue with this NAS.
- Windows 10 updated until today.
- NAS with firmware 1.0
- NIC with offload disabled

When I upload the files from Explorer, if they are under 20 MB they loading well (300/400 Mbits), but the larger ones of 20 MB lock/pause at 20 MB then advancing the other 20 MB, at the end the average is 1-5 Mbits

If I download a file from the NAS to my PC, any size, there are no issues (300/400 Mbits).
If I use a virtual machine with Kubuntu, there are no problems.

The problem is Win10 and its NIC driver.
Do you have any experience or suggestions about this issue?

Thank you.
Title: Re: WINDOWS 10 > UPLOAD TO NAS SLOOOW > DOWNLOAD FROM NAS FAST
Post by: RYAT3 on December 22, 2016, 10:21:29 AM
Which nic? Is this a laptop?
Title: Re: WINDOWS 10 > UPLOAD TO NAS SLOOOW > DOWNLOAD FROM NAS FAST
Post by: seamonkey on December 22, 2016, 12:12:52 PM
Hi RYAT3, Yes it' a laptop: Asus K75VJ.
Tks
Title: Re: WINDOWS 10 > UPLOAD TO NAS SLOOOW > DOWNLOAD FROM NAS FAST
Post by: seamonkey on December 22, 2016, 02:26:21 PM
Hi, another information for you.

I try a Win7, another laptop but HP, with the same network card (different driver).
I disabled the LSO and everything works perfectly... upload and download...

The issue is in Win10 NIC driver but why only in the PC > NAS direction? Upload/Write to NAS.

I'm frustrated...
Good night.
Title: Re: WINDOWS 10 > UPLOAD TO NAS SLOOOW > DOWNLOAD FROM NAS FAST
Post by: ivan on December 22, 2016, 02:28:35 PM
It doesn't look as if Microsoft has fixed their Samba upload problem with win10 yet.
Title: Re: WINDOWS 10 > UPLOAD TO NAS SLOOOW > DOWNLOAD FROM NAS FAST
Post by: seamonkey on December 22, 2016, 03:22:26 PM
Hi Ivan, I've other Win10 laptops and PCs and I've not issues.
The problem is the NIC's driver.
Why, I don't found a reason, the upload work for 20MB, then a long pause, other 20 MB, another long pause, etc...
But I must ask to NIC vendo, not only here, because this NAS, with Linux, works perfectly...
If you have some idea, please share it with me.
Thank you.

Quote from: ivan
link=topic=66088.msg277334#msg277334 date=1482445715
It doesn't look as if Microsoft has fixed their Samba upload problem with win10 yet.

Title: Re: WINDOWS 10 > UPLOAD TO NAS SLOOOW > DOWNLOAD FROM NAS FAST
Post by: RYAT3 on December 22, 2016, 04:05:30 PM

I try a Win7, another laptop but HP, with the same network card (different driver).
I disabled the LSO and everything works perfectly... upload and download...


This is what I had to do on my laptop Win7. Disable LSO.    Why do you want to keep it enabled?

To sum up:

Go to Start->Control Panel->Device Manager->Network adapters->Your adapters name (mine is Atheros AR8152/8158 PCI-E Fast Ethernet Controller (NDIS 6.20),  right-click then select Properties. On the Advance tab, find property Large Send Offload (IPv4) and change its value to Disabled then click OK.

If you have a Large Send Offload (IPv4) v2 try setting that to Enable (with the other one disabled of course).

Title: Re: WINDOWS 10 > UPLOAD TO NAS SLOOOW > DOWNLOAD FROM NAS FAST
Post by: seamonkey on December 23, 2016, 12:27:42 AM
This is what I had to do on my laptop Win7. Disable LSO.    Why do you want to keep it enabled?

Hi RYAT3, I've not wrote that I want keep LSO. I wrote that Iíve disabled it everywhere but in this laptop, with Win10 and this NIC/driver, only the upload doesnít work. In all other my systems (win7 and win10 with others hardware and drivers) all is ok.

Anyway, after my last test I understand that the issue is in the NIC driver and not in the NAS.
I close this request and I write to NIC vendor.

Thank you for you time.
Title: Re: [SOLVED] WINDOWS 10 > UPLOAD TO NAS SLOOOW > DOWNLOAD FROM NAS FAST
Post by: FurryNutz on December 23, 2016, 12:56:22 PM
Glad you found the cause. Hope it can be resolved.

Good Luck.