D-Link Forums

The Graveyard - Products No Longer Supported => Routers => DIR-890L => Topic started by: KeyzerSuze on December 13, 2016, 11:47:16 AM

Title: Issues with firmware 1.10
Post by: KeyzerSuze on December 13, 2016, 11:47:16 AM
Hi

Did an OTA upgrade of the firmware ... I was on the original I had in the router ... that was rock solid ..

This new version ... OMG .. I have done a few factory resets and tried re flashing. But now my devices .. android and ios . tablet and phones and sonos devices all keep dissconnecting and re connecting

thought I would check the forums before rolling back

I can't remember which version i had before.

but I have downloaded v1.07, v1.08, v1.09, v.1.10.  I will work my way backwards.

I noticed something about a v1.11 ... im in australia I can't seem to find this version does it fix the wireless issue.

also I run it in AP mode.


I used to have 8-9 device registered with the previous version. now nothing on the client page..
Title: Re: Issues with firmware 1.10
Post by: FurryNutz on December 13, 2016, 11:56:31 AM
Need to upgrade w lan cable only. Wireless can produce bad results.

I recommend getting FW files from your regional D-Link web site first off:
http://support.dlink.com.au/Download/download.aspx?product=DIR-890L&type=Firmware (http://support.dlink.com.au/Download/download.aspx?product=DIR-890L&type=Firmware)

Fillow the fw upgrade process see in my faqs.

Is Smart Connect enabled it disabled? Try both.

You can try the version from the Canada site if you like:
http://forums.dlink.com/index.php?topic=66025.0 (http://forums.dlink.com/index.php?topic=66025.0)
Title: Re: Issues with firmware 1.10
Post by: FurryNutz on July 19, 2017, 03:17:58 PM
http://forums.dlink.com/index.php?topic=66984.0 (http://forums.dlink.com/index.php?topic=66984.0)