D-Link Forums

The Graveyard - Products No Longer Supported => D-Link Storage => DNS-343 => Topic started by: pondandinio on February 15, 2016, 03:26:44 AM

Title: Force Format
Post by: pondandinio on February 15, 2016, 03:26:44 AM
Hi, I've searched but could not find a suitable answer.

I've inherited a DNS-343 from a friend but can not get it to present a usable volume.

The first time I booted it up, it gave me the option to format the 2 disks I had put in it. I set them up as standard disks and they formatted without issue. when I went to add the volume over the network, no volume(s) existed. I went back to the web interface but all the options in the RAID section were either missing or greyed out. As the unit was old and had been sitting on a shelf for years it had firmware 1.03 on it, so I upgraded the firmware to 1.05, rebooted, same issue.

The unit will see the disks, read the smart statuses and the bays show as populated on the OLED but it will not give me the option to reformat or create a volume. (The disks often take a while (2-3mins) before the NAS spins them up).

On the network there is a share (if the correct workgroup is assigned) for the device which has a printer (inaccessible as no printer is attached) and a 'web' folder which has a link to the web interface and no write permissions.

To rectify this I've tried:
No matter what I seem to try I can not get the unit to reinitialise the disks or give me the original setup options, the 'best' Ive got is in 1.03 it gives a warning at boot if bays are not filled sequentially (ie. only one disk in bay 2/3/4) and asks me to shutdown.

Any help would be greatly appreciated.

Title: Re: Force Format
Post by: ivan on February 15, 2016, 06:57:51 AM
After you formatted the disks did you use the web UI to create users/groups?  Did you turn on SMB/CIFS and give shares to it?  Have you turned on the FTP server, assigned users and, if so, can an FTP client see those shares?

With two disks formatted as standard disks you will have Volume_1 and Volume_2, these are created at the time of formatting.
Title: Re: Force Format
Post by: pondandinio on February 15, 2016, 07:24:37 AM
Yes, when I couldn't see volume_1 on the network I created a user and a group without issue, however I couldn't turn on SMB/FTP as the option(s) was greyed out, that's when I started troubleshooting with the steps posted above.

currently I am troubleshooting with just a single disk to reduce variables, but as above, the NAS doesnt give me an option to format/initialise the disk in order for there to be a usable volume.
Title: Re: Force Format
Post by: ivan on February 15, 2016, 12:36:59 PM
Next question, have you tried a factory reset by holding down the reset button for more than 5 seconds.  Doing this is the best way to clear any old configuration data in ROM.

When you say the SMB and FTP sections are greyed out are they the only sections under the 'Advanced' tab of the web UI that are greyed out?  Do you see all 12 items down the left hand side of the page starting with RAID and ending with Logout? 

Sorry to ask all these questions but in all the years we have been installing/setting up D-Link nas boxes for ourselves and our clients I have never seen anything on the 'Advanced' tab greyed out.  I have heard of problems with things like save settings but they have all been solved by using another browser so I suppose I should ask what browser are you using to access the web UI?
Title: Re: Force Format
Post by: pondandinio on February 16, 2016, 03:08:47 AM
Don't worry about all the questions, its expected. I didn't think it was going to be simple given all the posts I've read. Thanks for persevering.

I've tried two resets, one as you describe (hold the reset button in for 5+ seconds whilst the unit it powered on) and wait for it to reboot as well as holding the reset button in whilst powered off, powering on whilst still holding the reset button, only releasing the reset button 10 seconds after its finished booting (no idea if that's a legitimate reset but I found it via Google and gave it a try).

With portions being grey out, it is the various buttons in the pages which are greyed/disabled rather than the tabs/sections themselves. I will grab some screenshots when I can. I've tried in two browsers, Firefox (44.0.2) and Edge, I haven't tried it in Chrome.

The main issue is that I'm not given an option to format an inserted disk and no options or disk info appears in the raid section (assuming this is important in regard to formatting (new) disks) so turning on/off features or buttons being greyed out is probably due to this issue
Title: Re: Force Format
Post by: ivan on February 16, 2016, 11:36:41 AM
Thanks for persevering
  No problem, to a certain extent it gives me something to think about as I sit in 'mission control' checking all the clients backups arrive safely, besides which I like helping people and that was the main part of starting the business 25 odd years ago.

The fact you can't see any disks does point to a possible cause of the problem and also leads to the next question.  Are the disk/s you are using virgin disks or have they been formatted before?  If they have been formatted before with a windows or linux file system the nas firmware will not allow them to be seen just in case there is important data on them (I know but some people do try to format disks with backup data).  If that is your situation then you need to use the disk manufacturers disk tools and a USB/SATA caddy or adapter to reset them to factory conditions.  If they are brand new disks we need to start looking at the nas itself.
Title: Re: Force Format
Post by: pondandinio on February 16, 2016, 12:24:08 PM
Checked in additional browsers, now tried FF, Chrome, Edge, IE11, Safari (Mac/iPhone/iPad), FF/Chrome (Android), all behave the same, like the picture here (http://www.cpond.co.uk/images/misc/dns343.png):

I had tried the caddy approach with the disks but its been via windows, i might give gparted a try as they are preused disks (however they were preused disk on the very first boot when it gave me the option to format them)

Title: Re: Force Format
Post by: ivan on February 16, 2016, 03:29:41 PM
Help may be at hand especially since you know haw to use a USB/SATA caddy.

Go to http://hobbes.nmsu.edu/h-browse.php?dir=/pub/incoming/ (http://hobbes.nmsu.edu/h-browse.php?dir=/pub/incoming/) and download dfsee131.zip.  this is a very powerful tool for working on disks, It was originally for use with the OS/2 operating system but the author has extended it so it can be used with windows, Linux, Mac and DOS.  The zip has all 5 versions in it (it is our tool of first use when we encounter disk problems - we use OS/2).  Use it in the 'Expert' mode (found under edit drop down menu).

Plug in the usb caddy and then start the version of the program for your OS.  You will get a list of the disks on your system and any usb disks that are plugged in.  Note what the usb disk is called because that is the disk you will be working on.  It will also tell you what file system it is formatted with.  Now you need to use the Mode-FDISK menu, scroll down to Partition table operations, click, select New MBR code ERASE tables, click and select the usb caddy drive (be very careful and double check that you have the correct disk).  Doing this will return the disk to its factory state and should allow you to format it in the nas.


Edit:  One thing I do note from your screen grab is that the drive is running hot.  If we see any SATA drive running above 50 degree C we start to worry.
Title: Re: Force Format
Post by: pondandinio on February 16, 2016, 04:20:44 PM
yeah the drives were getting rediculously hot in there, it was on my list of concerns after I eventually got it working.

Tried unassigning the partition in gparted, no joy, then I used a program to zero the disk as thats how it was before i put it into the NAS, However now the thing wont spin up any disk (physically) inserted into slot 1 or 2, spins up normally in slot 3 or 4 and in the caddy still. A quick glance at the backplane board in the NAS doesnt show anything obvious nor is there a distinctive smell of fried electronics, the SATA pins look normal. I guess ill take it apart tomorrow and check the other side of the board for hardware failure...

Edit: Just as I posted the disk started up (typical) still wont let me format it though. will give DFSee a try tomorrow
Title: Re: Force Format
Post by: pondandinio on February 17, 2016, 02:21:17 AM
I used DFSee as suggested, reset the NAS, put the drive in and booted. Disk span up on boot and the NAS booted without error, still doesn't give me the option to format the disk. Repeated the process with one of the other spare disks I had, no joy. Now its back to waiting about 10 mins before it spins the disk(s) up.

Whilst I was looking in the unit I noticed a coin battery on the board, what function does this serve? Is it simply for the RTC or does it keep the ROM powered? I guess there wouldn't be much harm in reseating it (or replacing it)?

Quote from: iFixit DNS-323 Teardown
Don't remove the battery as this could lead to time loss, some basic (board-level) settings, and unwanted resets.

Edit: Having spoken to the friend who donated this to me, he tells a similar tale of formatting issues so I guess the unit was faulty from day one, shame its way outside of its warranty
Title: Re: Force Format
Post by: ivan on February 17, 2016, 07:49:01 AM
From your added description it does sound like a hardware problem that could range from a simple dry solder joint, which can give intermittent switching signals, to a temperature sensitive component to one of the LSI chips not working to specification.  Only the dry joint is simple to find using a good magnifying glass.

Think of the battery having the same function as the one on a motherboard that keeps the settings of the bios alive - take it out and you lose the settings, same here.
Title: Re: Force Format
Post by: pondandinio on February 18, 2016, 03:22:53 AM
Just for sanity's sake I tested all the steps with a completely separate disk borrowed from another friend which was manufactured more recent, all the same issues presented themselves. Its rather frustrating and perplexing that it let me format once but never again which leaves a lingering thought and hope that there's some way to fix it.

I will take the NAS apart at the weekend when I have a bit more time and check for dry solder joints but soldering isnt one of my strong suits! Beyond that my circuitry knowledge is almost zero which brings things to a bit of dead end.

Thank you ever so much Ivan for all your help, tips and ideas,