D-Link Forums

D-Link IP Cameras for Home => DCS-2630L => Topic started by: jon_ak on December 05, 2015, 08:13:42 PM

Title: Sending Email Notification Problems
Post by: jon_ak on December 05, 2015, 08:13:42 PM
My DCS-2630L camera refuses to send email notifications.  I have tried using a gmail account and went as far as opening a outlook.com account.  Gmail server was set to smtp.gmail.com on port 465 using ssl-tls, tried 587 also.  Outlook.com server was set to smtp-mail.outlook.com on port 587 using ssl-tls.   I tried using each port with StartTLS also and still no good.  This camera used to send notifications when I first installed it allbeit with a lot of trouble.  I had to do a factory reset due to mistakenly setting the allowed access list to deny when I was entering a IP address.
Title: Re: Sending Email Notification Problems
Post by: Hard Harry on December 05, 2015, 08:21:11 PM
Do you have outbound set to use authentication? Also, what ISP are you on? Last, is a PC able to send email if a client is configured in the same way?
Title: Re: Sending Email Notification Problems
Post by: jon_ak on December 05, 2015, 08:58:51 PM
Do you have outbound set to use authentication?
There is no place in the camera configuration to set authentication such as would be found in an email client, only the protocol ssl-tls or StartTls.  Is there supposed to be this setting?

Also, what ISP are you on?
I'm in Hawaii on HawaiianTel

Last, is a PC able to send email if a client is configured in the same way?
I setup outlook.com in thunderbird and in the office version of outlook using port 587 with StartTLS and it worked fine.
Title: Re: Sending Email Notification Problems
Post by: Hard Harry on December 05, 2015, 11:52:38 PM
Could you take a screenshot of the configuration for review? You can blur out anything personal.
Title: Re: Sending Email Notification Problems
Post by: jon_ak on December 06, 2015, 07:57:02 AM
i do not have the option to attach a file in the "attachments and other options" selection.
Title: Re: Sending Email Notification Problems
Post by: FurryNutz on December 06, 2015, 07:59:01 AM
Might of some help:
http://forums.dlink.com/index.php?topic=63536.0 (http://forums.dlink.com/index.php?topic=63536.0)

Adding Screenshots In A Post (http://forums.dlink.com/index.php?topic=58120.0)
Title: Re: Sending Email Notification Problems
Post by: jon_ak on December 06, 2015, 09:27:19 AM
Thanks for all the input.  I discovered what is causing the error.  When configuring the camera, I activated the IP filter, entered the IP addresses that I use to enable remote viewing which apparently caused the snapshot notification to fail.  With the IP filter disabled, snapshot notification worked first time.  This is somewhat puzzling as i thought the IP filtering was only supposed to allow/deny specific addresses/subnets etc from accessing the camera.  I also discovered that with IP filtering enabled and using the mydlink app, the camera is listed as offline even though the IP address of the tablet is in the allow list of IP filtering.
Title: Re: Sending Email Notification Problems (RESOLVED)
Post by: FurryNutz on December 07, 2015, 06:32:22 AM
Glad you got it figured out. Enjoy.