D-Link Forums

The Graveyard - Products No Longer Supported => D-Link Storage => ShareCenter® Add-on Applications => Topic started by: koadrian on September 02, 2015, 08:01:12 PM

Title: [320L] Funplug 0.7
Post by: koadrian on September 02, 2015, 08:01:12 PM
FunPlug won't install.
Problems Resolved:
- Fixed the following Security vulnerability
o Directory traversal found under /mnt directory

is this have a cause? fixing /mnt directory fun_plug won't detect?

if [[ ! -d /mnt/HD_a2 ]]; then
Title: Re: [320L] Funplug 0.7
Post by: speedyarmadillo on October 04, 2015, 03:03:38 AM
It appears as though D-Link no longer supports fun_plug as of firmware version 1.06b03, so the problem is intentional by D-Link.

The info below is a bit verbose, but I spent countless hours trying to get fun_plug to work before spending even more hours searching until I unraveled this mess so I am including the info here for completeness in case it helps anyone else.

D-Link did not initially publish that the fun_plug feature was removed, but it is now starting to appear in some release notes as D-Link is retroactively inserting the information (for instance, as of 2015-09-09 there were no release notes on any D-Link website saying fun_plug support was removed from 1.06b03 (on that date I had checked USA, Canada, UK, and Russian D-Link sites and there was no mention of it, even in forums).

I first saw reference to it 2 days ago in a Russian forum where a poster said "Fun_plug script was removed and no longer to be supported" (at "http://forum.ixbt.com/topic.cgi?id=109:95-56" a poster on "25.09.2015 09:38" says this).

That prompted further searching and I finally found that same exact phrase in the D-Link Canada release notes, yet those release notes were not there before (ftp://ftp.dlink.ca/PRODUCTS/DNS-320L/DNS-320L_REVA_RELEASENOTES_1.06.PDF).  This D-Link Canada website shows the release date as 2015-06-30, but the release notes say 2015/07/28 release date, yet I know they were on on the website as of 2015-09-09, so although the dates are very suspect, at least the release notes do mention that fun_plug is no longer supported (http://support.dlink.ca/ProductInfo.aspx?m=DNS-320L).

D-Link USA's website STILL TODAY shows NO MENTION of fun_plug functionality removal (ftp://ftp2.dlink.com/BETA_FIRMWARE/DNS-320L/REVA/DNS-320L_REVA_FIRMWARE_PATCH_NOTES_1.06.B03_EN.PDF).
The D-Link USA website shows the release date as 2015-08-06, but the release notes say 2015/04/01 release date and those release notes make NO MENTION of the removal of the fun_plug functionality, but since the 1.06b03 firmware binary file you download at D-Link USA is identical to the one you download from D-Link Canada, if one has the functionality removed then so does the other (both binaries have an MD5 hash of "0216D3AFF50FF31545F160A0226EDE3F" and so are identical).

D-Link UK's website today shows the latest fw as 1.04b12 which it says was released 2015-05-11, so that makes the UK 1.04 released AFTER everyone else had 1.05 already released, and puts the D-Link UK website 2 versions behind as their most recent firmware available (http://www.dlink.com/uk/en/support/product/dns-320l-sharecenter-2-bay-cloud-storage-enclosure).

D-Link Russia's ftp server today lists 1.05b06 as latest fw and is dated 2015-08-04, but release notes say 2015/07/16 release date (http://ftp.dlink.ru/pub/NAS/DNS-320L/Firmware/).  In the past I had noticed Russia publishes firmware earlier than others in some cases, but this is not true for 1.06b03.

Basically the official published dates are all over the place, and can't be trusted.

This is rather frustrating being as the fun_plug functionality was the reason I bought my 4th D-Link NAS, but now I am forced to either use old firmware with known security holes, or new fw 1.06 with no security holes but now no fun_plug.

So if anyone knows differently that fun_plug support is coming back, or if there is a work around, please chime in, otherwise it is dark days ahead for our D-Link NASes.
Title: Re: [320L] Funplug 0.7
Post by: philphil61 on October 04, 2015, 05:54:45 AM
I all honesty, and although I don't use funplug, I think their decision is corporate suicide.

I've had my first NAS (a 320L) almost 1 year.  I've discovered that the Google Drive function, clearly advertised as a function, has never worked.  I've had issues with updates to firmware (not forgetting the java fiasco) and addons.

When answering questions on shopping sites I give an honest reply and unfortunately I cannot recommend this product unless you just want a basic LAN NAS

When answering questions on forums I try to be as honest as possible.

You'd have thought that, with the total numbers of different devices sold around the world, support would be at it's highest standard but how many companies supplying electronic devices release untested firmware.  Yes security patches are expected but failure of the hardware to function.. wtf

@ speedyarmadillo re firmware update to 1.06  see my comment here posted 29th Sept   http://forums.dlink.com/index.php?topic=63519.msg259717#msg259717 (http://forums.dlink.com/index.php?topic=63519.msg259717#msg259717)

Title: Re: [320L] Funplug 0.7
Post by: gryzor on October 04, 2015, 06:35:53 AM
This is such a shame on D-Link's part. Just as I was going to try and install JDownloader (from what I understand it does need Funplug). At least I came upon your post before I dove into it, so many thanks for the (bad) news!

By the way, what with all the versions and dates and whatnot, can anyone point to a FW with which Funplug definitely works?

Title: Re: [320L] Funplug 0.7
Post by: philphil61 on October 04, 2015, 08:47:05 AM
I think all firmware prior to v1.06

I'm certain but as I've but never tried it v1.05 worked.
Title: Re: [320L] Funplug 0.7
Post by: gryzor on October 04, 2015, 08:48:11 AM
Thanks, will start trying soon, hopefully...
Title: Re: [320L] Funplug 0.7
Post by: sbrbot on August 17, 2016, 04:51:49 AM
I was successfuly using 320L with firmwares from 1.00 up to 1.04 with fun_plug (and many installed apps on it like TransmisssionBT, MiniDLNA, Twonky, etc.) for several years. Without it I couldn't live because NAS' internal BT client and Media server are disaster.

Not knowing that functionality with fun_plug was removed from firmware 1.06, I've recently upgraded my NAS firmware from 1.04 to 1.06 and afterwards to latest 1.08. Soon I realized that fun_plug does not work any more, but also found out that now there's plenty of 3rd party add-ons already available for easy installation (thanks to vtverdohleb). With fun_plug I used slacker CLI tool (over SSH) for apps installation but now it's much convenient to install apps like add-ons through NAS web UI.

I have to say that I was very satisfied with fun_plug but there's now better solution. Also, IFAIK D-Link never announced official existance of fun_plug 'functionality' neither ever gave the support for it. fun_plug was discovered by some NAS sw enthusiasts who reverse engineered D-Link software and discovered this and used it for enriching NAS with additional apps and functionalities.

So, we cannot complain, D-Link as never announced the apearance of fun_plug functionality as never announced it's disapearance.