D-Link Forums

The Graveyard - Products No Longer Supported => DIR-655 => Routers => Beta Code! => Topic started by: dellwo on December 13, 2014, 07:02:04 PM

Title: 2.12.B01_NA Firmware
Post by: dellwo on December 13, 2014, 07:02:04 PM
Has anyone tried the 2.12.B01 firmware?
What are the changes?
(DIR-655_REVB_FIRMWARE_2.12.B01_NA_BETA.ZIP  11/19/2014)
Title: Re: 2.12.B01_NA Firmware
Post by: dellwo on December 13, 2014, 07:44:05 PM
I went ahead and installed for S***s and Giggles.
No issues so far. Who knows, it might fix something.
Title: Re: 2.12.B01_NA Firmware
Post by: FurryNutz on December 14, 2014, 12:41:36 PM
Link>Welcome! (http://forums.dlink.com/index.php?topic=48135.0)


Where are you getting v2.12 from?
Title: Re: 2.12.B01_NA Firmware
Post by: dellwo on December 14, 2014, 05:03:00 PM
I got it off their FTP site (which I can't seem to access today).

I am in Northwest United States.
(edit: oh, I see you are in Idaho. I'm in Spokane)

Regards, Joe

Link>Welcome! (http://forums.dlink.com/index.php?topic=48135.0)

  • What region are you located?

Where are you getting v2.12 from?
Title: Re: 2.12.B01_NA Firmware
Post by: FurryNutz on December 14, 2014, 05:10:12 PM
Thanks, I'll ask about it and see. I know there was one bug in TIME that needed to be fixed, maybe this fixes it. I'll ask and report if I get any information.



I got it off their FTP site (which I can't seem to access today).

I am in Northwest United States.
(edit: oh, I see you are in Idaho. I'm in Spokane)

Regards, Joe

Link>Welcome! (http://forums.dlink.com/index.php?topic=48135.0)

  • What region are you located?

Where are you getting v2.12 from?
Title: Re: 2.12.B01_NA Firmware
Post by: FurryNutz on December 25, 2014, 11:40:26 AM
Still waiting on official word however it was mentioned that v2.12 could be in regards to this:
http://securityadvisories.dlink.com/security/publication.aspx?name=SAP10048 (http://securityadvisories.dlink.com/security/publication.aspx?name=SAP10048)
Title: Re: 2.12.B01_NA Firmware
Post by: dellwo on December 25, 2014, 01:35:53 PM
Interesting, thanks.
For the record, I haven't had any new issues with it.
ftp2.dlink.com/PRODUCTS/DIR-655/REVB/DIR-655_REVB_FIRMWARE_2.12.B01_NA_BETA.ZIP (ftp://ftp2.dlink.com/PRODUCTS/DIR-655/REVB/DIR-655_REVB_FIRMWARE_2.12.B01_NA_BETA.ZIP)

Still waiting on official word however it was mentioned that v2.12 could be in regards to this:
http://securityadvisories.dlink.com/security/publication.aspx?name=SAP10048 (http://securityadvisories.dlink.com/security/publication.aspx?name=SAP10048)
Title: Re: 2.12.B01_NA Firmware
Post by: FurryNutz on December 25, 2014, 01:44:33 PM
Me either. It's currently running and working well.

Do you see any differences in the Time and Time Zone behavior? We are hoping that the prior bug that some users see on Rev B routers may have been fixed.  ::)

However, it's not recommended for use yet until D-Link officially posts it and posts information about it.

Any one interested in using it may, however we recommend that if your router is working well, don't fix it. I'll post more information soon as I get it.

Title: Re: 2.12.B01_NA Firmware
Post by: dellwo on December 25, 2014, 02:04:09 PM
I never bothered setting time since it was always wrong.

Just checked and the default was just some random time (Pacific), with NTP server disabled.

What should I test it with. NTP or manual?
Also, I was never sure if I should check DST (since neither worked before).
Title: Re: 2.12.B01_NA Firmware
Post by: FurryNutz on December 25, 2014, 02:12:40 PM
Test with NTP enabled for your time zone and DST enabled. I think +1?
See if the time keeps stable and correct...
Title: Re: 2.12.B01_NA Firmware
Post by: dellwo on December 25, 2014, 02:19:33 PM
Ok, time is correct after reboot.
As I recall, it would change later, so I'll let you know.

Test with NTP enabled for your time zone and DST enabled. I think +1?
See if the time keeps stable and correct...
Title: Re: 2.12.B01_NA Firmware
Post by: FurryNutz on December 25, 2014, 02:24:43 PM
Yes, keep us posted.

Happy Holidays.  ;)
Title: Re: 2.12.B01_NA Firmware
Post by: FurryNutz on January 02, 2015, 02:40:25 PM
So a about a week and half later after returning from visiting with Holiday family, the 655 time seems to be correct and current. Nothing off. Maybe they fixed the TIME issue. Can you confirm your findings?

Moutain TZ, DST enabled, Offset +1 and Enable NTP Server: ntp1.dlink.com are my settings.
Title: Re: 2.12.B01_NA Firmware
Post by: dellwo on January 03, 2015, 06:27:31 PM
It kept the time even after rebooting.

Thanks, Joe
Title: Re: 2.12.B01_NA Firmware
Post by: FurryNutz on January 03, 2015, 06:28:15 PM
Good to hear. Seems to be fixed.  ;)
Title: Re: 2.12.B01_NA Firmware
Post by: FurryNutz on January 04, 2015, 10:14:06 AM
Hows the wireless doing for you? Any issues seen here?

It kept the time even after rebooting.

Thanks, Joe
Title: Re: 2.12.B01_NA Firmware
Post by: FurryNutz on January 04, 2015, 03:38:28 PM
I'm now noticing this again:  :(
http://forums.dlink.com/index.php?topic=48026.msg177044#msg177044 (http://forums.dlink.com/index.php?topic=48026.msg177044#msg177044)

Anyone else seeing this after doing some configurations and then rebooting and seeing contact network activity on a external network swtich? It eventually stops after 10-15 mins I think. I didn't see this on v2.11.  :-\ Happens on WiFi too.
Title: Re: 2.12.B01_NA Firmware
Post by: FurryNutz on January 29, 2015, 07:37:42 AM
This beta also fixes this:  ::)
http://securityadvisories.dlink.com/security/publication.aspx?name=SAP10048 (http://securityadvisories.dlink.com/security/publication.aspx?name=SAP10048)
Title: Re: 2.12.B01_NA Firmware
Post by: FurryNutz on March 18, 2015, 04:51:04 PM
I think the DST issue is still present in v2.12. Since DST kicked off this month, I think this is when it appears. I cant get accurate time zone for my zone (MST) as it's always an hour behind. No matter what Offset I use with NTP server enabled. I didn't see this issue before DST kicked off so I presume there is a problem with DST on this model router when DST kicks off in March.
Title: Re: 2.12.B01_NA Firmware
Post by: FurryNutz on May 24, 2015, 11:20:30 AM
FYI: NetUSB and suspected vulnerability:
http://forums.dlink.com/index.php?topic=56542.msg254644#msg254644 (http://forums.dlink.com/index.php?topic=56542.msg254644#msg254644)
Title: Re: 2.12.B01_NA Firmware
Post by: mikhoul on June 02, 2016, 08:08:45 AM
Hi,

I have a DIR-655 Hardware Version: B1  Firmware Version: 2.03NA

It since a few years I did not use it since I had a DSL Router all-in-one, but since few days I'm back on Cable 15Mbps/5Mbps (Canada)

In my set-up I have Wired: 2-3 Windows computers, Network Printer, PAP2T VOIP, Modem TC-4300 and GigaSwitch Wireless: Tablet and some phones ;-) 

I browsed a lot the forum to see the best options for the config settings firmware but I found it confusing a little bit.

I'd like to know your opinion  about the best config I could set for the DIR-655.

First the Firmware, which version is "the best" between V2.11 and V_2.12.B01 ?

From my understanding the main difference is the Exploit     CVE-2014-9518  being fixed, but I'm not sure if this release has introduced new bugs or not ?


Also from what I read again I understand there is some limitations in the Upload Speed under certain circumstance but it's not clear to me when ?
It seem related to QoS Engine but I'm not sure about the implications with my VOIP landline ?

Here's my config now:

(http://i.imgur.com/AmXkQXg.png)
 

I see also always in Forum that it'S better to set some settings like WAN speed to fixed instead of auto and I'd like to have your advice on those custom settings.


Best Regards !  ;D
Title: Re: 2.12.B01_NA Firmware
Post by: FurryNutz on June 02, 2016, 10:42:56 AM
Link>Welcome! (http://forums.dlink.com/index.php?topic=48135.0)


Internet Service Provider and Modem Configurations

The main problem with early DIR series routers was that D-Link put in a 2Mb UPLink soft cap in QoS. Though the QoS still works, speed testing and operation will be limited to 2Mb, even if your ISP UPLink is higher, when enabled on the router, the UPLink will be capped at 2Mb. This is seen on most early to mid model DIR series routers. Once the DIR-645 came out, they capped it a 20 or 50Mb on later models, now days I think it's up to 100Mb and maybe beyond.

I think the last time I tested my Rev B was with v2.12 and didn't see much if any differences.



Hi,

I have a DIR-655 Hardware Version: B1  Firmware Version: 2.03NA

It since a few years I did not use it since I had a DSL Router all-in-one, but since few days I'm back on Cable 15Mbps/5Mbps (Canada)

In my set-up I have Wired: 2-3 Windows computers, Network Printer, PAP2T VOIP, Modem TC-4300 and GigaSwitch Wireless: Tablet and some phones ;-) 

I browsed a lot the forum to see the best options for the config settings firmware but I found it confusing a little bit.

I'd like to know your opinion  about the best config I could set for the DIR-655.

First the Firmware, which version is "the best" between V2.11 and V_2.12.B01 ?

From my understanding the main difference is the Exploit     CVE-2014-9518  being fixed, but I'm not sure if this release has introduced new bugs or not ?


Also from what I read again I understand there is some limitations in the Upload Speed under certain circumstance but it's not clear to me when ?
It seem related to QoS Engine but I'm not sure about the implications with my VOIP landline ?

Here's my config now:

(http://i.imgur.com/AmXkQXg.png)
 

I see also always in Forum that it'S better to set some settings like WAN speed to fixed instead of auto and I'd like to have your advice on those custom settings.


Best Regards !  ;D
Title: Re: 2.12.B01_NA Firmware
Post by: mikhoul on June 02, 2016, 02:13:58 PM
I'm now noticing this again:  :(
http://forums.dlink.com/index.php?topic=48026.msg177044#msg177044 (http://forums.dlink.com/index.php?topic=48026.msg177044#msg177044)

Anyone else seeing this after doing some configurations and then rebooting and seeing contact network activity on a external network swtich? It eventually stops after 10-15 mins I think. I didn't see this on v2.11.  :-\ Happens on WiFi too.

What was this bug with 2.12B01 ?   Was it a real bug ?

I'm not sure I understand the signification after reading the link.

Is this affect the performance, It is better to use 2.11NA or 2.12B01 is the one to have since it fix Exploit CVE-2014-9518 ?

Give me some insight about it please !


Regards  :)
Title: Re: 2.12.B01_NA Firmware
Post by: FurryNutz on June 03, 2016, 06:46:07 AM
Do you have a link to this CVE issue?

Reason is to get more details and information from you so we have a better idea of your system and configurations.

You can load v2.12 and see how it works for you, if it doesn't then you can always reload v2.11.

The constant network activity was seen as far back as v2.08 and I think I was the first to observe this and post about it. I was thinking that it maybe ISP modem related possibly depending on Mfr. I only use Motorola modems so I don't know for sure. If you power up the router with out the ISP modem connected, I believe you don't see the constant activity. Only when it's connected does it happen then goes away after 10-15 minutes. It's an odd behavior.

And if you still using v2.03 and the router is working well, doesn't mean you have to up grade either.  ;)
Title: Re: 2.12.B01_NA Firmware
Post by: mikhoul on June 03, 2016, 07:36:09 AM
Do you have a link to this CVE issue?

Reason is to get more details and information from you so we have a better idea of your system and configurations.

You can load v2.12 and see how it works for you, if it doesn't then you can always reload v2.11.

The constant network activity was seen as far back as v2.08 and I think I was the first to observe this and post about it. I was thinking that it maybe ISP modem related possibly depending on Mfr. I only use Motorola modems so I don't know for sure. If you power up the router with out the ISP modem connected, I believe you don't see the constant activity. Only when it's connected does it happen then goes away after 10-15 minutes. It's an odd behavior.

And if you still using v2.03 and the router is working well, doesn't mean you have to up grade either.  ;)


Here's the link to the CVE: http://www.cvedetails.com/cve/CVE-2014-9518/  (http://www.cvedetails.com/cve/CVE-2014-9518/)    ;)

Could you tell me the step to replicate the "constant activity" on DIR-655 I will try to replicate them with my modem TC4300.
Does I need to make special action to make it appear ?

2.03 seem to work well but I would prefer to go with V2.12 since there is no vulnerability especially if there is no performance loss VS 2.11  8)
Title: Re: 2.12.B01_NA Firmware
Post by: FurryNutz on June 03, 2016, 07:46:31 AM
I believe after the FW is loaded and you do a factory reset, set up the router configuration and I think set firewall SPI to end point independent and save settings which should cause a reboot, after it reboots you may see the activity kick off. Something in configuring the router and doing a reboot does this if I remember right.
Title: Re: 2.12.B01_NA Firmware
Post by: FurryNutz on January 05, 2018, 12:27:29 PM
http://forums.dlink.com/index.php?topic=72893.0 (http://forums.dlink.com/index.php?topic=72893.0)

Do you have a link to this CVE issue?

Reason is to get more details and information from you so we have a better idea of your system and configurations.

You can load v2.12 and see how it works for you, if it doesn't then you can always reload v2.11.

The constant network activity was seen as far back as v2.08 and I think I was the first to observe this and post about it. I was thinking that it maybe ISP modem related possibly depending on Mfr. I only use Motorola modems so I don't know for sure. If you power up the router with out the ISP modem connected, I believe you don't see the constant activity. Only when it's connected does it happen then goes away after 10-15 minutes. It's an odd behavior.

And if you still using v2.03 and the router is working well, doesn't mean you have to up grade either.  ;)


Here's the link to the CVE: http://www.cvedetails.com/cve/CVE-2014-9518/  (http://www.cvedetails.com/cve/CVE-2014-9518/)    ;)

Could you tell me the step to replicate the "constant activity" on DIR-655 I will try to replicate them with my modem TC4300.
Does I need to make special action to make it appear ?

2.03 seem to work well but I would prefer to go with V2.12 since there is no vulnerability especially if there is no performance loss VS 2.11  8)