D-Link Forums

The Graveyard - Products No Longer Supported => Routers => DIR-880L => Topic started by: StephenM71 on December 10, 2014, 05:25:20 AM

Title: ICMP blocked
Post by: StephenM71 on December 10, 2014, 05:25:20 AM
Hi

Can anyone tell me how to allow ICMP packets through the DIR880L firewall?

I've looked through the UG and can't find any information on this.
Title: Re: ICMP blocked
Post by: FurryNutz on December 10, 2014, 06:53:59 AM
Link>Welcome! (http://forums.dlink.com/index.php?topic=48135.0)



Internet Service Provider and Modem Configurations

Is there a problem with not getting ICMP packets? Please explain your configuration and set up.
Title: Re: ICMP blocked
Post by: StephenM71 on December 10, 2014, 07:22:21 AM
Firmware Version: 1.02
Hardware A1

Location UK.

My home network setup is:-

DIR-880L connected to ISP provided Huawei HG612 modem.

I am trying to ping the DIR-880L from a PC which is not on my home network. There is no response (presumably because ICMP is being blocked)

Previous routers I have had have a setting such as 'Enable WAN ping respond' which allows you to do this.

This is a good feature to have as it allows you to monitor the quality of your connection.

I can't find a way to do this on this router.
Title: Re: ICMP blocked
Post by: FurryNutz on December 10, 2014, 07:33:29 AM

Also Virtual Server or Port Forward configurations may need to be configured as WAN Ping Respond may not be a feature on this model router.
Title: Re: ICMP blocked
Post by: FurryNutz on January 12, 2015, 10:44:22 AM
Any status on this?  ???

Firmware Version: 1.02
Hardware A1

Location UK.

My home network setup is:-

DIR-880L connected to ISP provided Huawei HG612 modem.

I am trying to ping the DIR-880L from a PC which is not on my home network. There is no response (presumably because ICMP is being blocked)

Previous routers I have had have a setting such as 'Enable WAN ping respond' which allows you to do this.

This is a good feature to have as it allows you to monitor the quality of your connection.

I can't find a way to do this on this router.
Title: Re: ICMP blocked
Post by: StephenM71 on January 22, 2015, 09:06:10 AM
Apologies for not getting back to you.

Is does appear to be the case that WAN ping response is not a feature of the router which is a bit of an oversight I think.

The only way to do this with the router is to route the ICMP traffic through to a PC and get the PC to respond.

This means if the end user want's to do something like quality monitoring of their broadband link using a website which continuously pings their IP then they must route the traffic and leave their PC on all the time. :(
Title: Re: ICMP blocked
Post by: StephenM71 on January 22, 2015, 09:26:10 AM
In theory a Virtual Server should work but when I enter a protocol of 'Other' and the number '1' for ICMP I get a protocol of 'null' in the table so It doesn't seem to work.

Port forwarding will not work as ICMP is a protocol.

As far as I can see there is no way to get this to work using this router.

I will have to switch back to a cheap old router I have to so these tests.
Title: Re: ICMP blocked
Post by: FurryNutz on January 22, 2015, 09:36:07 AM
Have you set up a firewall rule for the port(s) that you need as well as using Virtual Server?

Title: Re: ICMP blocked
Post by: StephenM71 on January 22, 2015, 11:16:33 AM
The windows firewall is setup to allow ICMP echo packets through.

I can't create a rule for ports in either the router or the windows firewall because ICMP is a protocol, it is not TCP/IP or UDP encapsulated.

My modem is a modem not a router. There are not 2 routers on my LAN.

I'll go back to using the old cheap router to perform these tests and hope DLINK decide to add a WAN ping feature in the future.
Title: Re: ICMP blocked
Post by: FurryNutz on January 22, 2015, 02:14:10 PM
What happens if you try putting the PC in the routers DMZ?
http://en.wikipedia.org/wiki/ICMP_hole_punching (http://en.wikipedia.org/wiki/ICMP_hole_punching)
http://en.wikipedia.org/wiki/ICMP_tunnel (http://en.wikipedia.org/wiki/ICMP_tunnel)

Have you disabled DNS Relay?

I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this. We find that phone contact has better immediate results over using email.
Let us know how it goes please.
Title: Re: ICMP blocked
Post by: StephenM71 on February 02, 2015, 02:33:42 PM
I contacted support and they said that the WAN ping enable feature is not part of the feature set of this router but it should be allowed by default.

I have checked many times and I cannot ping the router from the WAN. LAN yes, WAN no.

When I swap in my cheap old router I can ping just fine so my ISP are not blocking ICMP packets.

This is a bit of an oversight on D-Links part in my opinion.
Title: Re: ICMP blocked
Post by: FurryNutz on February 02, 2015, 06:43:36 PM
Thanks for the feed back and letting us know what D-Link said. Did you ask them if they were going to fix it in the next update?

Hopefully it will be fixed on next update.
Title: Re: ICMP blocked
Post by: FurryNutz on September 27, 2016, 11:34:34 AM
Not sure if this has been address in the most current FW version or not.
http://forums.dlink.com/index.php?topic=65585.0 (http://forums.dlink.com/index.php?topic=65585.0)

Care to try?  ???